Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 11 Vote(s) - 4.64 Average
  • 1
  • 2
  • 3
  • 4
  • 5
(UEFI) Dell XPS 15z L511z modded BIOS - and HOWTO
@kasar
I see, so there is no easy way to flash foreign bios to the system.... and I've read post you had issue with usb 3.0 and most likely would had issue with GPU too... it's shame you didn't turn RAID for testing propose.
Making my own programmer I would probably ended up with dead laptop Smile)) 
Anyway if you going to further modify l502x bios with l702x bios modules, I'm always volunteer to try it on my system, thanks. 
find
quote
mmm, well, you can try to flash by using the standard way of flashing the bios.
however, it would have more chances of even not boot.

also you would have no way of recover from a bad flash if the recovery cd rom I made doesnt work for crossflash issues.

I'm glad I made the external programmer and a global flash backup before going into advanced tests, else I would have a brick for sure.

well I had when my bios chip for phisically damaged, anyway I easly fixed it by ordering more of the same chips and reprograming them.

that basically turned back my laptop into working status.

mmm, relating raid, I basically dont know exactly where to start, I already modded the advanced setup .efi so RAID can be selected from there, and also tried to replace the RAID oprom module not sure if you tested it,or if it had some kind of partial success.

relating any other test from that I'm not sure what modules I can try replacing.

follow_me talked something about brabella's raid module, but I cant find it, if I could find it, I can try replace L502X's module with that one and test.
find
quote
You well prepared I see, with this level of experiments I would end up using my laptop as a cutting board. 
And yes I've tested that modded oprom you posted, nothing much changed...
Maybe @Brabbelbla can help with that RAID module then....
find
quote
Hi guys I'm not giving up Smile
So found some more info about our intel hm67 here:
http://www.win-raid.com/t19f13-Intel-EFI...dules.html
Seems it's a SataDriver maybe you guys can comment on that, can it help in our findings?
find
quote
srry for the delay, I got my laptop OS corrupted and I had to run some checks and diagnosis tools in order to get it back to working status without the need of format/reinstall

well, relating that, It seems interesting, anyway, while looking to it, it talk about reintegrate ffs files, I remember I tried that with the ICCoverclocking drivers but I had no luck Sad

maybe someone else can give us a hand with that?
find
quote
@determo13:
I don't believe there is some 'magic module' to port from the L702X BIOS to the L502X BIOS. I don't think there are code-wise differences relating RAID between them. I think your problem is indeed your SATA port layout. I remember @follow_me said that in RAID mode the drive in his ODD caddy would completely disappear in the BIOS. So my guess is that the code determining whether the OROM should get run thinks only one drive is present, and decides not to run it (tested that by disabling a SATA port, OROM doesn't run then). As said before, a way around it might be to force the OROM to load by writing a custom driver, but I have never done such a thing nor have the time to really try. Sorry. Better luck with @follow_me, maybe; he also wrote the shell enabler.

About the SataDriver you found, that is a proper UEFI driver instead of the legacy option ROM present in our BIOSes. I tried using it (findings: https://www.bios-mods.com/forum/Thread-U...9#pid70529, https://www.bios-mods.com/forum/Thread-U...7#pid70577) but never got it to work. I could try replacing a driver with a DXE dependency expression instead of SystemIsaFloppyDxe which did not, maybe it would affect the moment it gets loaded and magically fixes things. The flash device drivers are numerous, they have DXE dependencies, and as we only have two chips I could replace one of those, but I have to know which one. If that doesn't change things I could try to port PlatformPci from the Inspiron 7720 to our BIOS as I spotted a protocol GUID there that is published by the Intel SataDriver. Those things are for someone else to test, though, because I am getting a little cautious with my lappy. Crisis recovery doesn't work anymore and recently my screen stayed black a couple of bootups after trying one. Maybe @kasar could do that, having HW recovery.
find
quote
@brabbelbla

oh, why the recovery disk stoped working anymore?

well, I have also less time usually, I'm more focused in other stuff, anyway, I can do a dangerous test if required since I have advanced recovery options.

you guys can remember that almost since the begining I was the guy wich flashed weird stuff and did crazzy tests Big Grin

I can keep doing that while others keep being the main brains of the project Smile
find
quote
@kasar
Good to know you are willing to test Smile Any idea about the two chips present in the L502X/L702X?

And recovery just somehow stopped working. I can initiate the procedure, and it will read the capsule and set defaults, but it never gets past the splash screen, just resets. Had it way earlier, too, then it somehow magically fixed itself.
find
quote
two chips?

you mean the flash ones?

not sure about the L702X

bit for the L502X

as far I know the L502X have two main flash winbond chips

first one is the W25x40vsig wich is 512 kbit size

[Image: dsc00742aa.jpg]

I suspect this chip contains the EC region and that it save some configurations and minor stuff, since, I didnt focused on this flash chip since it didnt had the information I wanted to focus at, and also it was in a dificult place to desolder it or install a socket, as you can see it is really close to a bigger chip with really tiny legs, and with a normal soldering iron, it can create troubles if I accidentally touch those small legs/pins, so I dont have backup/dump from this chip or a way to access it.


the other chip is a W25Q32BV
wich is 4 mbit size

[Image: W25Q32BV-pinout.jpg]
[Image: bioschip.jpg]

wich store the descriptor, bios, ME, and maybe other stuff, this is the one I modded.

the EC one is probably the one from 512 kb, wich I didnt accesed yet, I'm almost sure the programmer pointed on this topic will be able to access it, but I have no backup of it


relating the recovery cdrom, if you are not using it on recovery, try change temporally from ahci to ide, that seemed to fix the blue screen from the portable windows.

remember to set it back to ahci after use the cdrom or your OS will probably complain.
find
quote
@Brabbelbla
Lets say its that ODD caddy thing doesnt work, But I cant see my main SATA device too, isnt it? Cant install OS on it etc....
Or Im missing something? I presume even in RAID mode I have to see my main hdd and be able too boot from it.
find
quote


Forum Jump:


Users browsing this thread: 20 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in