Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 11 Vote(s) - 4.64 Average
  • 1
  • 2
  • 3
  • 4
  • 5
(UEFI) Dell XPS 15z L511z modded BIOS - and HOWTO
(07-31-2016, 11:29 PM)neosaga Wrote: well thank you very much, I'll try with these commands, there is an option to keep the fan running?. for now use a recovery cd bios. and I leave it in v11, I had the v06 but even without uefi.

what differences exist between
.rar BIOS1_A12_SPEEDSTEP_UV_FULLMENUS_INTEL.rar (Size: 1.89 MB / Downloads: 885)
.rar BIOS1_A12_SPEEDSTEP_UV_FULLMENUS_INTELv2170_UCODE_029_PLOP.rar (Size: 1.89 MB / Downloads: 256)

I saw that changed the voltages and thought the bios came with Undervolting.

29/12 UPDATE BIOS MOD SUCCESSFUL! Added first mods for the 15z: undervolted video card, and upgraded to GT-525M GT-540M. Now need help to unlock BIOS features!

PD .It will be the problem? It was to use Winphlash.exe and Phoenix UEFI Winflash v1.5.66

to use the commands should I use? PHLASH.EXE ??
regards

Here's the command line:

winflash.exe /BIOS /EC /SA /BBL /CVAR <image.WPH>

the differences in those two files are the latest intel vbios (2170), the updated intel ucode (0x29) and the PLOP boot manager. What is undervolted is the Video card not the CPU (that is done in ME region and we haven't found a way to crack it yet)

The only option to keep the fan running is in windows under a specific FAN utility (@TimeWalker75 had written such an example). But I strongly suggest you open up the laptop and clean the fan as it commonly gets clogged with dust.
find
quote
Thanks for the reply!

Quote:Ah now I remember the A12 issue on the L502x; some people tried to replace the powermanagement.efi module from A11

So what can be done to correct this? Should I revert back to A11 ?
Is there any work around for this?

Quote:Some modules are interchangeable

Can you give me the Plop boot rom and a clue how to replace that? I'm really interested. No need to teach me how to mod, just tell me which module must be replaced.

Quote:Pleasure mate - glad to see this topic is still being used!

Yeah, when someone does good deeds, they'll continue to live in this world even if he leaves this world.
find
quote
(08-05-2016, 11:41 AM)Kpax7 Wrote: Thanks for the reply!

Quote:Ah now I remember the A12 issue on the L502x; some people tried to replace the powermanagement.efi module from A11

So what can be done to correct this? Should I revert back to A11 ?
Is there any work around for this?

Quote:Some modules are interchangeable

Can you give me the Plop boot rom and a clue how to replace that? I'm really interested. No need to teach me how to mod, just tell me which module must be replaced.

Quote:Pleasure mate - glad to see this topic is still being used!

Yeah, when someone does good deeds, they'll continue to live in this world even if he leaves this world.


Here's the link to the boot module:

https://www.plop.at/en/bootmanager/download.html

On A12 I'm not sure if there's any work being done on this at the moment. I think you'd best be downgrading to A11 as it seems to work fine. Good luck!


Sent from my iPad using Tapatalk
find
quote
Is there a setting to display over hdmi in bios as default?
find
quote
Thanks, but you forgot to mention which module should I replace with in the bios!!

And does the size difference make any troubles?
find
quote
(06-22-2015, 04:17 AM)jkbuha Wrote: Hi all - been a while since I've posted here as I've been focussing on a few other projects.

That said, something new to report. The Memory Configuration options in the unlocked BIOS work a treat. I've flashed new SPD timings on the DDR3 ram (using the paid version of Thaip***n) and successfully clocked the previous 1333 modules to 1600MHz. BIOS/OS and Benchmarks all validate the increase in speed (which is quite remarkable btw). Note of caution - you can brick the modules with incorrect SPD timings, but if you boot with a working RAM module and insert the faulty module whilst the OS is running, you can safely restore the working SPD settings.

Interesting now to see if I can clock vanilla 1333MHz modules to 1867 or better Smile

What memory module did you flash? and with which template?  I have the Hynix H5TQ2G83BFR-H9. And i am interested in flashing them @ DDR3 1600J profile.
find
quote
I really apreciate u guys work but i dont know even a single thing about bios modding, so can someone please upload the completely ready to flash bios
find
quote
Hi everyone, I have a problem, my gt525m have just died, this is the scenario: https://www.dropbox.com/s/ee1ezvrm5ubw3h...e.JPG?dl=0  I was searching for a vbios in order to flash the video card but honestly I dont have idea on how to do it, Ive been trying with phoenix UEFI winphlash but with no luck, I dont know what to do, so Im asking you guys If you can help me, Im sorry for being so annoying.
PD: Im not a native english speaker, my apologies for any mistake.
Benjamin.
find
quote
Does anybody have a L511z bios dump that i can flash directly into the bios chip using a flash programmer so i can try to unbrick my xps 15z L511z?

The method using a recovery CD does not work since i accidentally flashed a completely wrong bios Sad

The MX25L3206E bios chip is supported by my programmer, so all i need is to desolder the chip and a dump file of a working one.
find
quote
Meanwhile i found a BIOS Dump from the XPS 15z and flashed it but the Laptop is still bricked.

Is the KBC possibly bricked too when i flashed a wrong file?

Where do i find the KBC Chip?

But perhaps i only found the wrong Dump, so i am still looking for a Dump of the Main BIOS and possibly KBC too so i can flash them using my TL 866
find
quote


Forum Jump:


Users browsing this thread: 12 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in