Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Verification Failure CH341a - W25Q128FV Help
#1
Good Evening,
 I recently requested the help of getting some features unlocked on my Acer G9-793 Laptop which has a W25Q128FV chip. Dumped fine, Flashed the modded bin and cannot get it to verify through the CH341a program (verification errors!) or boot. The laptop turns on with all lights lit but does not post to bios, sits for 10 seconds and restarts. I've searched the internet high and low for a resolution. I've seen some recommend version 1.18 of CH341a however when I use this it gives an error for the bin being too large. Currently I've tried flashing v1.18, v 1.29, v 1.30, v 1.34 under both W25Q128BV AND W25Q128FV. I have also used AsProgrammer 1.4.0 & 1.4.1. None with success. Has anyone else had any experience dealing with this chip alongside this acer insyde bios? I am getting very tired of repeatedly taking this laptop completely apart due to the chip being directly under the keyboard.  I have double checked my pin configuration on the CH341a itself and I know that is correct. 
 Aside from desoldering the chip out and trying that, I am out of options

Any help is greatly appriciated!
find
quote
#2
So after further examination, I proved out my IC Test Clip and everything looks good, voltages and all. However, I got to looking at the WINBOND chip itself and it looks to be very damaged from the IC Test Clip at the very top of the pins. It is all scraped up and there looks to be wires frayed. Are there multiple wires that run inside each one of the 8 pins? Or am I just seeing things. This would be a great explanation as to why I'm getting inconsistent writes/verify. I ordered some new chips and plan to test and solder them in if it comes to it. Has any one see anything like this damage wise?

Thanks


Attached Files Thumbnail(s)
   
find
quote
#3
Solved!! This chip is very picky which version of CH341A it will use. I also learned that the Test Clamp is an awful way to flash chips, solder if you can!
The solution is to only use CH341A v 1.18. You may have to look for the right copy of this version. The first version I found did not accept .bin's of 16mb claiming they are too big for the program (The acer predator g9 laptop uses a larger 16mb .bin bios). I found a different version which had no problem.
Once you have found the correct version, keep reseating the Test Clip until you detect the chip correctly. You'll see the full chip name show up. Do not try to write/verify without the test clip in correct, it will only fail. I'm going to guess that I flashed this chip 50 times and once I found the pattern, it did consistently work. I'll be making another post about how to recover the Acer Predator g9-973 bios which uses the winbond W25Q128FV chip.

Never give up!
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in