Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
reprograming bios chip
#1
Hello,
I posted in an old subject related to TBGM01 motherboard.
Perhaps it would be beter to post a new one, because i'm newbie with bios programming.
I have a bricked motherboard from Packardbell ixtreme i9520 desktop, a ch341A usb programmer, and the chip to reprogram with the bios R01A0 from packard bell site.
But after programing the 842P8P02.ROM on the chip, the MB doesn't start. Do'nt know why.
A new chip from ebay seems to have more data on it when reading with ch341A and let my motherboard boot, but my ethernet controller is not present in peripherals.
I'm so lost.
Could you please help me.?
best regards. Sorry for the dubble posting and my poor english.
find
quote
#2
Find the LAN MAC ID on a sticker on the board, often near or on the LAN block, but could also be on any other sticker on the board, be sure to check sides of 24 pin, PCI/PCIE Slots, front and back of board etc. That ID will need put back into the BIOS. Do you have a dump of your BIOS that was corrupted/broken originally? If yes, please provide that and your MAC ID and I will tell you where to put the ID in your new BIOS

Often BIOS update from web download is only partial update, not complete BIOS like what's on the board, that's probably why it fails. upload a dump of the complete working BIOS, and your broken original dumped BIOS, and I'll check all this out for you.
find
quote
#3
Thanks for your help LostnBios.
I have a 2048 kb file dumped with CH341a from the chip the ebay Bios Master sended to me. But no ethernet.
No dump from the original bios.
The MB is from Foxconn and manufactured for Packardbell. Desktop ixtreme I9520, x58 I7 intel proc, known as PTU14 on PB site.
What i can see on the board :
M/B : MBU140900290900136EK00
near cpu : U00G090901317 PC TBGM01P8-1.0-8EKS3H
AMI Bios VF173657
Bios chip original : DIPchip MXL1605D
on the PS2 slots : 0001.6C20.00CA.9E00 seeming to be mac adress and  EA=0022.684A.4A8E


Attached Files
.bin   bought chip backup.bin (Size: 2 MB / Downloads: 2)
find
quote
#4
Why no dump from the original BIOS? This is required, well it will save me a lot of time and is best way to fix your BIOS properly, please put your old BIOS in the CH341A and dump that for me too, thanks

Please also look on the motherboard itself and see if you can find the LAN Chip, it's usually near the LAN or Audio ports, likely a Realtek chip (large square, if Realtek brand will have RTL printed on it). Once you find this, even if not Realtek brand, give me the full model # off the chip, or a few images so I can see if there is non-BIOS method to redo your LAN MAC ID
find
quote
#5
Hello
I'm very sorry but i blanked the original bios chip and no dump of it.
intel gigabit lan chip :

WG82567LF
NH06250D1
0812

sticker on the PS2 slots : 0001.6C20.00CA.9E00 seeming to be mac adress and this other number EA=0022.684A.4A8E

I don't want you to spend too much time on it. In fact, if i bricked the bios, it's because there is a boring bug in it, making the PC hang after each sleep mode (S3 error) , and i tried to update my bios with a rom from Gateway fx 6800 (they upgraded their bios for that S3 error) which is similar motherboard manufactured by Foxconn for Acer, Gateway and PB.
If you repare my lan, the S3 error will stay anyway. And it's the greater problem for me.

Never again i will buy Acer, Pb or like that .!!

Best regards.
find
quote
#6
Bummer about erasing the chip! None of those numbers look like MAC Address to me, no stickers on or near the LAN Port? How about on the rest of the board, check all stickers, look on side of 24pin and top/bottom sides of PCI/PCIE Slots too. Maybe you can you check your router logs and see if you can see it from there at some date before this happened? Any stickers on inside of case, or back of case?

Does the LAN Work if you flash back in your proper BIOS? This needs to be tested first, because it may be not working now due to other BIOS layout/config issues, instead of a missing LAN MAC ID, since this BIOS is not for your actual board.

You can switch to S1 sleep instead of S3, would that help at all? I don't use sleep, so unsure the differences between them all.
So, flashing the "Fixed" Gateway BIOS did not help the S3 issue either? If not, then I'd flash back to your proper BIOS anyway.
find
quote
#7
Hello.
flashing the gateway bios bricked the MB. No start of PC at all.
I bought a chip from ebay bios master (they put the bios from PB site for my MB themselves on it) but it was Soic instead of Dip8.
So i saved the bios they send to a file and programmed the Dip8, replaced it on my MB. And it started again (without lan ).
When i tried to put the rom from PB's site myself, no start again. The rom seem to be incomplete when reading it with CH341A and comparing with the rom of the bought chip. I give you the link :

http://global-download.packardbell.com/G...C=EMEA_13P

Be sure i checked all the Mb and discovered only these stickers on the PS2 ports.
Could you try this number EA : 00.22.68.4a.4a.8e  (EA for ethernet adress ??)

Best regards
find
quote
#8
Hello.
i understand nearly all. Idea
The file from bios master's chip is 2048 kb. When having a look to it i remarked the original rom (1024 kb) is copied 2 times on the chip ( the chip is 2048 kb capacity ), one from offset x0 to x0fffff and a second time from x100000 to x1fffff.
I edited the original PB rom myself with hexa tool to do the same and saved it. Reprog my chip and the MB started. But S3 bug is still present.
I did the same with bios from Gateway FX6800 that is updated for S3 error. Dubbled the rom file and reprogrammed my chip.
Eureka : my mobo start with a gateway bios and The S3 error is disappeared.

But no ethernet adapter Confused
If you can do something for that, it would be wonderful but if not let it fall, i will simply use another ethernet adapter or a dongle.
Other thing : congratulations for your great kindness .
Best friendly regards.
find
quote
#9
Hello.
tried an other bios from your site : https://www.bios-mods.com/forum/Thread-G...ios-Unlock
http://bios-mods.com/BIOS/AMI/Gateway/Ga...34s282.zip

I have now overclocking options.
but no gigabit lan Huh
 



thanks everyone for your great jobs


Attached Files Thumbnail(s)
   
find
quote
#10
Great you've made some progress, especially about the S3 issue, and now overclocking too!

Yes, this is normal, often BIOS you download can't be programmed in directly, even if split like you did some stuff will be missing (NVRAM volumes usually), so stuff gets lots aside from serial, UUID etc.

MAC Address does not often have any 00's in it, that's why I said those are probably not MAC, but we can try it.

Download this AFUDOS Package, this is from the stock Gateway BIOS package. Put it on a DOS Bootable USB or CD etc, boot to DOS and run this command
http://s000.tinyupload.com/index.php?fil...4269333297

AFUDOS.exe /M0022684A4A8E

If you get error 04, then this is not valid MAC Address

What does the current MAC address show up as when you run IPCONFIG /All from command prompt?

* Edit - Actually, I find that probably is the correct MAC Address, I looked up the MAC and see it's Hon Hai MAC addy which is Foxconn
https://aruljohn.com/mac/0022684A4A8E
https://www.adminsub.net/mac-address-fin...22684A4A8E
https://en.wikipedia.org/wiki/Foxconn

So, that should sort it all out now, hopefully!
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in