Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Latest Threads
[REQUEST] Acer Nitro 5 AN515-54 BIOS Unl...
Last Post: Jonas Amaral
Today 06:22 AM
» Replies: 87
» Views: 26524
Asus A8M2N-LA/HP NodusM-GL8E: CPU Upgrad...
Last Post: DeathBringer
Today 06:22 AM
» Replies: 44
» Views: 12206
[REQUEST] Lenovo ThinkPad X1 Fold Whitel...
Last Post: Dudu2002
Today 06:09 AM
» Replies: 1
» Views: 46
[REQUEST] Lenovo Flex 2-15 (A0CNxxWW) Wh...
Last Post: Dudu2002
Today 06:01 AM
» Replies: 364
» Views: 105023
[Request] Alienware 17 R2 bios unlock
Last Post: feluchi
Today 05:11 AM
» Replies: 122
» Views: 36377
HP Pro 3300 & 3400 (H61): Upgrade to Ivy...
Last Post: miant
Today 12:42 AM
» Replies: 124
» Views: 81570
[REQUEST] Acer Nitro 5 AN515-47 BIOS unl...
Last Post: AdrianoA3
Yesterday 01:56 PM
» Replies: 4
» Views: 265
[REQUEST] Acer Nitro 5 AN517-43 BIOS unl...
Last Post: tanago
Yesterday 01:25 PM
» Replies: 2
» Views: 120
Alienware 14 bios unlock
Last Post: Dudu2002
Yesterday 01:20 PM
» Replies: 1
» Views: 93
Lenovo Legion Y530-15ICH 1050Ti
Last Post: Dudu2002
Yesterday 01:15 PM
» Replies: 1
» Views: 147
[REQUEST] ASUS VIVOBOOK X505Z BIOS TPM S...
Last Post: eMerchant
Yesterday 10:27 AM
» Replies: 0
» Views: 80
[REQUEST] Acer Aspire 4750(G,Z) & 4752(G...
Last Post: MyAngelMegu
Yesterday 08:28 AM
» Replies: 42
» Views: 31297
[REQUEST] Lenovo IdeaPad U310 & U410 (65...
Last Post: Dudu2002
Yesterday 03:27 AM
» Replies: 1772
» Views: 393577
[REQUEST] Acer PT715-51 (Triton 700) ins...
Last Post: gtarik
05-22-2024 11:51 PM
» Replies: 22
» Views: 10171
Optiplex 7060 SFF 9th Generation Intel C...
Last Post: DeathBringer
05-22-2024 02:43 PM
» Replies: 47
» Views: 9200
[REQUEST] Lenovo G500(S) (7BCNxxWW) Whit...
Last Post: brum
05-22-2024 06:06 AM
» Replies: 566
» Views: 213623
[REQUEST] Gigabyte Aero 15 OLED BIOS Unl...
Last Post: C4lDx
05-21-2024 02:45 PM
» Replies: 5
» Views: 448
[REQUEST] Lenovo Z50-70 & Z40-70 (9BCNxx...
Last Post: Dudu2002
05-21-2024 02:44 PM
» Replies: 727
» Views: 205425
Unlock all hidden options for insydeh20 ...
Last Post: Andrew_baha
05-21-2024 09:59 AM
» Replies: 255
» Views: 1024920
[REQUEST] Acer Revo M1-601 BIOS Unlock
Last Post: sglider
05-20-2024 10:49 AM
» Replies: 9
» Views: 5290

Asus h110m-a & xeon e3-1280v5
#11
(04-19-2024, 09:12 AM)DeathBringer Wrote: So you can press Yes for all warnings in FIT.
Thanks you:

So, I have outimage.bin.

How do I flash this image?
find
quote
#12
By any suitable hardware programmer.
find
quote
#13
(04-19-2024, 09:25 AM)DeathBringer Wrote: By any suitable hardware programmer.

I found something.
What do you think about this method for remove ME:
https://github.com/mostav02/Remove_Intel...g-anything

I think I may flash bios entirely using FTP and disabling temporary ME using bios feature which able it to be flashed from next boot until reboot.
Im not sure if these other methods for disabling ME may help to Xeon recognition, what do you think?
find
quote
#14
You can try HDA_SDO method.
find
quote
#15
(04-19-2024, 02:48 PM)DeathBringer Wrote: You can try HDA_SDO method.

I've searched about that, supposedly it does the same thing as booting into a mode that can be modified with FPT. I have dumped the complete bios with FPT and have verified that the binary is different from the vendor version converted to bin. The size is the same as expected. When adding the dumped version to the FIT program, some warning messages appear.

"Warning: Could not set "GbE Read Access" to: 0x00000008, reverting to previous/default value: 0xFFF
Warning: Could not set "Embedded Controller Write Access" to: 0x00000020, reverting to previous/default value: 0xFFF 
Warning: Could not set "Embedded Controller Read Access" to: 0x00000020, reverting to previous/default value: 0xFFF 
Warning: The ME FW image loaded has been pulled from a previously booted system. Some FW settings will not be allowed to be changed. "

I am in no rush to do this and I prefer to be clear about what I am doing and learn at the same time.

I would like to know why there is this difference and if it would be convenient to flash the seller's modified version or make a new modified one from the dump. Thank you very much in advance
find
quote
#16
Updates:

Someone lent me a programmer (EZP2019+) and I'm trying it out.
It has not worked with the newer bios, modifying it with FIT as DeathBringer said, and I have started trying with the old ones.

I have discovered a pattern, when I put a bios of the asus h110m-a before the 3000 series.

For example, the first bios, "H110M-A-ASUS-0304" in the FIT program, warning messages similar to those in the previous post appear. Does not detect partitions.

Messages like this:
"Warning: Could not set "GbE Read Access" to: 0x00000008, reverting to previous/default value: 0xFFF
Warning: Could not set "Embedded Controller Write Access" to: 0x00000020, reverting to previous/default value: 0xFFF
Warning: Could not set "Embedded Controller Read Access" to: 0x00000020, reverting to previous/default value: 0xFFF "

If I go ahead and modify the bios in the same way as the 3000 series onwards (no warning appears 3000 onwards), after burning the bios to the chip. The PC does not boot even with the stock CPU, which in this case is the i3-6100. The PC tries to boot but turns off and starts again.

Curiously, I also need to use that same computer for the "CSME System Tools v11 r46" FIT program to work.

Currently I am still doing tests, since I have the programmer I am not afraid of the brick. I would appreciate any suggestions that would help me achieve my purpose.
find
quote
#17
Update:

I finally got it to work. After trying almost everything. I'm going to explain what I did in case it helps someone in the future.

I have done several things, some were probably not necessary, such as modifying the microcodes so that the board accepts some coffelake.

1. (Probably not neccesary) This is the coffelake mod.
https://winraid.level1techs.com/t/tool-e...bios/32795
Used AllinOne.exe with option 1 on last vendor bios. In this case it was H110M-A-ASUS-3805.CAP (EDIT: Don't do this unless you use a virtual machine,  that automatic program to patch the bios introduces a virus into the computer, perhaps more, including an old well-known Trojan, it is not a false positive. It is better to use coffetime, or simply skip this step which is not necessary for xeon to work. )

2. Then I did what dsanke said there (same that Deathbringers said with extra steps). This is supposed to work to fix 200 series, but worked for my 100 series.
https://winraid.level1techs.com/t/are-xe...ets/100144

I used the modified bios from step 1, not a dumped one as dsanke said. Which should work, but in my case when I added a bios dumped with FPT to FIT, warning messages appeared, and these bios failed later, that's why I didn't do it with that dump version, and I used the one from the seller (also modified with step 1).

 Dsanke extra steps (with some notes)
"Open BIOS with FIT and save as a xml file, then edit it using a modern editor, not notepad provided by windows.
    1. search HostCpuWriteAccess, HostCpuReadAccess, MeWriteAccess, MeReadAccess, GbeWriteAccess, GbeReadAccess, EcWriteAccess, EcReadAccess, change the value to 0xFFF.
    2. search "Reserved value", change the value to Yes. -----------> This is the same that Deathbringer said in this forum
  1. replace the “ME Region.bin” in decomp folder with the version I have provided (this link: https://winraid.level1techs.com/uploads/...2U64sC.zip)
  2. load xml in fit, then build. flash outimage.bin.
"
3. Then, I flashed that bios on the chip using the programmer someone lent me. The chip is placed and flashed as shown in this tutorial I found https://youtu.be/9WprUQ1NMw8 (Its neccesary to erase it before flash). And put on the motherboard with Xeon e3 1280v5 placed. It is necessary that there be a graphics card because this processor does not have an integrated one. If not, three beeps and one long beep will sound.

It works beyond my expectations, I thought I wouldn't get it!

Thanks to Deathbringer for the help and I hope this message helps more people.

P.D. Discovered why FIT wasn't working on the other computer. It's because the name of the folder where it was had an accent.
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)