Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Latest Threads
[REQUEST] Asus ROG Strix GL702ZC BIOS Un...
Last Post: draklrd
Today 05:55 PM
» Replies: 122
» Views: 39376
Request for Memory no memory detected er...
Last Post: H@cK_T7910
Today 05:38 PM
» Replies: 10
» Views: 611
[REQUEST] Acer Aspire Timeline 5830T
Last Post: bambam22
Today 05:24 PM
» Replies: 0
» Views: 21
[REQUEST] Lenovo Ideapad Z585 (60CNxxWW)...
Last Post: space1356
Today 03:35 PM
» Replies: 80
» Views: 16216
[REQUEST] Acer Aspire E1-571(G) BIOS Unl...
Last Post: Bypass1
Today 02:52 PM
» Replies: 129
» Views: 36296
[REQUEST] Lenovo Y50-70 (9ECNxxWW) BIOS ...
Last Post: tunner
Today 02:47 PM
» Replies: 2279
» Views: 511026
[REQUEST] Lenovo Ideapad 320-15ikb (6JCN...
Last Post: Dudu2002
Today 02:05 PM
» Replies: 17
» Views: 2159
lenovo z570 Advanced Menu Unlocked
Last Post: BGG13
Today 12:15 PM
» Replies: 4
» Views: 2124
[REQUEST] asus rog strix scar 2 - bios 3...
Last Post: saiyanprinz
Today 12:14 PM
» Replies: 14
» Views: 1147
[REQUEST] Lenovo G480 (5ECNxxWW) Whiteli...
Last Post: Dudu2002
Today 12:09 PM
» Replies: 110
» Views: 27894
[REQUEST] Lenovo Thinkpad X1 Carbon Gen3...
Last Post: Dudu2002
Today 12:06 PM
» Replies: 34
» Views: 6676
[REQUEST] Asus VIvobok X412FLC BIOS Unlo...
Last Post: nitsan57
Today 11:26 AM
» Replies: 0
» Views: 53
[Request] Unlock MSI H97M-G43
Last Post: TheMaster
Today 10:55 AM
» Replies: 1
» Views: 990
Asus Strix G512LV Bios Unlock
Last Post: ROGSKILL
Today 09:46 AM
» Replies: 23
» Views: 1363
New Members Say Hi Here
Last Post: byakinta
Today 09:46 AM
» Replies: 140
» Views: 184936
[REQUEST] HP pavillon 15-cx0xxx BIOS Unl...
Last Post: Breaeth
Today 08:25 AM
» Replies: 6
» Views: 107
MSI MS-9661 bios unlock/mod request
Last Post: CaffeineCode
Today 03:14 AM
» Replies: 1
» Views: 1580
[REQUEST] Acer Swift 3 SF315-51(G) BIOS ...
Last Post: Dudu2002
Today 03:08 AM
» Replies: 5
» Views: 93
[REQUEST] Acer Aspire E5-575(G) BIOS unl...
Last Post: Dudu2002
Today 03:05 AM
» Replies: 126
» Views: 38108
ASUS N56VZ MAC, UUID, KB Light and Seria...
Last Post: Growtopia Jaw
Today 12:10 AM
» Replies: 0
» Views: 94

Asus Strix G512LV Bios Unlock
#1
Star 
Hello,

I am new to the forum and inexperienced in this field.
I hope that an expert will be able to help me because after browsing the web and testing different solutions, all my attempts have failed and I don't want to brick my machine with bad modified firmware.

On the official ASUS ROG forum, many users report a lack of configuration in their original bios and get stuck when changing hardware or optimizing software.

Features of my laptop :

- Model: Asus ROG STRIX-G15-G512LV-AZ301T
- Processor: Intel Core i7 10870H
- RAM: Samsung 16GB (2x8GB) DDR4-3200 1.2v JEDEC
- GPU: Nvidia GeForce RTX 2060
- HDD: 512 GB SSD M.2 NVME
- OS : Windows 10 Home 64 bits

My Problem

I recently purchased this ballistix kit 2x32 GO DDR4-3200 SODIMM 1.35v :
- https://www.crucial.com/memory/ddr4/bl2k32g32c16s4b

Unlike my old Samsung 2x8 GB memory sticks running at 3200 Mhz in 1.2v, these only run at 2666 Mhz in 1.2v. I have no way in the bios to set up the XMP 2.0, nor to configure the frequencies and the right voltage at 1.35v in order to take advantage of its maximum bandwidth (3200Mhz) and its optimal timings (CL=16).

Here is the link to the latest BIOS ASUS firmware, currently installed on my machine :
- https://dlcdnets.asus.com/pub/ASUS/GamingNB/BIOS/G512LVAS311.zip

On the other hand, the bios limits me in the configuration of my CPU, both for undervolting and overclocking. The ideal would be to have a fully unlocked firmware, with all the hidden options available.

Unlock a maximum of configurable options from the bios, in particular :

> Advanced / OverClocking Performance Menu / ALL
> Chipset / ALL
> Memory Configuration / ALL
> XTU Interface limitation

I would like to get a finalized ROM, compatible and usable directly with the Asus EZ Flash software. If you need a dump, please provide me with the necessary tools and steps to follow. I remain available and hope to find a fully operational and functional bios.


Thank you very much.
find
quote
#2
1. You said you've tried different solutions to unlock bios ,so what have you done ? And you don't want to your laptop got brick ,but any modifications and flashing bios have its risk ,so do you wanna pass the blame to someone who help you edit bios?

2. It's impossible to re-flash mod bios via EZ flash.

3. After you flash mod bios in asus's 10th gen laptop ,it will trigger off the drive bitLocker ,i don't know the exact reason of it. so ,you need have a Bitlocker recovery key or directly disable Bitlocker before you flashing the mod ,or you will not access your drive.

Refer to the experience from forum member Sakiwinkie , point at #12.
https://www.bios-mods.com/forum/Thread-R...ock?page=2

4. Loading xmp profile or tune memory freq in bios is workable ,there are many samples on i made mod(8th and 9th) ,you can visit below.
https://239239.blogspot.com/2021/01/G732...rvolt.html
https://239239.blogspot.com/2020/08/GU50...ry_12.html
https://www.bios-mods.com/forum/Thread-R...nus?page=2&highlight=gl704

5. About cpu undervolt ,as i knew , since bios release date after 2020 ,asus prohibits user to do undervolt via intel xtu or throttlestop. But we can disable "CFG Lock" and "OverClocking Lock" in bios to re-active xtu and throttle to do cpu undervolt. However currently(2021) asus blocked undervolt with new methods again ,even if we disable "CFG Lock" and "OverClocking Lock" ,it is no longer available to enable xtu and throttle again. So ,if you wanna do undervolt please stay bios version at 2020 year release.
These infoemation also from member Sakiwinkie with his g732lws.

warning ! Pleae don't directly tune cpu vcore voltage in bios or your machine will get dead and can't revert through write bios.

6. If you've disabled bitlocker already ,use this tool to dump bios and attach ,i would attempt to edit it.
https://katfile.com/0lclpqlxy9gw/f14.rar.html

My page>>>click
My bios unlock >>> click
donate me >>>click


find
quote
#3
First of all, thank you very much for your feedback, i will try to provide you with as much information as possible to answer your questions.

1) At the moment i'm talking to you, i've never flashed the bios, i simply tried to modify the original bios with several software : AFUWIN64, AMIBCP, UEFITool, MMTool, etc..
Unfortunately, i did not succeed in doing so, but i systematically receive many error messages and i don't know the procedure to follow to edit a functional bios. The tutorials on the internet always seem obsolete, incomplete or even worse, dangerous for the bios. My laptop is brand new, that's why i take every precaution.

I respect your work and generosity on the forum and your reputation precedes you. Your blog and user feedback proves that you are a very competent, serious and bona fide person.
No excuse if I brick my bios, I won't blame anyone, let alone you, for helping me.

2) All right, i'll make a note. So i forget about ASUS EZ Flash for the modding of the bios.

3) All right, i didn't know about this BitLocker problem.

Genius239: "... or directly disable Bitlocker before you flashing the mod ...".
I followed the Sakiwinkie member's post and not finding the associated Bitlocker recovery key on my Microsoft online account, i finally disabled the Bitlocker option in Windows > Start / Settings / Update & Security / Device Encryption / Device Encryption is OFF.
I also disabled the Bitlocker Drive Encryption Service.
The manage-bde -status command tells me that the encryption status is disabled and that no item is encrypted.
The get-tpm command tells me the TPM is present and active but i have no option to disable it in the bios. I don't know if this is necessary but i don't think so.

Is it enough?

4) I visited the articles on your blog and this is exactly what i need : access to set the RAM to XMP 2 and voltage, which i need to set to 1.35v without necessarily touching the rest.
They seem to have access to all the settings options.

5) All right, thanks for your prevention message and your precisions regarding Intel XTU, Throttlestop, "CFG Lock" and "OverClocking Lock".

On Asus support, I only have access to two versions of BIOS :

- The 311 dated 2021/01/26: the one that is currently present on my system.
> https://dlcdnets.asus.com/pub/ASUS/GamingNB/BIOS/G512LVAS311.zip
- The 310 dating from 2020/07/22
> https://dlcdnets.asus.com/pub/ASUS/GamingNB/BIOS/G512LVAS310.zip

Do I have to go back to BIOS version 310 via ASUS EZ Flash to make it easier?

6) I disabled Bitlocker and my disk is not encrypted.
I ran the dump.bat file with administrator privileges. The operation went well and generated a dump.rom file available at this address :
> https://drive.google.com/file/d/1cAELm8W9Njr_Qfe8mGjZq_1Fq8Nr4fO8/view?usp=sharing
> Attached Files

Additional Questions :

- Do I need to disable Fast Boost or Secure Boot Control in the bios?

While waiting for your return, thank you very much for your involvement.


Attached Files
.rar   dump.rar (Size: 6.78 MB / Downloads: 7)
find
quote
#4
Check your Pm.

My page>>>click
My bios unlock >>> click
donate me >>>click


find
quote
#5
I followed your procedure to flash my bios and everything went as planned.

Simple and efficient, i didn't get any error message and i attached in private message the dump_full.rom file as requested in your user manual, once the procedure was completed.

The Advanced and Chipset menu are now available and i congratulate you 239modBig Grin

I can now browse the options, however i have two problems concerning XMP 2.0 (1) and CPU UnderVolting (2) :

1) In the bios, in the "Advanced \ OverClocking Performance Menu \ Memory \ Memory Profile", i find in the drop-down list : "Default profile \ Custom profile \ XMP profile 1".

No choice concerning XMP 2.0, however in the gray description above, i notice that there is "Default / Custom / XMP1 / XMP2".

Screenshoot in support : https://imgur.com/a/Hd7HzF5

Why can't i find XMP 2.0 in the profile selection ?

Possible solution :

- Do i have to set all the RAM values with a custom profile or is there a way to have access to XMP 2.0 in the context menu ?

- If the only solution is a fully customized configuration, i would like feedback and advice on the following values (i have not yet applied them) :

> Advanced \ OverClocking Performance Menu \ Memory \ Memory Reference Clock : 133
> Advanced \ OverClocking Performance Menu \ Memory \ Memory Ratio : 12
> Advanced \ OverClocking Performance Menu \ Memory \ Memory Voltage : 1.35 Volts
> Advanced \ OverClocking Performance Menu \ Memory \ tCL : 16
> Advanced \ OverClocking Performance Menu \ Memory \ tRCD/tRP : 18
> Advanced \ OverClocking Performance Menu \ Memory \ tRAS : 36

Since i don't have an "Auto" value in the other fields, should i leave them with the original default values or put specific ones ?
The other fields in question : tCWL / tFAW / tREFI / tRFC / tRRD_L / tRRD_S / tRTP / tWR / tWTR_L / tWTR_S / NMode / DIIBwEn[0] / DIIBwEn[1] / DIIBwEn[2]

I think i have to rely on the third column, which i circled in red on this screenshoot : https://imgur.com/a/RimFcQ2
On the screenshoot, the field "VDD [mV]" set to "1350" is missing.
No value specified below for "DIIBwEn[x]" values: 0 1 2 2 by default at the bottom.

Do you think these values are correct since they represent 3200 frequency timing ?

As a reminder, here are the specifications of my DDR4 kit installed on my system : https://www.crucial.com/memory/ddr4/bl2k...16s4b#spec

- In the bios, in the "Chipset \ System Agent (SA) Configuration \ Memory Configuration" menu, i have a field named "Maximum Memory Frequency" with the default value "Auto". Should i leave it in "Auto" or set 3200 in its drop-down list ?

2) In the Intel XTU software, after having modified the following options in the bios :

> Advanced \ OverClocking Performance Menu \ OverClocking Feature : Enabled
> Advanced \ OverClocking Performance Menu \ XTU Interface : Enabled
> Advanced \ Voltage Configuration \ Core Voltage Offset Configuration : Enabled
> Advanced \ CPU - Power Management Control \ CPU Lock Configuration \ CFG Lock : Disabled
> Advanced \ CPU - Power Management Control \ CPU Lock Configuration \ Overclocking Lock : Disabled

I still don't have access to the Core Voltage Offset settings, nor the clocks or ratios, everything is grayed out. Only ICC parameters have been unlocked and are adjustable in Intel XTU under Windows 10. Unfortunately not enough to do undervolting.
As you said in your previous post, this is a problem you have known about since the recent Asus update (2021).

Very important point :

The value in "Advanced \ CPU - Power Management Control \ CPU Lock Configuration \ Overclocking Lock" changes to Enabled every time i reboot my PC despite my modification.
With the shortcut F10, i validate the backup and restart, but nothing happens. Impossible to boot with this value Disabled after a reboot, it always returns to its original state, i.e. Enabled.
Additional information in the bios : Enable/Disable Overclocking Lock (BIT 20) in FLEX_RATIO(194) MSR

That must be where the problem comes from.

Possible solution :

- Should i reflash my bios to an earlier version, namely the 310 dated 2020/07/22 using ASUS EZ Flash? And redo the procedure with a rom modified by you from version 310 ?
- Other idea or proposal ?


Thanks again for your involvement Genius239 Guru.
find
quote
#6
There are only two xmp profile in default bios ,choose one of them you should can read a xmp information from memory spd.
Or you could consider tune memory freq manually ,please refer to below link. And i''m not very understanding about memory timing ,so you need to test them yourself , i'm only a little bios modder and can't understand everything .
https://239239.blogspot.com/2021/01/tunememory.html


Why the option "Overclocking Lock" enabling automatically in every reboot?? Because you've enable "Overclock feature" under OC menu.
In fact ,currently the OC menu interface that you can saw had improved by me. On default OC menu you only can see a item "Overclocking Feature" and its default value is disable ,when you enable it ,the full of OC menu will be appear. But now you can directly see OC menu without tune Overclocking Feature. What you used is version 2 oc menu ,on version 1 you also can see full of OC menu ,but option "Overclocking Feature" is hidden cuz i don't wanna user to change it.
"Overclocking Feature" will affect "Overclocking Lock" and hidden/show OC menu ,this is why i spent much time to edit oc menu.

On stock OC menu ,if you wanna load xmp profile and active xtu or throttlestop to do undervolt ,you should do like below.

Go into OC menu and enable "Overclocking Feature" to appear OC menu then set up xmp or other settings under OCmenu then save and reboot. After you confirm anything as well on operating system ,go into bios again then disable "Overclocking Feature' and disable "Cfg lock' and "Overclocking Lock" concurrently then save and reboot.
If you did above procedure ,you can keep load xmp configuration and do undervolt fine on the operating system and "Overclocking Lock" will not re-enable in every reboot.

It might a little complex for users on above procedure ,right? So ,i attempt to improve the OC menu to reduce user's wrong tweak ,but i don't know why you will enable it....

My page>>>click
My bios unlock >>> click
donate me >>>click


find
quote
#7
Hello,

I have followed the above procedure.

> "Go into OC menu and enable "Overclocking Feature" to appear OC menu then set up xmp or other settings under OCmenu then save and reboot. »

I enabled Overclocking Feature and set up XMP Profile 1, after that I saved and restarted my PC to access my OS.

And at reboot... BlackScreen. No Logo, No POST of the bios, absolutely nothing... The diodes, keyboard, rgb light up but the screen remains black.

After some research on the Internet, many have had black screens after activating XMP.
I'm currently opening the machine to remove the stack and do a CMOS Clear.
Unfortunately, I can't find the stack, I'm still searching for the moment.
Otherwise, there is a solution proposed by Asus that I haven't tested but that will install the original BIOS and that's not what I want. I wish to keep the 239mod.
> https://www.youtube.com/watch?v=18-lOq1XQiA

Link related to blackscreen
> https://www.reddit.com/r/buildapc/comments/a252g1/black_screen_of_death_with_xmp_ram_profile/
> https://linustechtips.com/topic/1199004-...n-no-post/

There are many threads on the web on this subject. It's still amazing how the simple act of selecting an XMP profile can brick a machine. Everything has been working fine so far.

Do you have any recommendations to get out of this blackscreen and reset the default BIOS settings?

If the CLEAR CMOS doesn't work despite my attempts, what is the solution ?

Thank you for your precious help.

#UPDATE

Problem solved, I managed to make a clear cmos. I'm back on the 239mod.

For the moment, I don't touch the XMP Profile anymore.
Everything is back to normal.
find
quote
#8
I've told you currently OC menu was improved ,you don't need to enable Overclocking Feature to appear complete oc menu.

Help string of Overclocking Feature is "Performance Menu for Processor and Memory" ,its mainly feature is let oc menu appear when you set it to enable ,but now you don't need to enable it , you still can see the complete oc menu because i've improve it.
Enable "Overclocking Feature" will affect "Overclocking Lock" to enabling automatically while every reboot ,this is why i edit oc menu ,now do you understand??

You're the few cases of got failure with load xmp profile on my mod experience , scarcely users reply me this condition.
I've told you you could tune memory freq manually ,you could start at 2933mhz(133x11) then increase step by step.

Clear cmos is necessary while you did any wrong bios settings ,i know a force way to clear cmos ,that is hold on power button more than one minute then turn on power again.

===============
All samples related black screen of load xmp you linked ,no one of them is laptop platform ,so i said almost no user response to me the same status like your case.

My page>>>click
My bios unlock >>> click
donate me >>>click


find
quote
#9
Hello,

Thank you for your details.
I understand that the overclocking feature no longer needs to be enabled.
It remains systematically disabled, i don't touch it anymore since i have access to the whole menu. Noted.

Your tip for clear cmos works very well via the power button.
Thank you, it saves me from systematically removing the bios battery.


During my afternoon, i started from a blank base, with all the default settings (F9 in the bios). I give you a feedback of my tests.

1) Concerning XMP, i remind you that i only have access to three options from the drop-down list of the "Memory Profile", namely : "Default profile \ Custom profile \ XMP profile 1".
I have never seen "XMP profile 2" in this list. I don't know if this is normal.

Anyway, i have been able to test many possibilities :
- The XMP Profile 1 clearly makes the machine crash, blackscreen, therefore incompatible with my system.
- So i had to go through a custom profile, and as recommended, i performed the operation step by step.

> The best i could get out of it is a frequency of 3100 Mhz in CL16 and i'm very satisfied for the moment. According to the MemTest software and the Windows diagnostic tool, the memory is compliant and reacts rather well without any errors.
I am thinking of fine-tuning the secondary and tertiary timings in my future tests.

My stable RAM configuration
> Memory Reference Clock: 100
> Memory Ratio: 15
> Memory Voltage: 1.35 Volts
> QCLK Odd Ratio: Enabled
I discovered that with the QCLK Odd Ratio option enabled, default disabled, i was able to recover an additional 100Mhz.

Note that my old original memories managed to reach the speed of 3200 Mhz, but none of my tests work when i set them to 3200 Mhz (133x12 or 100x16 = BlackScreen).
I don't know the cause, maybe the voltage limit on the chipset bus... I keep looking but anyway, thanks genius239, it works in 3100 Mhz CL=16 and it's very good for the moment.

2) Concerning the undervoltage, it's getting more complicated.
I assure you that with default settings, without touching "Overclocking Feature", it's impossible to keep the value disabled in "OverClocking Lock". I followed your procedure perfectly, i went to a default bios, made various tests, absolutely nothing helps. The value "OverClocking Lock" ALWAYS comes back Enabled.

I think it's due to Asus BIOS version 311, probably a security has been implemented to keep this value always active. As a result, it is impossible to have adjustments on XTU or ThrottleStop, i have to make do with the 0-80mV available through the basic functionality of the Asus bios: "Advanced \ Voltage Configuration \ Core Voltage Offset Configuration".

If you see a solution to this problem, personally, i've tried everything. I can send you a demonstration video to support it.

Should i reflash my bios to an earlier version, namely the 310 dated 2020/07/22 using ASUS EZ Flash ? And redo the procedure with a rom modified by you from version 310 ?

Thank you.
find
quote
#10
hey guys, another dude with an asus strix g15 trying to figure out how to deal with high cpu temps. has there still not been any improvements regarding this issue. recently bought this laptop and regreting the decision
find
quote


Forum Jump:


Users browsing this thread: ROGSKILL, 10 Guest(s)