Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
You have to register before you can post on our site.



Latest Threads
Packard Bell TE11HC: HM70 mod to accept ...
Last Post: Pucel_a
Today 08:55 AM
» Replies: 7
» Views: 0
[REQUEST] A55BM-K unlock
Last Post: Dennis50300
Today 05:21 AM
» Replies: 13
» Views: 3780
[REQUEST] Lenovo Thinkpad T440p (GLETxxW...
Last Post: Dudu2002
Today 04:29 AM
» Replies: 682
» Views: 154529
Last Post: Daniel6745
Yesterday 05:56 PM
» Replies: 0
» Views: 0
HP Bios Unlock
Last Post: filmmaker11736
Yesterday 02:44 PM
» Replies: 0
» Views: 0
Acer predator orion 3000
Last Post: neogamer0909
Yesterday 12:48 PM
» Replies: 27
» Views: 1870
NP300E5Z-S06AE: upgrade i5-2450m to i7-2...
Last Post: georgekevorkian
Yesterday 09:29 AM
» Replies: 2
» Views: 0
[REQUEST] Lenovo G780 (5ECNxxWW) Whiteli...
Last Post: yeahyeah
Yesterday 09:15 AM
» Replies: 963
» Views: 274416
Asus M5A78L-M LX Plus SLIC 2.1 request
Last Post: interwb
Yesterday 08:58 AM
» Replies: 11
» Views: 9715
[REQUEST] Gigabyte Aorus 15p XD Unlock
Last Post: Pratty
11-27-2022 11:37 PM
» Replies: 4
» Views: 303
ASUS P9X79 WS TPM 2.0 Module
Last Post: dynamic_duo
11-27-2022 04:37 PM
» Replies: 0
» Views: 0
Asus X670E Extreme Bios Mod
Last Post: Robr
11-27-2022 03:37 PM
» Replies: 0
» Views: 0
[REQUEST] Lenovo B590 (H1ETxxWW) Whiteli...
Last Post: Tommy_1984
11-27-2022 02:10 PM
» Replies: 910
» Views: 272382
Dell Optiplex 7010 bios M.2 NVMe support
Last Post: lexa1812
11-27-2022 01:52 PM
» Replies: 1
» Views: 2252
[REQUEST] Lenovo Flex 2-14 (A0CNxxWW) Wh...
Last Post: Dudu2002
11-27-2022 01:52 PM
» Replies: 273
» Views: 61439
[REQUEST] Asus ZenBook UX582HM bios unlo...
Last Post: Fluffinko
11-27-2022 01:18 PM
» Replies: 3
» Views: 474
[REQUEST] Asus x99-a 3.1 4x4x4x4x bifurc...
Last Post: molegan
11-27-2022 12:36 PM
» Replies: 14
» Views: 2146
[REQUEST] Lenovo Ideapad Z710 (7FCNxxWW)...
Last Post: Dudu2002
11-27-2022 12:08 PM
» Replies: 258
» Views: 77061
[REQUEST] Lenovo IdeaPad Gaming 3 15IMH0...
Last Post: Dudu2002
11-27-2022 10:44 AM
» Replies: 50
» Views: 12320
Acer Laptop New Keyboard , Layout Proble...
Last Post: Copersonality
11-27-2022 04:22 AM
» Replies: 0
» Views: 0

Aurora R4 NVMe bios support
Hey all,

So my question is if it's even possible to mod the Alienware Aurora R4 A11 BIOS for the x79 chipset to enable native PCI-e x4 and NVMe support?  For reference, I'm using a PCI-E x4 to M.2 adapter with a Samsung 960 pro 500gb.  Windows recognizes the drive when I boot off my SATA drive, but I want my PCI-E drive to be my os drive and the BIOS can't see it, the windows uefi bootloader can't boot from it and no settings in my bios change anything, it's constantly just giving me an error message "Windows can't boot, files missing" with the option to try again.

Thanks in advance,
I have an Aurora R4 motherboard (x79) with BIOS revision A11 and have modded BIOS. I am booting off a single SATA SSD (Samsung 840 Evo 1tb) on Windows 10 x64 (1903) in Secure Boot.

Question is:
- If i apply the modded BIOS, can i still boot fine with my current setup? Will it affect boot-ability of my current setup?
- I am provisioning this when I upgrade my SSD to an nVME drive that I intend to do a fresh install of Windows 10 (which I can disable Secure Boot, Fast Boot, CSM later)

NVME drive I plan is - Adata XPG SX8200 Pro
NVME PCIe x16 adaptor -

I followed the instructions on modding my BIOS to allow NVME boot here - [/url][url=]

*UPDATE* - this does not work. Use AFUDOS.
I was able to flash my modded Aurora R4 A11 BIOS using AFUWIN for APTIO4 ( - under \afuwin\64\afuwin64\AfuWin64\AFUWINGUIx64.EXE)

I just programmed the Main BIOS Image, checked Do Not Check ROM ID and Restart After Programming
[Image: YASNlpx.png]

Link to original A11 BIOS file -
Link to modded A11 BIOS file -

So far, I am still able to boot (in Secure Boot) Windows 10 using my SATA SSD.

Will post an update once I have an NVME drive to do a fresh install of Windows and boot directly off of it.

Just use the AFUDOS in this link to flash your AuroraR4

In AFUDOS, just use the format
AFUDOS biosfile.bin /GAN

[Image: gwJVDIs.png]

*Update* - Using my Xeon E5 2670 CPU:
[Image: WXYlqAn.png]
IF AFUWIN you linked works as you suggested in second post, then no one should risk using AFUDOS w/ /GAN instead of the AFUWIN method
Since /GAN can mess things up pretty badly if it goes sideways.

Thanks for posting your mod BIOS, I'm sure it will help many users
Correcting myself
  • AFUWIN utility did not work for me. Did not find any AFUWIN utility that can run with /GAN parameter. When I mentioned that AFUWIN worked, was only when i only flashed the Main BIOS Image (when I programmed all blocks or even just the Boot Block, it showed an error saying 18 - Error: Secure Flash Rom Verify fail)
  • AFUDOS worked for me. I feel nervous trying it as it is bordering to blind-flashing.
Updated BIOS file containing the following fix

Based on A11
- Native NVMe booting via PCIe adaptor
- Microcode fix for Spectre bug
- Updated NIC firmware
- Updated RST firmware to support RAID TRIM

Please refer to the link of the BIOS file as well as AFUDOS (need to run natively on USB-BOOT DOS and not DOS Box)

Aside from that, here's the update to fix Intel ME bug
Please refer to the link of the Intel ME FW updater

You may run it in Windows (x64) by typing
FWUpdLcl64.exe -f
I've upgraded to a Samsung 970 EVO 512gb and experienced ultra-fast bootup here!
Here's my video of how fast my Aurora R4 boots off an NVMe
AFUWin @ Main BIOS block image checked only is all you need to reflash to reflash BIOS region (Where you edit in the NVME mod edit)
So you can safely flash your NVME mod BIOS via AFUWinGUI if you want, or via AFUDOS (Just don't use /GAN), all you need is /P = program main block
(05-20-2019, 11:35 PM)Lost_N_BIOS Wrote: AFUWin @ Main BIOS block image checked only is all you need to reflash to reflash BIOS region (Where you edit in the NVME mod edit)
So you can safely flash your NVME mod BIOS via AFUWinGUI if you want, or via AFUDOS (Just don't use /GAN), all you need is /P = program main block

I CONFIRM this BIOS works. Unable to flash without using FreeDOS bootable USB. Also did have to include /GAN ... was quite worried but it worked. Cleared my Service Tag#, which I re-entered. Installed the new Samsung 970 EVO then used Samsung mitigation software to clone after installing the Samsung NVME Windows 10 driver. Removed my older SATA SSD (850 EVO) after shutdown and the system booted nicely from the 970 EVO.

Attached Files Thumbnail(s)

Forum Jump:

Users browsing this thread: 1 Guest(s)