Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Aurora R4 NVMe bios support
#1
Hey all,

So my question is if it's even possible to mod the Alienware Aurora R4 A11 BIOS for the x79 chipset to enable native PCI-e x4 and NVMe support?  For reference, I'm using a PCI-E x4 to M.2 adapter with a Samsung 960 pro 500gb.  Windows recognizes the drive when I boot off my SATA drive, but I want my PCI-E drive to be my os drive and the BIOS can't see it, the windows uefi bootloader can't boot from it and no settings in my bios change anything, it's constantly just giving me an error message "Windows can't boot, files missing" with the option to try again.

Thanks in advance,
find
quote
#2
I have an Aurora R4 motherboard (x79) with BIOS revision A11 and have modded BIOS. I am booting off a single SATA SSD (Samsung 840 Evo 1tb) on Windows 10 x64 (1903) in Secure Boot.

Question is:
- If i apply the modded BIOS, can i still boot fine with my current setup? Will it affect boot-ability of my current setup?
- I am provisioning this when I upgrade my SSD to an nVME drive that I intend to do a fresh install of Windows 10 (which I can disable Secure Boot, Fast Boot, CSM later)

NVME drive I plan is - Adata XPG SX8200 Pro
NVME PCIe x16 adaptor - https://www.lazada.com.ph/products/magid...99057.html

UPDATE
I followed the instructions on modding my BIOS to allow NVME boot here - [/url][url=https://www.win-raid.com/t871f50-Guide-How-to-get-full-NVMe-support-for-all-Systems-with-an-AMI-UEFI-BIOS-303.html#msg77107]https://www.win-raid.com/t871f50-Guide-How-to-get-full-NVMe-support-for-all-Systems-with-an-AMI-UEFI-BIOS-303.html#msg77107


*UPDATE* - this does not work. Use AFUDOS.
I was able to flash my modded Aurora R4 A11 BIOS using AFUWIN for APTIO4 (https://ami.com/en/?Aptio_4_AMI_Firmware...tility.zip - under \afuwin\64\afuwin64\AfuWin64\AFUWINGUIx64.EXE)

I just programmed the Main BIOS Image, checked Do Not Check ROM ID and Restart After Programming
[Image: YASNlpx.png]

Link to original A11 BIOS file - http://s000.tinyupload.com/index.php?fil...6924655120
Link to modded A11 BIOS file - http://s000.tinyupload.com/index.php?fil...8208490510

So far, I am still able to boot (in Secure Boot) Windows 10 using my SATA SSD.

Will post an update once I have an NVME drive to do a fresh install of Windows and boot directly off of it.
find
quote
#3
Update#2

Just use the AFUDOS in this link to flash your AuroraR4
https://www.bios-mods.com/forum/Thread-G...EFI-Aptio4

In AFUDOS, just use the format
AFUDOS biosfile.bin /GAN

[Image: gwJVDIs.png]

*Update* - Using my Xeon E5 2670 CPU:
[Image: WXYlqAn.png]
find
quote
#4
IF AFUWIN you linked works as you suggested in second post, then no one should risk using AFUDOS w/ /GAN instead of the AFUWIN method
Since /GAN can mess things up pretty badly if it goes sideways.

Thanks for posting your mod BIOS, I'm sure it will help many users
find
quote
#5
Correcting myself
  • AFUWIN utility did not work for me. Did not find any AFUWIN utility that can run with /GAN parameter. When I mentioned that AFUWIN worked, was only when i only flashed the Main BIOS Image (when I programmed all blocks or even just the Boot Block, it showed an error saying 18 - Error: Secure Flash Rom Verify fail)
  • AFUDOS worked for me. I feel nervous trying it as it is bordering to blind-flashing.
find
quote
#6
Updated BIOS file containing the following fix

Based on A11
- Native NVMe booting via PCIe adaptor
- Microcode fix for Spectre bug
- Updated NIC firmware
- Updated RST firmware to support RAID TRIM

Please refer to the link of the BIOS file as well as AFUDOS (need to run natively on USB-BOOT DOS and not DOS Box)
http://s000.tinyupload.com/index.php?fil...7579325788

Aside from that, here's the update to fix Intel ME bug
Please refer to the link of the Intel ME FW updater
http://s000.tinyupload.com/index.php?fil...2204820694

You may run it in Windows (x64) by typing
FWUpdLcl64.exe -f 8.1.70.1590_1.5MB_PRD_RGN.bin
find
quote
#7
I've upgraded to a Samsung 970 EVO 512gb and experienced ultra-fast bootup here!
https://www.youtube.com/watch?v=PlaHc1O31y8
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in