Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
You have to register before you can post on our site.



Latest Threads
[REQUEST] Lenovo IdeaPad Y580 (5DCNxxWW)...
Last Post: B@sker
Yesterday 07:21 PM
» Replies: 89
» Views: 31850
[REQUEST] Lenovo G40-70 (9ACNxxWW) White...
Last Post: Dudu2002
Yesterday 04:03 PM
» Replies: 23
» Views: 7303
[REQUEST] Lenovo Ideapad 320-15IKB (4WCN...
Last Post: Dudu2002
Yesterday 11:52 AM
» Replies: 14
» Views: 6793
[REQUEST] Lenovo L480 (R0QUJ32W) Whiteli...
Last Post: Dudu2002
Yesterday 11:49 AM
» Replies: 3
» Views: 0
[REQUEST] Lenovo X270 (R0IETxxW) Whiteli...
Last Post: thinkpadx270
Yesterday 10:27 AM
» Replies: 12
» Views: 2602
Request: Nitro 5 AN515-45-R0B6 BIOS unlo...
Last Post: Phanhai
Yesterday 01:09 AM
» Replies: 16
» Views: 1677
Abit KN9 Ultra AM3 support Request
Last Post: Byundai
06-03-2023 08:38 PM
» Replies: 167
» Views: 112430
[REQUEST] HP Compaq dc5750 Microtower BI...
Last Post: Byundai
06-03-2023 02:41 PM
» Replies: 2
» Views: 3781
[REQUEST] HP cs0000ne BIOS unlock
Last Post: galacticwarrior449
06-03-2023 06:18 AM
» Replies: 0
» Views: 0
Asus Zephyrus GX701GXR Bios unlock
Last Post: klyma
06-02-2023 01:37 PM
» Replies: 0
» Views: 0
Acer Predator Helios 300 PH317-51 Unlock...
Last Post: Dudu2002
06-01-2023 02:30 PM
» Replies: 41
» Views: 32821
[Request] Unlocking advance menu in Leno...
Last Post: Dudu2002
06-01-2023 02:28 PM
» Replies: 3
» Views: 1018
Help! how to add slic 2.1 to main asus H...
Last Post: phuth
06-01-2023 06:45 AM
» Replies: 0
» Views: 0
Bios MOD Lenovo L390/ Wifi support MacOS
Last Post: PoMpls
06-01-2023 03:33 AM
» Replies: 0
» Views: 0
[REQUEST] Alienware x17 R1 Bios Unlockin...
Last Post: w1ll1s080911
05-31-2023 11:02 PM
» Replies: 2
» Views: 365
Samsung R60 plus
Last Post: Aljoscha
05-31-2023 04:09 PM
» Replies: 12
» Views: 10420
[REQUEST] ACER Extensa 215-23 bios mod r...
Last Post: coolwaves4all
05-31-2023 03:06 PM
» Replies: 2
» Views: 0
[REQUEST] Acer Nitro 5 AN517-54 BIOS Unl...
Last Post: Dudu2002
05-31-2023 01:16 PM
» Replies: 7
» Views: 0
[REQUEST] Acer Nitro 5 AN515-54 BIOS Unl...
Last Post: 34kon
05-31-2023 11:17 AM
» Replies: 64
» Views: 20875
[REQUEST] Lenovo G710 BIOS Whitelist Rem...
Last Post: alex 177
05-31-2023 06:42 AM
» Replies: 557
» Views: 122407

Dell Inspiron 530 / 530s v1.0.2 Experimental Unlocking & Upgrading Project
I managed to brick my 530s flashing the bios. I bought a replacement bios chip from eBay, but after doing some research, I think that the chip is soldered onto the motherboard?

Attached Files Thumbnail(s)
(12-29-2010, 03:29 PM)Dansolo Wrote: New development for the 530 1.0.18 BIOS... experimental, though. I unlocked some options with modbin6, which corrupted the BIOS, so I extracted the _en_code.bin and _item.bin only and put them into a working version. I bolded that for the people that were talking about using modbin6. Do not mess with it if you're not prepared for the possibility of corruption and thus having to get around it like I did here. I don't know if the overclocking options will work but they should be there now, though there are only a couple of things unlike the 1.0.2...

I took the latest Intel AHCI ROM that I have, 1.20E.0027 and changed the device ID to correspond to the original ISA Phoenix AHCI BIOS device ID and fixed the checksum. I also enabled the AHCI option. I do not know if this will work due to changing from Phoenix to Intel AHCI.

RAID 8.7.0 ICH9 is in there and I know it works from a previous mod that I did that did not contain an AHCI ROM. It worked without needing AHCI. It is possible that adding a different AHCI version to this ROM will break RAID as well if it tries to load and fails.

I updated the VGA BIOS from 1471 to 1653 and the Intel LAN PXE ROM from 1.2.50 to 1.3.63.

I was going to update the CPU microcode but CBROM crashes when touching that. (It also corrupts the BIOS... good thing I made a backup before I tried this.)

This is EXPERIMENTAL. Try at your own risk! And make sure you have the appropriate system for it because there seems to be different revisions or something.
Aaaand here's one for 1.0.2... Took the ROM from the original post and:

-Enabled more options, nothing too special, and grabbed _item.bin and _en_code.bin with CBROM, again, to keep the BIOS out of modbin6's corrupting habits.

-VGA BIOS 1471 -> 1533 -> 1653 (found this 12/30, so I updated the file again)

-Realtek PXE 2.37

-RAID 8.7 ICH9. Don't know if it'll work.

-Same AHCI trick with 1.20E.0027. Don't know if it'll work. I don't even know if this ROM expects the same AHCI device ID, and would guess that it does NOT, so this part is probably even less likely to work here. Though a missing AHCI BIOS wouldn't brick a computer (hasn't yet in my experience, anyway). EDIT: I decided to just keep the same device ID but also add another AHCI ROM with the ICH9 device ID of 2923, so hopefully one of the two will work. File was updated a few minutes after I put the first one up.

Same caveats from the last post for 1.0.18. This is experimental! I do not own this computer and cannot test it!

First, let me start out by saying I would HIGHLY recommend breaking this into 2 threads.
This thread has the Inspiron 530b/530Sb in the OP, however, there is quite a split between Inspiron 530 models.

There are several variations of the Inspiron 530 and they break into two complete incompatible BIOSs. helps identify different models, but doesn't help with identifying which BIOS is needed (Though entering your Service Code on the support page will).

Basically, as far as I can tell, it breaks down into regular mid-tower vs slimline. The regular tower uses the 2MB 1.0.16/1.0.18 BIOS, the slimline uses the 1MB 1.0.2 BIOS. However, this summary breakdown may not be completely accurate.

My process:
I have an original Inspiron 530 that has the 1.0.18 BIOS already in place.

The flash program included in the first post does not work with the 2MB BIOS. So I downloaded the BIOS updater from DELL, and of course it is packaged as an EXE with little flexibility. I ran the flash utility, copied the data it extracted from the temp directory, removed their bios, and created a batch file with their launch command so the flasher would work. One note, I had to tell the flash utility that this BIOS was version 1.0.19 so it would run. Not to worry anybody reading this, after flashing, the actual BIOS revision will remain 1.0.18. I have attached the WinFlash files required below, just drop in the 1.0.18 Bin from the post on page 3, and run launch.bat (or if you need to change the bin name, just edit it inside the launch.bat file).

My results:
I was able to flash the BIOS after a bit of fiddling around. There are no actual overclocking options available in the BIOS, however, there are a few more tweaking options now. I am now able to toggle C1E, which is the primary feature I was looking for (Disabling C1E helps SSD performance). I have no idea why Dell won't give the C1E option.

AHCI does not appear to work. Under the stock BIOS, I was in "RAID" mode with a single SSD (which is the only way to get AHCI with stock BIOS). After switching to the modified BIOS, I tried AHCI, but it would quickly crash and reboot during windows startup. Back to RAID, and everything is fine.

One oddity, when I disable full screen logo, I get an error "No timer tick interrupt!" which requires F1/F2 to continue, which did not occur under stock BIOS. If I leave full screen logo enabled, I get no warning or request for F1/F2. This was not an issue under the stock BIOS. All internet searches state this is usually a bad MB or CPU, however, I don't think that is the case here, everything is still stable.

Attached below is a CPU-Z dump for information purposes and the required WinFlash files needed for the 1.0.18 BIOS (see description above).

Attached Files
.txt   inspiron530.txt (Size: 70.72 KB / Downloads: 526)
.zip   Dell 530 1.0.18 (Size: 47.21 KB / Downloads: 751)
It would be really great to upgrade the RAID Option ROM to version 10.5 or above. This is necessary to support hard drives bigger than 2TB.
How is this going for everyone? I have a inspiron 530slim and would like to overclock it. I may toy with other settings but overclocking is my main concern I think it's the 1.0.2 bios
I have been searching for a means to change the BIOS on the Dell 530 for some time now, since there have been some questions regarding the bios chipset and what size is possibly on the MB I am going to try and include some photos of my system.
    Supply swapped out once I began adding to the case

The following are shots of the tags within the MB, cpu-z shows it working as a Rev2 board. The BIOS chip is located in the top right corner of the mb as you look at it...
As an after thought ... not to show my age here, as I crawled out of the C-64 age the older bios's panned out by companies like Dell and Phoenix (pre sellout) used a 2-3 key combo to unlock the closed or blocked sections of the BIOS that these companies felt were over the top for the averagae user. Has anyone searched for one of these tricks to be used for the Dell Techs... there are also tools out there called Dell Unlock Tool for restoring a tanked PC bios.
MAy wish to check into those if your planning on testing this bios mod.
Found this ...

Phoenix Technologies - Phoenix BIOS, Phoenix-Award BIOS
•Press Del during the Power On Self Test, immediately after the computer starts.
•Many older Phoenix BIOS systems required Ctrl+Alt+Esc, Ctrl+Alt+Ins, or Ctrl+Alt+S to access BIOS.

If you're still having troubles entering BIOS or can't figure out what company supplied the BIOS on your motherboard, here are some keyboard commands you might want to randomly try in addition to the any of the ones listed above:
•Ctrl+Alt+Shift+Del (using Del from the keypad)
•Fn+[any "F" function key] (on some laptops)
Hi all,

I have a G33M03, the one that supports the core 2 quad. This is my main computer, and I am partially open to testing, as long as it doesn't brick my motherboard as that is the last thing I need. I am totally open on wrecking my operating system, so feel free to try to test a bios on me that destroys my os. I would love to overclock on this computer, would like to hit 3ghz. Apparently, I looked at the specs of my dell, and I got the core 2 quad q6600 with g0, meaning it's much easier to overclock that the b3 one, but the only thing that's holding me back is the mobo. I am upgrading to haf 922 and cx600 power supply, parts have already arrived and waiting to be installed. So I do hope someone could crack the bios for overclock and have it work. Thanks.
The Dropbox link is broken, Please fix Smile
It's broken because it bricked too many mobos?
Thanks Willis - after reading your post things made more sense (differences between the 530 slim and mini tower). I have the same mini tower (and same Foxconn G33M02 mainboard running the 2MB 1.0.18 Dell BIOS) as you, and updated mine successfully using your flasher and modded BIOS - it works well! I now have the RAID 0, 1, 5, 10 options, and C1E disable option (for my SSD). Can't test the "lack of a bootable CD in raid mode" that scotay mentions on p4 as have that running through SATA PCi card due to lack of ports. (Frustratingly, I noticed that the mainboard does have two more SATA ports onboard (ports 2 & 3) but they do not have connectors soldered; these show up in the BIOS but are greyed out!) Thanks again! Smile
Considering the Vostro 400 Quad Q33M03 system I have is practically identical to the Inspiron 530 quad-core system, will I have any issues if I try and flash 530 BIOS to my system via DOS? Old links point to TheLostBrain for modded Vostro 400 BIOS that supports RAID 0, but that site is long gone and I can't find any mirrors or repackages anywhere for Vostro 400s.

Forum Jump:

Users browsing this thread: 5 Guest(s)