Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Latest Threads
[REQUEST] Lenovo IdeaPad U330, U430 & U5...
Last Post: Dudu2002
Today 07:10 AM
» Replies: 469
» Views: 98226
[REQUEST] ASUS P5G41T-M LX Bios Mod Requ...
Last Post: osmnszn
Today 06:01 AM
» Replies: 0
» Views: 43
[REQUEST] Lenovo G500 (78CNxxWW) Whiteli...
Last Post: Manoeler
Today 05:30 AM
» Replies: 1258
» Views: 233948
BIOS UNLOCK ASUS laptop
Last Post: misha_lox
Today 04:36 AM
» Replies: 0
» Views: 46
HP ProDesk 600 G4 support for 9th gen CP...
Last Post: xtinct16
Yesterday 08:53 PM
» Replies: 0
» Views: 68
[Request] Unlock advanced BIOS GKCN54WW ...
Last Post: genius239
Yesterday 07:42 PM
» Replies: 1
» Views: 79
[Request] Zotac Magnus One AMI Bios unlo...
Last Post: genius239
Yesterday 07:05 PM
» Replies: 56
» Views: 6578
[Request] unlocked/modifyed bios for Del...
Last Post: zantetsuken
Yesterday 06:42 PM
» Replies: 9
» Views: 494
Bios R0180Z9 Unlock Request
Last Post: robertelo
Yesterday 06:01 PM
» Replies: 0
» Views: 44
[REQUEST] Lenovo Legion 5 (EFCNxxWW) BIO...
Last Post: NS94
Yesterday 05:45 PM
» Replies: 34
» Views: 8483
[REQUEST] Unlock Bios for HP Pavilion Sl...
Last Post: zantetsuken
Yesterday 04:52 PM
» Replies: 0
» Views: 78
Asus eee 1015B POST Memory test missing
Last Post: bbdra
Yesterday 04:13 PM
» Replies: 0
» Views: 70
[Request] Asus X515DAP BIOS Unlock
Last Post: Drift
Yesterday 02:56 PM
» Replies: 0
» Views: 80
Insyde Bios Image Extraction
Last Post: Budgeteer
Yesterday 02:20 PM
» Replies: 0
» Views: 65
Lenovo flex2-14 whitelist remove
Last Post: Dudu2002
Yesterday 01:58 PM
» Replies: 1
» Views: 102
[REQUEST] Lenovo G780 (5ECNxxWW) Whiteli...
Last Post: Dudu2002
Yesterday 01:56 PM
» Replies: 950
» Views: 263726
HP MCP61PM-HM (Nettle2) 5.27 With Unlock...
Last Post: sars
Yesterday 09:30 AM
» Replies: 867
» Views: 689323
[REQUEST] Lenovo G580 (5ECNxxWW) Whiteli...
Last Post: Dudu2002
Yesterday 04:51 AM
» Replies: 2089
» Views: 491563
[REQUEST] Lenovo Y50-70 (9ECNxxWW) BIOS ...
Last Post: Dudu2002
Yesterday 03:43 AM
» Replies: 2332
» Views: 605614
[REQUEST] Asus GL703GM BIOS Unlock
Last Post: xHasker
07-02-2022 04:36 PM
» Replies: 23
» Views: 2234

Dell Latitude E5420 BIOS Recovery
#1
Hello,

I apologize in advance if I am posting this in the incorrect forum section.

Relevant SPECS:
[spoiler]
Model: Dell Latitude E5420
CPU: 2520M
Chipset: HM65, ME7.x 1.5 MB
BIOS Type: EFI / Phoenix (as reported by Phoenix Tool)
BIOS Ver: A14
[/spoiler]

Intro: After selling my old laptop, instead of purchasing a new laptop, I simply bought an E5420 motherboard, its DC cable, charger, and its ethernet daughter board. I use this as a mini-desktop replacement. I was using an eGPU via PE4C w/ GTX 970.

Cause of Problem: I dumped my ME FW and modified it using FITC to enable PCIe x2 and proceeded with flashing it in DOS. I later learned that the FITC for ME7 was bugged because it produces corrupted FW images which caused a semi-brick.

Symptoms: Startup is exceedingly slow. While I am still able to access its BIOS settings, the system halts during the last step of POST which is when the BIOS sends the End Of Post message to the ME FW. The error message displayed is: "Error sending End of Post Message to ME" and the system halts. Unresponsive to CTRL-ALT-DEL which is the hotkey for rebooting during POST.

Attempted Troubleshooting: Initially, I tried using my programmer to flash my backup ME firmware but my programmer does not support the flash chip MX25L1606E however it DOES support MX25L1606. Afterwards, I purchased its keyboard and tried to perform BIOS recovery using various filenames and key combinations but I do not know the correct filename or key combo. Googling this is extremely difficult because there is little to no information for the E5420. Using Andy's Phoenix Tool (which is supposed to return the correct BIOS recovery filename) gives me gibberish (I tried it anyway).
I have also tried removing the CMOS even though I suspected it not to work since the issue lies with the ME FW. Have also tried switching/removing the RAM sticks around as well as removing the CPU then powering on, turned it off and put CPU back in to maybe refresh/reset some NVRAM variables but to no surprise, it did not help.

Request: What can I do? Does anyone know the correct parameters to initiate BIOS recovery on the Dell Latitude E5420? Which programmer should I purchase?

I have attached a zip containing the stock BIOS from Dell's site as well as the decompressed image produced by Phoenix Tool (I think it's HDR, but has no extension by default).
find
quote
#2
Restart the computer.

Press and hold the CTRL key + ESC key on the keyboard until the BIOS Recovery page appears.

On the BIOS Recovery screen, select Reset NVRAM (if available) and press the Enter key. Select Disabled and press the Enter key if you wish to save the current BIOS settings.

Select Recover BIOS and press the Enter key to start the recovery process

For another solution check Dell Latitude E5420 Manual- guideusermanual.com/product-name-latitude-e5420-manual&po=344620&lang=English
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)