Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Latest Threads
[REQUEST] Acer Aspire E5-575(G) BIOS unl...
Last Post: Dudu2002
Today 04:25 AM
» Replies: 138
» Views: 50532
MSI MS-6570 K7N2 Delta L/ILSR BIOS mods
Last Post: chaoshusky
Yesterday 09:19 PM
» Replies: 0
» Views: 0
[REQUEST] Lenovo Thinkpad Edge E430 & E5...
Last Post: bob7224
Yesterday 07:48 PM
» Replies: 515
» Views: 120695
2011 MacBookPro8,3 add Ivy Bridge CPU su...
Last Post: dosdude1
Yesterday 04:21 PM
» Replies: 0
» Views: 0
[REQUEST] Lenovo Z410 & Z510 (8DCNxxWW) ...
Last Post: Dudu2002
Yesterday 12:29 PM
» Replies: 555
» Views: 119784
[Unlocked] Acer Aspire One D250
Last Post: maxluan2709
Yesterday 12:13 PM
» Replies: 2
» Views: 4898
HELP Lenovo ideapad 3 15alc6 crisis reco...
Last Post: dicapo
Yesterday 11:37 AM
» Replies: 0
» Views: 0
[REQUEST] Lenovo Thinkpad X1 Carbon Gen ...
Last Post: Dudu2002
Yesterday 06:39 AM
» Replies: 32
» Views: 10072
On site repository for INSYDE unlocked B...
Last Post: happydance
Yesterday 05:21 AM
» Replies: 85
» Views: 204180
[REQUEST] SONY VAIO VPCSE2MFY BIOS
Last Post: rezilienza
Yesterday 01:46 AM
» Replies: 0
» Views: 0
NVMe for ASUS SABERTOOTH Z77
Last Post: derWalter
11-29-2022 06:35 PM
» Replies: 15
» Views: 17472
[REQUEST] Lenovo G710 BIOS Whitelist Rem...
Last Post: Dudu2002
11-29-2022 04:07 PM
» Replies: 552
» Views: 122407
[REQUEST] Lenovo Y50-70 (9ECNxxWW) White...
Last Post: Dudu2002
11-29-2022 03:17 PM
» Replies: 1970
» Views: 394338
Packard Bell TE11HC: HM70 mod to accept ...
Last Post: Pucel_a
11-29-2022 08:55 AM
» Replies: 7
» Views: 0
[REQUEST] A55BM-K unlock
Last Post: Dennis50300
11-29-2022 05:21 AM
» Replies: 13
» Views: 3780
[REQUEST] Lenovo Thinkpad T440p (GLETxxW...
Last Post: Dudu2002
11-29-2022 04:29 AM
» Replies: 682
» Views: 154529
ASUS P9D-I NON-ECC RAM SUPPORT
Last Post: Daniel6745
11-28-2022 05:56 PM
» Replies: 0
» Views: 0
HP Bios Unlock
Last Post: filmmaker11736
11-28-2022 02:44 PM
» Replies: 0
» Views: 0
Acer predator orion 3000
Last Post: neogamer0909
11-28-2022 12:48 PM
» Replies: 27
» Views: 1870
Samsung NP300E5Z-S06AE: upgrade i5-2450m...
Last Post: georgekevorkian
11-28-2022 09:29 AM
» Replies: 2
» Views: 0

GA-EP45-DS3R rev. 1.0 4TB support
#1
Hi guys, first of all, great job you're doing. And now my request. Is it possible to get support for 4TB drives for my mobo? I'm using BIOS version F11c.

Here's the link for BIOS downloads:
http://www.gigabyte.com/products/product...=2842#bios
(although that version isn't on Gigabyte web anymore)

I have 8 HDDs and bought new 4TB WD Red and I really can't afford to change my whole rig because of 1 HDD.

Thanks!
find
quote
#2
I updated the F11e beta bios for the GA-EP45-DS3R Rev 1.0 with the following changes:

ICH10R southbridge - v13.1.0.2030
8111C ethernet - rtegrom259.lom
AHCI-pchahci_1.20E

The 4TB WD Red appears to be a conventional SATA drive (non-SSD). The beta bioses Gigabyte provided for similar MB had changes that would work with a SSD but give trouble with the motorized ones. If you have a problem, let me know and we can update the F10 bios or a F11 non-beta bios if you have one of those.

I'm currently using Intel RST 13.0.1.1000 with the above OROM without any trouble.
find
quote
#3
Thank you very much for VERY fast reply. Could the troubles you mentioned result in data loss? Because I already have my 4TB HDD almost full so I don't wanna loose any data. Maybe it would be safer to update the older F10 version?

Regards
find
quote
#4
I updated the F10 bios for the GA-EP45-DS3R Rev 1.0 with the following changes:

ICH10R southbridge - v13.1.0.2030
8111C ethernet - rtegrom259.lom
AHCI-pchahci_1.20E
find
quote
#5
Hi gto4ben, thanks for your trouble, I'm sorry to report that provided BIOS updates didn't work (neither F11e nor F10).

So here's what I did:
1) Successfully updated my BIOS with files you provided. No errors there.
2) Rebooted and entered config with only 2 drives connected, system Intel X25G2 and WD20EARS.
3) I then set the SATA mode to AHCI, rebooted and none of my drives were recognized. And the AHCI BIOS doesn't pop up at all like in my original F11c BIOS.
4) Then I tried RAID mode, I get the Intel OROM pop up and drives are recognized, but Windows 7 doesn't load. It gives me a BSOD (STOP 0x0000007B...)
5) Only way I can boot is to set to IDE mode. All the drives are recognized and Windows boots up normally, but the drivers revert to non-AHCI automatically.

I did this with both updated versions, as I mentioned. So I reverted to my old F11c BIOS, and everything works normally.

Do you have any idea what would be the problem here? The trick is the AHCI part maybe, because I don't have the AHCI BIOS screen.

Regards
find
quote
#6
All windows OS have trouble with booting from ACHI if the OS was installed with IDE and vis versa. There is a tool that is supposed to make it easier so if the bios is set to AHCI, you can avoid the BSOD.

If your previous F11C bios has a pop up that allowed you to do switch AHCI/IDE, it sounds like I should preserve the old AHCI OROM in the bios to make life easier. Attached are the following updates.

F10 bios for the GA-EP45-DS3R Rev 1.0 with the following changes:

ICH10R southbridge - v13.1.0.2030
8111C ethernet - rtegrom259.lom
original AHCI - ICHAAHCI_F10

F11e bios for the GA-EP45-DS3R Rev 1.0 with the following changes:

ICH10R southbridge - v13.1.0.2030
8111C ethernet - rtegrom259.lom
original AHCI - ICHAAHCI_F10

I don't know which AHCI OROM your F11C bios has. If you send me this bios, I'll just update the Intel RAID OROM. That should give you what you need and preserve everything else.
find
quote
#7
Hi, thanks again for your trouble.
The OS was installed with AHCI and my drives weren't even recognized with pchahci_1.20E, so that's not the issue.

I tried the latest version of your ROM update, that contains old AHCI, and my drives were recognized. The problem is again my 4TB drive. The drive was formatted and copied to, when it was connected to Adaptec 5805 controller (which has support for 4TB drives). But when I connect that drive to motherboard, I see the 4TB partition, but I get strange behavior. Some files I can access, some I can't. I see them, but I get error opening file. I presume it's because of the motherboard's old AHCI. And I can't install Intel Rapid Storage 13.xx, says my platform isn't supported.

Regards
find
quote
#8
Since your drive can be partially read, have you performed a chkdisk /r on it to see if Win 7 can fix it? The older Intel OROMs had a bug that caused data corruption when they are trying to enter power saving mode. I know the Intel 12 series and up don't have this problem.

There may be incompatibility across the Adaptec and Intel HD SATA controllers. When the HD was connected to the Adaptec Controller, did you use the Adaptec Storage Manager Software or did you use the Windows Disk Management? I would expect a better result and compatibility if the HD was setup as a simple volume or JBOD using Windows Disk Management. Once setup on the Adaptec, you may be locked into using Adaptec cards if you want to access your data correctly. The chkdisk /r may be able to correct what the incompatibility caused.

In the past, I tried to use a HD that was setup on a Promise Controller and move it to an Intel controller. I got a similar problems that you are experiencing. I then reinstalled the Promise controller with the old drive and setup a new drive using the Intel controller. I transferred the data and then started fresh on the old drive using the Intel controller. No problems with data after that.
find
quote
#9
Hi

I would also be interested by these BIOS mods but I can't see any attachements ?

Is there an issue with my forum profile ?

Thank you
Best regards
find
quote


Forum Jump:


Users browsing this thread: 5 Guest(s)