Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Machine not booting after BIOS flash
My machine has an MSI 7529 (G31M3-L V2) motherboard, and I am running Win 7.

I was getting an endless succession of crashes and BSOD's, and after trying a number of "things" I decided to update the BIOS by flashing it with the latest version.

I backed the BIOS up to a ROM file before doing anything.

I downloaded the prescribed BIOS update software and BIOS ROM file from MSI, and went ahead.  The flashing processing - done from a USB flash drive formatted by Rufus with FreeDOS - went successfully.

I started the machine, got the MSI splash screen, and then messages to say that the BIOS was not set correctly, and take F1 to enter setup, or F2 to load defaults, and so on.

I took F2, and the machine went ahead and booted into Win 7, and I then worked with Win 7 with no problem, and no crashes.

I shut the machine off, and when I went to reboot, all I got was a blank screen.  As far as I can see the BIOS did not even reach POST stage.

I removed both the power cable and the BOS battery, gave it a few minutes, put the power cable and battery back in place, and then rebooted.

Again I got the BIOS not set correctly and F1/F2 messages, and again I took F2, and again the machine booted into Win 7, and again the BIOS would not boot on restart.

I then did the same reset, but took F1, and after this the BIOS would not respond.  It only seems to respond if I take F2.

I also get exactly the same result whether I am booting into DOS from the USB flash drive, or booting into Win 7 from an HDD, so I would assume from this that it is not the drives that are the problem.  The keyboard and mouse are both PS2.  There is also a CD ROM drive that I disconnected.
The issue does not seem to be with the general BIOS settings such as boot sequence and so on, as on the second restart after the reset the BIOS does not seem to reach the stage of actually going into the setup menu.

I also tried getting into the "hidden" options in the BIOS using Alt E1, and CTRL F1. and Shift E1, but nothing happened see

I then re-flashed using the backed up version of the BIOS which I had.  This reset flashing worked successfully, and the machine booted into Win 7, but again I got my succession of crashes and BSOD's.

There is clearly some sort of problem here with either BIOS or the hardware, and if anyone has any suggestions I would welcome them.

I also want to unlock the "hidden" BIOS options, as it is possible that one of these may give me access to a setting will solve the problem.

How do I actually unlock the BIOS, as the method I picked up off the web site I have given above do not appear to work?

Stuart Aitchison

Forum Jump:

Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in