Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Possible to swap audio firmware? HDA Realtek
#1
Hi all,

I have an interesting problem.  I am working on an arcade machine with a bad motherboard.  The software is proprietary.  I was able to find a motherboard with the same chipset as the arcade motherboard that runs the software just fine.

However, I am trying to get a different board - again same chipset - to work, and the game is crashing with a generic error about audio.  Both boards use the Realtek audio codec (ALC892) and have identical specs.

So, I figured it must be something in the BIOS.  I removed the non-working board BIOS chip (call this board #1) and put it in the working board (board #2).  Board #2 which formerly worked now crashes with the same error.  Board #1 will not boot with the board #2's BIOS.

Then I set out downloading BIOS from other manufacturers' boards with the same chipset and hoping for the best.  After several hours, I found a BIOS that will boot on board #1 into the game!  The only issue is, the on-board USB SD-card reader is not working.

I would have to assume there is something different between the 2 BIOS that is causing the game to crash.  My question is - is there a way to copy only over the audio firmware/ROM from the working BIOS and add it to the non-working BIOS?

I have attached both BIOS ROMs.  The AD04 is the original BIOS which causes the game to crash.  The EM50 BIOS is the BIOS that allows the game to boot but without SD CARD reader support.  Is it possible to copy the audio firmware from EM50 to AD04?


Attached Files
.zip   works-EM50AM10.zip (Size: 1.33 MB / Downloads: 5)
.zip   ad04_flashrom.zip (Size: 1.29 MB / Downloads: 3)
find
quote
#2
Anyone? Lost n bios?
find
quote
#3
Both BIOS are setup for HD Audio, instead of AC97, did you notice this, or can that help you wire it differently for the non-working system? This can be changed in the BIOS settings to AC97 for the EM50 BIOS if you wanted to try that instead of different pinout/wiring testing. This same setting not present in the ad04 BIOS, so I guess that's not helpful since it's only in the EM50 Sad

Neither BIOS has rom or modules for Audio, only realtek in either is boot/PXE LAN roms. I checked both BIOS settings for the HD Azalia audio, and both are same, so nothing enabled on one and disabled on the other

Here is three BIOS you can test, one I switched PCI Root Bridge from E50-works to ad04-Not working BIOS, this is only place I found the device ID for ALC892 in one but not the other. This may cause other things to fail, hard to know. And, then there is two BIOS with setup module, AMITSE, and AMITSE/SetupData swapped. If it's due to some setting or config I can't see in BIOS setup itself, this swap might sort it out for you on one or the other.
http://s000.tinyupload.com/index.php?fil...3664673096

I found this, which might be useful info for you too, unsure of the OS situation, but maybe relevant no matter what?
https://www.linuxuprising.com/2018/06/fi...ue-in.html
https://patchwork.kernel.org/patch/9386543/
https://gist.github.com/Brainiarc7/8ff19...233c4866d0

Aside from this, maybe only way to sort the audio or SD issue is if someone can look at and edit the ACPI tables for you (If it's even there), and that's not something I know how to do
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in