Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Power failure while updating bios
I'm new here and don't know how should I ask for help. My apologies . I was updating bios to 5.90 form 5.20 and while updating I faced load shedding issue and pc turned off (73% done). After that turned power on and nothing shows on monitor (it's not posting anything on monitor). I got random code on led which is located on motherboard. Led shows me few random code changing and F2 then F9 and it shows forever.

My motherboard Bios chip model: MX25U12873F

May be my motherboard bricked.

PC Specs: Ryzen 7 1700 Asrock Fatal1ty X370 Gaming X G.skill flarex 3200 Mhz 8GB Corsair MP510 250 GB Asus ROG Strix RX580 OC 8GB

my question is :

1. Is there any way to restore bios?
2. can I flash the chip using "BIOS_PH" header?
3. Can I flash this chip using an external SPI programmer (CH341A based programmers)? If I can flash using external should I desolder the chip?

Current situation: For the COVID-19 pandemic we are in lockdown situation. every service center is close now. and the the lockdown period is not mention yet. I'm a full time freelancer and I need to fix the motherboard asap. I can't effort new one now.

BIOS_PH header image:
[Image: f16t8715p142120n3_vjbTIsXu-thumb.jpg]

Only available flash programmer in my place is:
[Image: f16t8715p142120n2_JWzMypOb-thumb.jpg]
[Image: f16t8715p142120n4_ZjnRsrLz-thumb.jpg]

Please help me to fix this problem.
Hi friend,
only way to unbrick your firmware is to use the SPI Programmer with Pomona Clip.
You showed two models both goods.

Let's see here abput your pc eeprom :

So You have to make a Firmware Dump by the programmer and then I will rebuild your Firmware based on stock bios.
let me know
I'm using CH341A programmer with 1.8v adapter to recover bios. I can read, erase, blank, and write. But after writng program when I try to verify it shows me error "chip with the contents are in disagreement".

The program I use to flash - asprogrammer, ch341 program v1.29 v1.31 (free) 1v1.30. they all shows me same problem.

Bios chip model: MX25U12873F

I downloaded 3.50 version of the bios from asrock website. Motherboard model: Asrock Fatal1ty X370 Gaming X
Downloaded the bios file and simply rename it from "X370GX_3.50" to "bios.bin" then tried to write. I don't know is this the right way or not.
I saw thread that said this problem occur only for poor connectivity. I tried with this SOIC8 SOP8 Flash Chip IC Test Clips and BIOS_Ph header connector but it shows same problem.

is this is the problem with file name or extension?

please help me to recover bios.

Forum Jump:

Users browsing this thread: 3 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in