Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Latest Threads
[REQUEST] Lenovo L420 WhiteList removal
Last Post: WillingMost7
Today 08:23 AM
» Replies: 0
» Views: 0
[REQUEST] Bios Unlock Asus ROG GL552VW
Last Post: Szebike
Today 07:24 AM
» Replies: 203
» Views: 59313
[REQUEST] Dell Inspiron 5548 Bios unlock...
Last Post: WillingMost7
Today 07:07 AM
» Replies: 0
» Views: 0
[REQUEST] Lenovo B590 (H1ETxxWW) Whiteli...
Last Post: Dudu2002
Today 05:33 AM
» Replies: 918
» Views: 272382
Extract Bin from asrock instant flash fi...
Last Post: grandalf
Today 04:51 AM
» Replies: 0
» Views: 0
TerraMaster F2-220 Bios
Last Post: Voigoth
Today 03:07 AM
» Replies: 1
» Views: 0
[REQUEST] Lenovo Thinkpad X240 (GIETxxWW...
Last Post: Dudu2002
Yesterday 06:08 PM
» Replies: 44
» Views: 15807
[REQUEST] Lenovo Y50-70 (9ECNxxWW) BIOS ...
Last Post: Dudu2002
Yesterday 05:01 PM
» Replies: 2350
» Views: 628071
[Request] Adding 7th Gen CPU support to ...
Last Post: xDJoelDx
Yesterday 04:40 PM
» Replies: 4
» Views: 0
[REQUEST] Lenovo Thinkpad T420s (8CETxxW...
Last Post: Niemand
Yesterday 03:15 PM
» Replies: 205
» Views: 71819
SOLVED Samsung AMI BIOS Write-Protection
Last Post: e_favero
Yesterday 10:24 AM
» Replies: 1
» Views: 1253
[REQUEST] HP 1030 G1 setup_extr.txt only
Last Post: sonyu
Yesterday 08:48 AM
» Replies: 0
» Views: 0
[REQUEST] Alienware x17 R1 Bios Unlockin...
Last Post: Zumakeydom
Yesterday 08:47 AM
» Replies: 1
» Views: 365
[REQUEST] Lenovo Thinkpad T430u (H6ETxxW...
Last Post: Dudu2002
Yesterday 07:36 AM
» Replies: 30
» Views: 9106
Unlock GA-P67-DS3-B3 (rev. 1.0)
Last Post: paissi
Yesterday 04:29 AM
» Replies: 26
» Views: 9008
Acer Aspire ZS600 (IPISB-AG Rev 1.06): U...
Last Post: DeathBringer
Yesterday 12:40 AM
» Replies: 13
» Views: 1736
AMD Ryzen Motherboard Crossflashing Thre...
Last Post: sluclikocr
02-01-2023 06:02 PM
» Replies: 1
» Views: 3270
[REQUEST] Unlock Bios Lenovo Yoga Book Y...
Last Post: Cryen
02-01-2023 05:28 PM
» Replies: 1
» Views: 2112
[REQUEST] Lenovo IdeaPad S145-15API (BUC...
Last Post: Dudu2002
02-01-2023 02:10 PM
» Replies: 8
» Views: 2809
[REQUEST] Lenovo G780 (5ECNxxWW) Whiteli...
Last Post: Dudu2002
02-01-2023 11:52 AM
» Replies: 965
» Views: 274416

[REQUEST] GL504GS BIOS unlock
#71
No problem, being a 7th/8th gen platform, I had hopes that it may be possible, but now I understand better. If unlocking the options available would be possible I would appreciate it, being able to access the OC functions for undervolt purposes would be very useful. Thank you!
find
quote
#72
I received the PM & flashed the BIOS, it worked great! Thank you so much!

I then tried enabling the iGPU & setting the primary GPU from PEG to auto in order to improve thermals and power efficiency. Unfortunately I did not look at the board schematic before doing so - turns out this laptop has all video outputs attached directly to the NVIDIA GPU, there is no mux. This made it unbootable (black screen on boot, can't enter BIOS blindly to set defaults just through shortcuts like F2->F9->F10). No output on DP or HDMI either. I tried Ctrl+Home to boot recovery, tried shorting JRST2001 & 2002 underneath the second RAM module, tried pulling both CMOS & regular battery, no progress. I don't think any of these methods clear NVRAM values, which is what I think the problem is. I am procuring a CH341A and will try flashing the chip directly. I have attached the board schematic for future "victims".


Attached Files
.zip   GL504GSv2.1.zip (Size: 3.06 MB / Downloads: 2)
find
quote
#73
@varu

On normal laptops ,all graphic signals are output through integrated graphics(cpu) ,and no mux design. so ,now it's boot but no graphic signal output. As long as you only can see option "SG Mode Select" under Switchable Graphics and it's only has Muxless model ,it probaly is this design.


On this old laptop ,it should has a cmos battery ,remove it and wait for minutes can clear cmos. Or try this way , first turn off your laptop then turn on it and hold on the power button more than 40sec until it shut down again. Then turn it on to test if clear cmos is successful.

find
quote
#74
Thank you, I wonder why simply enabling the iGPU would lock it up then! Unfortunately still no luck. If plugged in and I try holding the power button, it turns off after a few seconds and remains off (charging status light also goes off and remains off until release). Upon powerup 40+ seconds later, no change. If I do the same on battery only, the behaviour is identical except once it turns off the fans also spin up to their max speed and remain so until I release the power button - also with no change after 40+ seconds.

Unplugging the CMOS battery also has brought no change, I left it unplugged for hours, also unplugged the main laptop battery.

I have added the official BIOS renamed to both ASUS.BIN and ASUS.CAP to a small FAT16-formatted drive, but recovery has not started. I am not sure how I could trigger BIOS recovery.

I have acquired a CH341A, modified it for 3.3V, and soldered to test points right beside the chip. Unfortunately I am unable to flash it on the board, the CH341A stops registering as soon as the wiring adapter is plugged in - presumably as it's trying to power up far more than the chip itself. Being WSON8 I would need to unsolder it with a hot-air station and solder it to a specific WSON8 adapter - this is the next step on the list. If you have any further ideas or something I can try before carrying out such invasive tactics, please let me know! I appreciate all your help so far!
find
quote
#75
@varu

1. It should easy to revert bios by clear cmos if only some wrong bios tweaks. Not only tune igpu ,but you did other options? Such as directly tune "Core Voltage Offset" in the bios?? I don't think it is only a simple wrong bios setting.

2. Wson8?? on 8th gen asus laptops ,it still should a sop8 chip and it near the south bridge. I've never touch CH341A so i can't give you any suggestions ,but you can find many instructions about it on the internet.

3. Just out of curiosity ,on normal programmer the work voltage is 3.3v~5v ,it didn't need to modify. But if you wanna read a low unlodervolt chip(such as 1.8v) ,you need a 1.8v adapter.

find
quote


Forum Jump:


Users browsing this thread: 2 Guest(s)