Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[REQUEST] Lenovo IdeaPad U330, U430 & U530 (7CCNxxWW) Whitelist Removal
#1
Hi there, been trying to do this myself, but no luck Angry

the thing is, my intel 5100 died on me, and I'm trying to use atheros 5007 card...

intel card (original) : PCI\VEN_8086&DEV_4237&SUBSYS_12118086&REV_00
atheros (non-original): PCI\VEN_168C&DEV_001C&SUBSYS_7131144F&REV_01

link to bios download

afaik, it's Insyde not RSA signed
if any further info is needed, I'll be glad to provide it
find
quote
#2
http://dl.dropbox.com/u/45117524/bios-mo...miloml.exe

I wait your news Wink

BIOS REPOSITORY.Please consider donating (me or forum) if you like my work.
Please remember to come back and leave feedback. I hate leech and disappear thing.

Nice day.
Camilo.
find
quote
#3
now this is what I call ultra fast respond !!!
but, after flashing with InsydeFlash.exe it gave me an error again:

104-Unsupported wireless network device detected.
System Halted. Remove device and restart.

I'm just curious, what did you do ?
I tried to open it with andy phoenixtool, tried to isolate moduls, found 86 80 37 42 in one of them (can't remember what was it named, something like A95.....) then I changed value to 8C 16 1C 00, hit ok within andy phoenixtool, and that was it...
couldn't find any other hex values in any other moduls, even tried using IDA pro free and search through whole file, no luck...

did you do the same thing or did you try to remove whole whitelist checking thing ?
find
quote
#4
Sorry, i'm dumb sometimes Smile

I packed again the unmodded one Smile lack of sleep, u know.

Download again from same link, it's packed now the modded one.

BIOS REPOSITORY.Please consider donating (me or forum) if you like my work.
Please remember to come back and leave feedback. I hate leech and disappear thing.

Nice day.
Camilo.
find
quote
#5
no one who can do this kind of stuff is dumb !!!
it works mate, it really does, I just need to tape over my pin 20 and it should be good...[censored], it really works...
REP UP !!!!
now, I'm curious, how the hack did you do this...I mean, I still get error message, it is there for about 2 secs, and whole thing just continues to boot, like nothing happened, so, I assume every card should work from now on ?


edit: thing really works after taping that pin on card, thanx mate, really, thanx a lot !!!
find
quote
#6
Yes, i just patched the endless loop that hangs the machine and forces to power off and remove card. So it will complain when you insert an usupported card, but will boot anyway Smile

I can try to remove the message if it disturbs you.

BIOS REPOSITORY.Please consider donating (me or forum) if you like my work.
Please remember to come back and leave feedback. I hate leech and disappear thing.

Nice day.
Camilo.
find
quote
#7
haha, thanx a lot, message is find, no need to remove it Wink
I just need to figure out how to make it to work in linux too
windows are fine, but in linux, it is disabled, and I can't get it enabled :/
find
quote
#8
With pin 20 tapped radio is disabled in linux??? Strange.

Anyway i've reuploaded the mod without the 104, just clean boot. On same link.

BIOS REPOSITORY.Please consider donating (me or forum) if you like my work.
Please remember to come back and leave feedback. I hate leech and disappear thing.

Nice day.
Camilo.
find
quote
#9
jeah, very strange, I will try to figure out what is going on with it Wink

thanx again for another bios mod Big Grin
find
quote
#10
Well, i patched it a bit more trying to make the radio working.

Download again and test it Smile Same link Smile

BIOS REPOSITORY.Please consider donating (me or forum) if you like my work.
Please remember to come back and leave feedback. I hate leech and disappear thing.

Nice day.
Camilo.
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in