Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Request] Dell Inspiron 17r SE 7720 Unlocked Bios
#1
Hello,

I am seeking a modded bios for the inspiron 7720 with the unlocked options.

http://www.dell.com/support/drivers/us/en/19/DriverDetails/Product/inspiron-17r-se-7720?driverId=76N71&osCode=W764&fileId=3080131888

This is the link for the latest official bios.

I would greatly appreciate a mod for this if it is possible.

Thankyou Big Grin
find
quote
#2
Well, there are sequences like:
29 02 29 02 0a 82 40 84 a5 02 45 0a 01 00 00 00 00 00 00 00 2f 02 20 02
already on the bios ... considering 0x0a is the content suppression operator.. http://wiki.phoenix.com/wiki/index.php/E...UPPRESS_IF
there is a chance that strings which are in the form of:
29 02 29 02 0a 82 40 84 97 02 45 0a 00 00 00 00 00 00 00 00 2f 02 29 02
and
17 02 29 02 0A 82 40 84 99 02 45 0A 00 00 00 00 00 00 00 00 2F 02 29 02
are actually suppressing some of the menus in the PlatformSetupAdvancedDxe module CFEF94C4-4167-466A-8893-8779459DFA86.
But! There's always a but. There are way to many sequences like that in the module, so it's really hit or miss .. it may enable some menus and disable some along the way.

What we need to determine though to avoid flashing the rom all the times is are you able to seideload the recovery capsule and use the substitute bios of off the flashdrive.

Could you take this file here: https://dl.dropbox.com/u/2573233/17R-SE_...apsule.rar
- Extract the archive, put the BIOS.cap in the root of a FAT32-formatted USB flash drive.
- Shut down your machine and unplug the power lead from the laptop
- Insert the USB with enclosed file in the left most port towards you
- Hold down the End key on your keyboard and insert the power lead into the laptop's socket. Let go of the End key when you plug the power lead in.
Your laptop should start with fan spinning at full speed and your power button will most likely blink. After some ~10 to 15 seconds the fan will cut off and you will be presented with Dell's splash screen. Do whatever it takes to get into the BIOS setup as soon as the splash appears.

If this will work, there's a way for you to test custom bioses without the need for flashing .. so we can tamper around with the Advanced Setup module.
find
quote
#3
Thanks for the speedy reply.

So I followed your instructions but with no luck.

I powered on the comp by holding the end key and releasing it after i plugged in the power lead and then I let the computer run for about 10 minutes but the dell splash screen never came. Also, the USB stick light flashed for a couple seconds then stopped, then turned off.

I checked and my USB was already in the Fat32 format and I also tried putting the usb in other ports.

Not sure if I did something wrong or if it just doesn't work.

Thanks again
find
quote
#4
Ok, in this case we are going with plan B.
Get this toolkit and dump your on-chip bios: http://forums.mydigitallife.info/threads...up-Toolkit
Name the dump BIOS.cap and proceed with the method you've been trying previously...
find
quote
#5
So I followed your instructions with the tool kit and managed to enter the bios, but there were no unlocked options - just the original ones.
find
quote
#6
Of course Smile
You dumped your own bios and side-loaded it from external media. This was a POC to see if it was still possible on new gen of SecureCore Tiano found on your 17R-SE.
Mind sending me the BIOS.cap you've created by using the toolkit ? Attach it here or upload to a sharing page (mediafire for eg). I will try modify the contents of it.
find
quote
#7
Ok great. Big Grin

Here is my BIOS.cap

http://www.mediafire.com/?zphzdnwx8aoczdm
find
quote
#8
Ok, lets see here .. try repeating the same procedure with this one: https://dl.dropbox.com/u/2573233/T1_BIOS.rar
I've swapped some bytes .. not all of the occurrences, just the ones which looked more likely to unlock (or hide lol) something.
find
quote
#9
Ok I gave it a try, but still no changes in the bios.
find
quote
#10
Weird .. are you sure you are loading the bios from FAT32 ?

Try this one ?
https://dl.dropbox.com/u/2573233/T2_BIOS.rar
Went ahead and replaced every occurrence possible .. most likely to hide more things than unlock new menus .. but hey, it's worth a try.
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in