Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED]MSI GP60 Haswell Refresh Support
Hello i am tight situation to get laptop up so i could move to it and sell own pc or i wish so.

this model:
MSI GP60  (Intel HM86)

and with this cpu:

Turns out they never moved on to Haswell refresh platform support. And don't have enough money now to get yet right cpu. PLUS i want to learn or someone educate me what it takes to upgrade to this as i am hungry of knowledge always (disassembly of ford ecu over year and many other things..)  Blush

Anyway i have this with new motherboard laptop and original motherboard was toasted and sadly original cpu i7-4700MQ was toasted too as earlier owner gave up at this point. I did desolder bios chip out and back couple times trying modifying support (microcodes replaced newer - vbios update 2179 - IntelGopDriver module BUT not yet IntelSaGopDriver module! - is this the problem still? ) already but result stays now same: Boot ups with backlight on but black screen just.

Tools used:
MMtool, hxd, UEFItool (this was someone done very nice program).

I use hot air station and no problem soldering i understand details of it.
Oh yes i flash chip outside with universal TL866 crap (once locked amd flash chip and couldnd't unlock it. thanks ruining my day).. and yes i verify it did flash correctly.

Anyone can argue i have elsewhere problem but i will ignore now them. Or that AC plugging charging out in guide i am done it thank you.

MSI support responded that this motherboard model was tested only with i7-4700MQ  which i thought too even though in their manual says dual cores too (which turned now lie that never tested.. surprise!)

I uploaded original and clearly texted modified bios files (or mess to pro's of course they wouldn't want touch even with greatest stick to others mess).

I offer 10USD as start price as thank you for him who helps as coffee money.. and if get today done and booted up laptop fully (i will send paypal) i would be very happy. But of course i try not corrupt anyone by money  Tongue

I be back later of (my time - finnish). I hope this helps to start and showing where i failed.

Attached Files
.zip (Size: 5.96 MB / Downloads: 1)
Post screenshots of first (CPU) & third (Mainboard) tabs of CPU-Z with supported CPU.
Kinda impossible for me sir. Sorry much. Cpu is fried. (Original motherboard had power mosfet went kaboom next to cpu socket with original cpu)

06C3 is cpuid in mmtool i believe i am targeting at. Same than original cpu if helps anything to come over lack of information.

And for til sometime i cant get replacement so i am trying go alternative way. I will sell gpu after i get this booted and get cpu with that.

If any specific info from those tabs you looking is necessary.. point me the way sir. Thank you.
Sorry i am mobile but i found excactly to this model (i remember from top of head only when i see) all you asked.

Over there is many cpuz screenshots. Hope helps.

Included here now. Sorry.


Attached Files Thumbnail(s)
Try to flash this BIOS -
Hi okay i will be back to try that somewhere then 5 hours later. Thank you.
(05-11-2018, 05:11 AM)DeathBringer Wrote: Try to flash this BIOS -

Hi again. I am now tested and with this one it actually goes black again and then back only with backlight and seems trying but still no picture. Tried hdmi output too.

What is IntelSaGopDriver purpose? Many speaking about IntelGopDriver module but not IntelSaGopDriver.
Try -
And - or
#9 I tried that one but it acts like original laptop bios and looking at it it doesn't have Haswell refresh microcodes. I will revert bios modding original and try couple things still. If any ideas to that be free share. Thank you!

A.3 got update on this desktop H81 mb from MSI and IntelGopDriver was updated from
IntelSaGopDriver was updated too as there much difference but comparing to laptop from start it is smaller in size.. 5Kb vs 3Kb in this desktop so i hesitate to update to this.

I will double check E16GDIMS.709 updates... as it have been up sale with this i5 (MSI CX61 2QF laptop)
(05-11-2018, 03:26 PM)xanthefin Wrote: looking at it it doesn't have Haswell refresh microcodes.
Original Haswell and Haswell Refresh CPUs use common microcode.
Version 0x17 is compatible with your i5-4210M.
BIOS E16GDIMS.707 for motherboard MS-16GD supports your CPU -
So you have hardware problem, not with BIOS.

(05-11-2018, 03:26 PM)xanthefin Wrote: I will double check E16GDIMS.709 updates... as it have been up sale with this i5 (MSI CX61 2QF laptop)
Motherboard MS-16GD is used in many MSI laptops.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in