Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
What can you do if your Bios chip seems to be write protected using CH341a
#1
Well I'm now 0 for 2 after years of flashing everything without problems.

This time it is an AOpen DEX4501 (Core 2 Duo, conventional AMI bios). I had it set up with a temporary power supply, and right after the bios was erased (flashing from DOS) the power cut out.

So it appears I have an erased bios--at least when I read it with the CH341a tool. However, it can't identify the actual bios chip, and gives a Code 25 "Write timed out" if you try to program it. (Tried the various versions up to 1.34, which did the least since it it can't ID the chip, it won't let you go any farther.

I tried using the ASProgrammer and again--can't ID chip, but can read and confirm that it is erased (blank check), but when I try to program it just sits, and when I finally cancel I get the message "Possible Protection is enabled".

So deets:

Chip is Winbond 25x16AV -- data sheet is online, and does seem to suggest that there is some write protection, but again, I am out of my depth. (It does show as a chip choice in the ASProgrammer--but not in the CH341 tool where I used the "Common" settings for 25x16 with no success.)

Any experts who can help me out?
find
quote
#2
Looks like I may have been able to solve my problem using a USB recovery stick with just the bios on it>

I followed the suggestions here:

Quote:What you need:
1) Download your BIOS file and extract it from archive.
2) Download HP USB Disk Storage Format Tool.
3) 4096 MB or LESS usb flash-drive.

How to:
1) Open the HP USB Disk Storage Format Tool and format your flash-drive into FAT32 using Quick Format option.
2) Place your downloaded BIOS file on the flash drive and make 6 copies of that file, give them the following names:
---2.1 AMIBIOS.ROM
---2.2 AMIBOOT.ROM
---2.3 E7693AMS.M53 (this is the ORIGINAL name of your BIOS as it is)
---2.4 E7693AMS.M53.ROM (this is the variation of the original name just follow my example based on my original name)
---2.5 E7693AMS.ROM (this is the variation of the original name just follow my example based on my original name)
---2.6 M53.ROM (this is the variation of the original name just follow my example based on my original name)
---2.7 SUPER.ROM
!REMEMBER These all files are just RENAMED copies of your original BIOS file!


https://forum-en.msi.com/index.php?topic=269702.0

Then booted and pressed Control + Home --and it loaded the bios file. Normally it would be AMIBIOS.ROM--but I changed to a smaller drive (It had previously failed on large USB stick) AND changed the file names at the same time, so not sure what was successfully loaded.

Despite absolutely no boot activity up to that point, it found the USB stick when booted (i could see activity), waited just a minute or so, and it popped up with a live monitor and said it was going to reboot!
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in