Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[request] Update microcode in HP BIOS for IPIBL-LB Motherboard
#1
Hi everyone. I'm hoping someone can help me get the bios setup for my HP Pavilion a6303w. Basically I think I need the exact 771 Microcode injected into the bios so it will cooperate with my 775 board and Windows 8.1.

Details:
Purchased used Socket 771 Xeon X5460 SLBBA (12M Cache, 3.16 GHz, 1333 MHz FSB) and the adapter sticker to replace the Pentium Dual Core E2140 in my 775 motherboard.

Previous/Stock CPU: Intel '05 E2140 Pentium Dual Core SLA93 (1.60GHZ/1M/800/06)

OS: Windows 8.1 Pro (64 bit)

Motherboard: IPIBL-LB (Benicia)

Prior to installing the cpu I upgraded to the latest BIOS on the HP website.

Current BIOS Installed = AMI (HP's Version 5.43 which can be downloaded HERE.

Problem: Installed the Xeon CPU and initially the only problem I noticed was the CPU fan immediately ramped up to full speed. Despite this windows loaded and I seemed to notice some performance increase. I ran CPU-Z and noticed it showed the correct processor but it listed 2 only 2 cores and 2 threads. Also in system information under "My computer/This PC) it still showed the old CPU.

I decided to reboot and see if things got sorted and that's when my problems began. The PC won't boot now with the Xeon installed. It will power up, the cpu spins at maxspeed and then it will
try to boot, get through the POST procedure and then attempt to load windows. It will then crash at the Windows 8 Splash screen. It flashes an error message very briefly before crashing and rebooting. I've managed to see two different error messages:
Your PC needs to restart. Please hold down the power button.” It then typically shows two error codes either:
Error Code 0x0000005D
or
Error Code 0x0000004C

I have to think the CPU isn't bad since it ran upon the initial boot. Also when I test using the built in HP Diagnostic utility it passes the check. The Xeon is recognized and listed in BIOS. If I put the old E2140 Pentium Dual Core back in everything works fine.

I'm hoping all I need to do is get the correct 771 Microcode injected into the BIOS so this system and Windows 8.1 will work with the Xeon. Can anyone help me with a workable BIOS for this setup?

Also HP does their BIOS update files as windows based executable files so I'm sure that will make things more difficult when it comes time to flash a modded bio since I can't boot into Windows in any mode with the Xeon installed. If I have to drop the stock dual core back in to flash the new bios and then reinstall the Xeon CPU I'm fine with that.

Otherwise someone will also have to walk me through flashing via USB etc. In anticipation I've been trying to teach myself and I've messed around extracting the contents of the HP 5.43 bios update with 7Zip but I'm not sure which files are the actual BIOS files etc.

I've tried everything I can think of: resetting BIOS via jumpers, pull the CMOS battery to reset, making sure XD is enabled in BIOS, loading BIOS defaults etc.

Sorry for the long post but I wanted to make sure you have everything you need. Hopefully someone can help me get this Xeon up and running!
-SingleDad
find
quote
#2
Hi singledad!
I already inject microcode within the bios,but i don't understand why do you
use the high tdp cpu? It is high power consumptive and hot.(x:130w,e:95w,l:50w)
I think that you should to be use e54xx or l54xx on this motherboard is better.

Try it and reply info.
thanks!!


Attached Files
.rar   bios.rar (Size: 700.19 KB / Downloads: 196)
find
quote
#3
So I have the original HP 5.43 BIOS installer. I extracted it to a folder. Do I just replace the modded BEN5.43 file you uploaded with HP's BEN5.43 in the folder?

That's what I did and then ran the update exectuable "Installer" and I get this error message:
"WINDOWS BASED BIOS UPDATE
Proper Command Line Parameters Were Not Passed. No Action Taken. "
find
quote
#4
I'll see about creating a bootable USB and flashing from DOS.
find
quote
#5
method1
First,running original sp46442.exe and stop at "windows based bios update" message box,then you need to find windows temp folder.
You can found a bios update temp folder ,and you need to replace the bios which
i modified,then enter "yes" to start flash bios.
Temp folder in win7 =C:\Users\xxxx\AppData\Local\Temp
xxxx=your windows account
You can remove all files at temp folder first,so you can find bios temp folder quickly.The name of bios temp folder is too irregular.

method2
Extracting sp46442.exe get a folder and replace by modify bios.
You can running AFUWIN.exe in the same folder, or download other version
afuwin to flash bios.

method3
You can flashing it within the dos environment by afudos.

(04-04-2014, 09:44 PM)singledad Wrote: I'll see about creating a bootable USB and flashing from DOS.
Yes,you can try it.


Attached Files Thumbnail(s)
       
find
quote
#6
Thanks so much genius239! I managed to figure out how to flash the original file via AFUDOS.

The addition of the Microcode solved the CPU fan running at full speed issue and I can now boot into Windows normally!

However in CPU-Z the Quadcore X5460 shows up, but it's listed as cores: 2

Within Windows system information everything still refers to the old E2140 Pentium Dual Core. Now I'll have to see about trying to uninstall the old CPU and see if I can get Windows to recognize the Xeon somehow.

Much progress thanks to you genius! Let me know if you have any ideas on how to fix Windows not recognizing the Xeon.
find
quote
#7
method1
follow attachment pictures.
1.enter "msconfig" at start button run system configuration.
2.select tab boot -->advanced option
3."number of processor">>You can set it here.
If the checkbox is enable,set it disable.
If it is disable,set it enable and set core numbers.
Remember completed reboot.

method2.
New install windows system.


Attached Files Thumbnail(s)
           
find
quote
#8
I tried Method 1 and MANY other suggestions. Nothing worked. After a day of trying I gave up and just did a clean install of Windows 8 Pro 64 Bit. That worked and Windows now recognizes it as the Xeon 5460 Quad core and all seems stable.

However I had a new problem I suspected I would encounter. After installing Windows 8 Pro 64 Bit I tried to upgrade to Windows 8.1 Pro 64 Bit. The setup does an initial check to make sure the PC meets minimum requirements. It fails the CompareExchange128 check.

I'm fairly sure the Xeon X5460 SLBBA supports CMPXCHG1B / Compare Exchange128 but can someone help me verify?

I thought maybe it's just the IPIBL-LB (Benecia) motherboard that does not support CompareExchange and thus that's why I'm failing the check. That doesn't make sense either because I already had the Windows 8.1 Upgrade installed on the this system and this mother board with the Pentium Dual Core E2140 installed.

Is there ANY way that the BIOS can be modified to activate CompareExchange? Does an updated/different Microcode or other BIOS change need to be added? If it's possible let me know. Obviously I don't want to brick my board with a bad BIOS update but I'm willing to donate a small amount to the site/person for all the help if I can get this sorted.

I Also wanted to add that I'm running the latest intel Chipset Drivers available for this motherboard and the latest BIOS available (which you modded to inject the Microcode for the X5460 of course)
find
quote
#9
try this site

http://www.overclock.net/t/1384920/good-...rboard/460
find
quote
#10
Thanks for the suggestions guys.

I finally got this sorted out with help over at Delidded.

Turns out it likely had to do with either outdated Microcodes or some sort of microcode conflict.

I'm not complaining about Genuis's work here though because if it wasn't for him I probably would have given up at the beginning. The progress he made kept me determined that this setup would work...it was just a matter of finding the right BIOS updates/injections since nothing has been supported or updated on this board in the past 5 years.

The FIX:
Someone generously took a look at the stock BIOS removed all the old LGA 775 Microcodes for processors like the Q9650 and the Q9550 and then updated them to the newest ones available from Intel. They also added the latest Xeon Microcodes to the stock BIOS. This seemed to be the right voodoo dance.

I reflashed, reset BIOS again and nothing changed. However I already knew from my previous experience that Windows probably just wasn't recognizing the changes to BIOS. Since I had already been through all the fixes and suggestion the first time I wasn't willing to spend another 2 days trying to force things. I was already prepared to cut to the chase and I just reinstalled windows with newly modded bios and the new CPU already in place. That was the ticket.

Bottom line is this modded bios works like a charm and I'm now able to upgrade to Windows 8.1 and continue to receive support and updates past the 2015 deadline. Thanks so much to everyone for their help!

Greatly appreciated!
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in