Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
You have to register before you can post on our site.



Latest Threads
Dell XPS 15 9550 bios password help!!!
Last Post: abubin
Today 01:11 PM
» Replies: 4
» Views: 131
[REQUEST] Lenovo G500 (78CNxxWW) Whiteli...
Last Post: Dudu2002
Today 12:40 PM
» Replies: 1202
» Views: 169280
Fujitsu Celsius R930 (D3118-A2) unlocked...
Last Post: smooker
Today 12:39 PM
» Replies: 18
» Views: 3711
[REQUEST] Lenovo G500 (78CNxxWW) BIOS Un...
Last Post: Antonek
Today 11:53 AM
» Replies: 302
» Views: 85684
[REQUEST] Lenovo G500(S) (7BCNxxWW) Whit...
Last Post: Antonek
Today 11:21 AM
» Replies: 674
» Views: 151217
Last Post: david035
Today 08:46 AM
» Replies: 1
» Views: 1315
Asus R301LA
Last Post: StefanAm
Today 08:23 AM
» Replies: 9
» Views: 203
[REQUEST] Lenovo Thinkpad W701ds BIOS Un...
Last Post: laurenceyu
Today 07:41 AM
» Replies: 4
» Views: 250
TEMP folder doesn't get used...
Last Post: behealed
Today 06:57 AM
» Replies: 0
» Views: 53
BIOS ROM question
Last Post: sunrunner
Today 06:49 AM
» Replies: 0
» Views: 63
[REQUEST] HP Erica6 AMI bios 8906 vF.03
Last Post: RussianJesus
Today 04:03 AM
» Replies: 7
» Views: 465
[Request] ASUS ROG GL553VW BIOS Unlock
Last Post: genius239
Today 01:42 AM
» Replies: 3
» Views: 103
[REQUEST] Acer Nitro 5 AN517-51 BIOS Unl...
Last Post: rog195
Today 12:44 AM
» Replies: 24
» Views: 2686
[REQUEST] Gigabyte AORUS 15 YC Bios Unlo...
Last Post: genius239
Yesterday 08:29 PM
» Replies: 6
» Views: 335
[REQUEST] ASUS FX506LU full unlock
Last Post: Sml6397
Yesterday 06:06 PM
» Replies: 60
» Views: 3204
Gateway M-6337 BIOS Mod & Help Reducing ...
Last Post: Sml6397
Yesterday 04:39 PM
» Replies: 19
» Views: 153
[REQUEST] Lenovo G580 (5ECNxxWW) Whiteli...
Last Post: Dudu2002
Yesterday 03:59 PM
» Replies: 1977
» Views: 364464
Lenovo E520 hidden advanced options
Last Post: Noric
Yesterday 02:58 PM
» Replies: 0
» Views: 91
[REQUEST] Galax A320M BIOS mod request
Last Post: hnv99
Yesterday 11:28 AM
» Replies: 0
» Views: 101
[REQUEST] Lenovo 530s-14ARR (8PCN58WW) B...
Last Post: Dudu2002
Yesterday 05:47 AM
» Replies: 3
» Views: 391

[solved] ASUS P5K SE/EPU - AHCI
(01-31-2011, 10:06 AM)Florin9doi Wrote: ASUS P5K SE/EPU 0501 - bios mod
  • AHCI mod by Antinomy
  • "Native" renamed to "AHCI"
  • Apple logo (widescreen aspect ratio)
  • ASUS SLIC 2.1
  • Marvell 88SE6121 1.1.0.L69 option rom updated to 1.1.0.L73
  • Atheros L1 option rom updated to
  • EZ Flash 2 v3.06 updated to v3.37 (NTFS support)


I have the P5K SE/EPU as well and I was wondering, is this the best modified BIOS for my motherboard atm?

And is there also a version without the Apple logo? Because I don't use Mac OS X.
What else do you want? There can't be the best for everyone. "Best" depends on what you need from it. Wink
I'll make a version with the original logo for you.
Well, I tried the one with all the updates and your version, but I got internet interruptions with the updated one. (Tried multiple drivers)

Edit: Wait, maybe... enhanced overclocking capabilities?
Hmm, I still have internet connection interruptions even with this BIOS Sad
So, I guess one with the latest ROM versions is the best, since changing the BIOS version didn't resolve the internet connection interruptions.

I consider latest best xD
Hi, the internet problems are not because of the BIOS. Thank you.
Glad to hear that!

I've returned the logo to original one, so here's the recent version:

(changes done by Florin9doi)
  • AHCI mod by Antinomy
  • "Native" renamed to "AHCI"
  • ASUS SLIC 2.1
  • Marvell 88SE6121 1.1.0.L69 option rom updated to 1.1.0.L73
  • Atheros L1 option rom updated to
  • EZ Flash 2 v3.06 updated to v3.37 (NTFS support)

If you have any certain suggestions - give a feedback.
Case in this post:
solved - mod BIOS and original have the same ROM ID. If you have a ROM ID error, your board is not a P5K SE/EPU - be careful, there's a bunch of similar names!
I've instaled this rom, but my Win7 not inicialize. probably by the ahci driver are not installed on my system. what your driver? where can i find it? Huh
Marvell 88SE6121 chip stopped working and the system hangs. I think it is responsible for managing disks and now I can not use IDE disks. how can we solve?
Is Marvell enabled in BIOS and IDE enabled too? As for Windows - you need to install AHCI drivers before switching to AHCI in BIOS.

AHCI is fully supported in Microsoft Windows 7 x64,

How to enable AHCI if you already install Windows Vista using IDE interface.


1. Exit all Windows-based programs.

2. Click Start, type regedit in the Start Search box, and then press ENTER.

3. If you receive the User Account Control dialog box, click Continue.

4. Locate and then click the following registry subkey:


5. In the right pane, right-click Start in the Name column, and then click Modify.

6. In the Value data box, type 0, and then click OK
7. On the File menu, click Exit to close Registry Editor

Reboot your notebook, enter bios (F2, del etc),
change your hard disk interface to AHCI.

Forum Jump:

Users browsing this thread: 2 Guest(s)