Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
You have to register before you can post on our site.



Latest Threads
[REQUEST] Remove whitelist from Insyde B...
Last Post: TheStig21
Today 03:35 PM
» Replies: 0
» Views: 0
[REQUEST] Lenovo ThinkPad L420 & L520 (8...
Last Post: WillingMost7
Today 03:15 PM
» Replies: 33
» Views: 10641
[REQUEST] Acer Predator Helios 300 PH315...
Last Post: Dudu2002
Today 07:46 AM
» Replies: 6
» Views: 0
Last Post: feluchi
Today 03:34 AM
» Replies: 57
» Views: 12657
Adding rebar to MSI Z77A-G41: Where to i...
Last Post: Tacking1512
Yesterday 05:33 PM
» Replies: 0
» Views: 0
[Request][Will pay\donate] Lenovo X13 Ge...
Last Post: Izzy2004
Yesterday 04:03 PM
» Replies: 2
» Views: 0
[REQUEST] Lenovo L540 (J4ETxxWW) Whiteli...
Last Post: Dudu2002
Yesterday 03:38 PM
» Replies: 51
» Views: 3162
[REQUEST] Lenovo Ideapad Z710 (7FCNxxWW)...
Last Post: Dudu2002
Yesterday 03:37 PM
» Replies: 264
» Views: 77061
[REQUEST] HP Compaq 6730b Whitelist Remo...
Last Post: sampppa
Yesterday 01:58 PM
» Replies: 9
» Views: 2686
[REQUEST] Acer Aspire E5-473(G) BIOS Unl...
Last Post: Dudu2002
Yesterday 06:27 AM
» Replies: 32
» Views: 8762
[REQUEST] Please help unlock em64t in bi...
Last Post: akubik
Yesterday 06:20 AM
» Replies: 1
» Views: 1395
[REQUEST] Lenovo ThinkPad Edge E330 (H3E...
Last Post: Dudu2002
Yesterday 06:00 AM
» Replies: 765
» Views: 167291
Dell Precision 3630: add legacy boot fro...
Last Post: ssybesma
Yesterday 02:21 AM
» Replies: 0
» Views: 0
[REQUEST] Acer Nitro 5 AN515-55 BIOS Unl...
Last Post: Dudu2002
03-21-2023 06:08 PM
» Replies: 140
» Views: 38843
Last Post: Reg-Edit
03-21-2023 05:40 PM
» Replies: 244
» Views: 411438
Asus S433E Forgot Password BIOS
Last Post: adrianhda0
03-21-2023 02:04 PM
» Replies: 0
» Views: 0
[REQUEST] Bios unlock for Asus G513RW
Last Post: BlankIsDumb
03-21-2023 10:50 AM
» Replies: 0
» Views: 0
[REQUEST] Asus Rog G532LWS BIOS Unlock
Last Post: Magniflex
03-21-2023 10:42 AM
» Replies: 6
» Views: 0
Clevo P775TM1-G BIOS
Last Post: feluchi
03-21-2023 06:04 AM
» Replies: 171
» Views: 53643
[REQUEST] Clevo W258HPQ BIOS Unlock
Last Post: DivineCougar
03-20-2023 01:19 PM
» Replies: 0
» Views: 0

No problem, being a 7th/8th gen platform, I had hopes that it may be possible, but now I understand better. If unlocking the options available would be possible I would appreciate it, being able to access the OC functions for undervolt purposes would be very useful. Thank you!
I received the PM & flashed the BIOS, it worked great! Thank you so much!

I then tried enabling the iGPU & setting the primary GPU from PEG to auto in order to improve thermals and power efficiency. Unfortunately I did not look at the board schematic before doing so - turns out this laptop has all video outputs attached directly to the NVIDIA GPU, there is no mux. This made it unbootable (black screen on boot, can't enter BIOS blindly to set defaults just through shortcuts like F2->F9->F10). No output on DP or HDMI either. I tried Ctrl+Home to boot recovery, tried shorting JRST2001 & 2002 underneath the second RAM module, tried pulling both CMOS & regular battery, no progress. I don't think any of these methods clear NVRAM values, which is what I think the problem is. I am procuring a CH341A and will try flashing the chip directly. I have attached the board schematic for future "victims".

Attached Files
.zip (Size: 3.06 MB / Downloads: 2)

On normal laptops ,all graphic signals are output through integrated graphics(cpu) ,and no mux design. so ,now it's boot but no graphic signal output. As long as you only can see option "SG Mode Select" under Switchable Graphics and it's only has Muxless model ,it probaly is this design.

On this old laptop ,it should has a cmos battery ,remove it and wait for minutes can clear cmos. Or try this way , first turn off your laptop then turn on it and hold on the power button more than 40sec until it shut down again. Then turn it on to test if clear cmos is successful.

Thank you, I wonder why simply enabling the iGPU would lock it up then! Unfortunately still no luck. If plugged in and I try holding the power button, it turns off after a few seconds and remains off (charging status light also goes off and remains off until release). Upon powerup 40+ seconds later, no change. If I do the same on battery only, the behaviour is identical except once it turns off the fans also spin up to their max speed and remain so until I release the power button - also with no change after 40+ seconds.

Unplugging the CMOS battery also has brought no change, I left it unplugged for hours, also unplugged the main laptop battery.

I have added the official BIOS renamed to both ASUS.BIN and ASUS.CAP to a small FAT16-formatted drive, but recovery has not started. I am not sure how I could trigger BIOS recovery.

I have acquired a CH341A, modified it for 3.3V, and soldered to test points right beside the chip. Unfortunately I am unable to flash it on the board, the CH341A stops registering as soon as the wiring adapter is plugged in - presumably as it's trying to power up far more than the chip itself. Being WSON8 I would need to unsolder it with a hot-air station and solder it to a specific WSON8 adapter - this is the next step on the list. If you have any further ideas or something I can try before carrying out such invasive tactics, please let me know! I appreciate all your help so far!

1. It should easy to revert bios by clear cmos if only some wrong bios tweaks. Not only tune igpu ,but you did other options? Such as directly tune "Core Voltage Offset" in the bios?? I don't think it is only a simple wrong bios setting.

2. Wson8?? on 8th gen asus laptops ,it still should a sop8 chip and it near the south bridge. I've never touch CH341A so i can't give you any suggestions ,but you can find many instructions about it on the internet.

3. Just out of curiosity ,on normal programmer the work voltage is 3.3v~5v ,it didn't need to modify. But if you wanna read a low unlodervolt chip(such as 1.8v) ,you need a 1.8v adapter.


Forum Jump:

Users browsing this thread: 4 Guest(s)