Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Acer Aspire 5745PG BIOS Downgrade -> No display, can't get crisis mode to work
#1
I tried to downgrade my old Acer Aspire 5745PG BIOS from v1.19 to v1.11 because that is the last version that allows you to enable the discrete GPU only, since the intel GPU does not appear to have drivers that work with later versions of Windows 10.

I downloaded the correct BIOS, and it seems to have flashed fine from Windows, but since then the display has not turned on.

It looks like Windows is still booting, since I still see hard drive activity and it responds to the power button gracefully. I just can't get any display output (I also tried plugging in an HDMI monitor but that doesn't do anything either).

So I thought I could use the BIOS recovery to flash back to v1.19 since a functioning display without drivers is better than no display at all.

I downloaded Phoenix tool 2.50 and loaded up the v1.19 BIOS, and it says recovery filenames are "ZR7X64.f?". I assumed this meant I could just name the file ZR7X64.fd (the original filename is ZR7x64EC.fd), stick it on a flash drive and it would flash itself, but I can't get this to work. It starts in recovery mode (i.e. the power light flashes as expected), then a few seconds later the fan goes on full blast. Nothing else after that. I left it for about 10 minutes with no change. Restarting the laptop after this seems to have made no changes, and I think Windows is still booting up.

Do I need anything else to be present on the flash drive in order for this to work? Would me using a USB3 drive on a USB2 port have anything to do with it? (I don't have any other flash drives laying around).
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in