Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Alienware Aurora R1 mobo bricked ?

Hope I am posting in the correct section, I don't speak perfect English so I don't understand everything.

I did some research and I can't find a solution to my problem, but I arrived on this forum where I thought that maybe we could help me.

I have a problem with an Alienware Aurora ALX (R1) PC, I wanted to update the BIOS and there was a power failure... Now the computer starts up but no longer displays anything. It beeps when I remove the RAM or when I plug in a USB drive. But these are the only signs of life that I can get.
I tried to create a key with Crisis BIOS recovery but I cannot extract .rom file from .bin file found in .exe. And since I do not understand everything I am afraid of going about it badly.

Is it possible to do something or the motherboard is bricked in your opinion?

Thank you in advance.
Yes friend,
it's bricked, but may be there is a Recovery Procedure for it.
Please post your bios version, link to producent bios download and desciption and model of your pc (more infos is better).
I will try to help You, but if isn't possible then You have to consider to buy an SPI Programmer and a Pomona Clip ...

Then We will rebuild your bios and You can rewrite it back !
Let me know
Thanks so much for helping me!
Ok for the BIOS it's here:

And my PC:
But I have an i7 930 instead of the 975, 12gb ram and not the same GPU.
And the motherboard is one: Alienware MicroATX LGA 1366 Intel X58
I don't know if you have everything you need ?

And for the SPI Programmer and the Pomona Clip I will buy them if necessary. I didn't know them, they are very interesting tools !

Thanks again.
I found this file for You, but You will rewrite back by SPI Programmer.
Before to write this one , It's better make a Firmware Dump by SPI Programmer and upload here foe me,
so even it's possible to get all yours PC informations !
let me know
Ok awesome ! So I'll buy what I need and get back to you.
Thanks a lot !

I received the clamp and the programmer but could not detect the BIOS chip with the software, I tried on several different PCs and nothing changes. I have followed a lot of guides and videos and I really can't do it. I really don't understand why.

Edit: I passed a test with the chipset of my graphics card. So it's not the received hardware that has a problem apparently.

Forum Jump:

Users browsing this thread: 3 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in