Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Broken Insyde-Bios Acer Aspire 4820TG
#1
Ladies & gentlemen,

I interrupted a BIOS update and probably destroyed my Insyde BIOS. So I tried to do a BIOS recovery with different tutorials (for example https://www.bios-mods.com/bios-recovery/), but it did not work.

Model: AS4820TG
Product Name: Acer Aspire 4820TG-434G50Mn
BIOS Chip: SOIC8

I have performed the following steps:

1. I got the correct BIOS file from the Acer website (BIOS_Acer_1.15_Windows.zip).
2. I unzipped BIOS_Acer_1.15_Windows.zip, came out the following files:
BIOS_Acer_1.15_Windows.zip \ DOS \ ZQ1_115.exe
BIOS_Acer_1.15_Windows.zip \ Windows \ ZQ1_115W.exe
3. I unzipped the ZQ1_115W.exe, came out the following files:
AtpTimerInfo.dll
ding.wav
FWUpdLcl.exe
InsydeFlash.exe
iscflash.dll
iscflash.sys
iscflashx64.sys
Platform.ini
xerces c_2_7.dll
ZQ1x64.fd
4. I formatted a 2GB USB stick with FAT.
5. I copied the file ZQ1x64.fd to the USB stick.
6. I have removed AC and the battery pack.
7. I connected the USB stick to the laptop.
8. I pressed FN + ESC and did not let go.
9. I have connected AC to the laptop.
10. I pressed the power button.
11. After 15 seconds the USB stick started to light up and I released FN + ESC.
12. The fan got louder. No beep. The screen switched between two blacks. The USB stick changes regularly between: 10-20 seconds light up, 3 - 4 times short flash, no light, 10-20 seconds light up...  ...and so on.
13. I wait 10-30 minutes but nothing happens.
14. I turn off the laptop, remove the USB stick and turn on the laptop again.
15. I still do not get any output on the screen.

Have I made some mistakes? Or should I try another file? Or is there another solution without remove the chip?
I already tried every BIOS-file from the Acer homepage (v1.13-v1.25) and also a working and tested file from notebookreview. I also tried with ‘Windows’ key and the ‘B’ key. And i also used another USB Sticks.
Sorry for my poor English.

I dont have money for new hardware so i would be glad if someone can help me with this issue, very very thank you.  Smile
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in