Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fix memory support on SM-3322
#1
Hello there!
I've recently populated all memory slots on a Itautec SM3322 motherboard with 2GB modules, to a total of 8GB, maximum memory supported by this board according to the manual. The motherboard recognizes all 4 slots, but lists only 4096MB of RAM.
I attached a picture of the memory page on the bios, and the bios file itself.

This motherboard is a rebranded Pegatron A480-S, according to CPU-Z.
I also noticed that if I remove the dedicated GPU, it recognizes all 8192MB of RAM.

I believe it can be a bug on the bios. The manufacturer won't provide a new, updated bios for it, so I want to know if it is possible to fix this.

Thanks in advance


Attached Files Thumbnail(s)
   

.rom   SM3322.ROM (Size: 1 MB / Downloads: 2)
find
quote
#2
Show photos of your SODIMMs from both sides.
What's your graphics card?
How many memory is recognized by BIOS with 2 and 3 SODIMMs?
find
quote
#3
Just attached the pictures as you asked.The RAM is some cheap kit I got from AliExpress.
If I use 2 or 3 modules, it gets detected correctly.
I tested several combinations, and seems like all modules work fine.
Testing one module at a time returns no error on Memtest.

I tried a R9 280 and a HD 6570 and got the same results.


Attached Files Thumbnail(s)
       
find
quote
#4
Make two TXT-reports of CPU-Z and two photos of BIOS page with amount of memory:
1) 3 RAM modules and HD 6570
2) 4 RAM modules and HD 6570
find
quote
#5
I attached the requested files.


Attached Files Thumbnail(s)
       

.txt   3module.txt (Size: 61.1 KB / Downloads: 1)
.txt   4module.txt (Size: 62.61 KB / Downloads: 1)
find
quote
#6
OK. Also I need two TXT-reports of CPU-Z:
1) 1 RAM modules and HD 6570
2) 2 RAM modules and HD 6570
find
quote
#7
OK. I attached the requested files.


Attached Files
.txt   1module.txt (Size: 58.16 KB / Downloads: 1)
.txt   2modules.txt (Size: 59.59 KB / Downloads: 1)
find
quote
#8
Make a screenshot of Windows system information with 4 modules and HD 6570.
It looks like:
[Image: 4488EAFFF353.png]
find
quote
#9
Hello there!
I attached the picture to the post.
Even with Windows detecting 8GB of RAM, I notice it fails Prime95 on blend mode and any memory intensive applications. But when using the integrated GPU, it does not happen. So I believe it could be related to the motherboard not detecting the memory properly on post.


Attached Files Thumbnail(s)
   
find
quote
#10
OK.
Download RWEverything. Try portable version.
Press CPU MSR registers button, press User list button or F5, type a=0xC001001A, press Add, type b=0xC0010010, press Add, type c=0xC001001D, press Add, press Done.
Post values of MSR with these addressees.
find
quote


Forum Jump:


Users browsing this thread: 3 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in