Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gigabyte GA-G1975X + Pentium D 965 3.73GHz SL9AN
#1
Hello,

I wondered if someone here could update the BIOS for the Gigabyte GA-G1975X to properly support the 3.73GHz Pentium D 965 SL9AN?

According to Gigabyte's website the board does support this CPU with BIOS version F4 and up, but I have installed the last official F6 and it is still not properly identified. The BIOS identifies it as a 3.28GHz CPU and only clocks it up to that speed. I have verified this with CPU-Z. CPU-Z reports the correct CPU name and speed, but only shows it running at 3.28GHz.

Link to the board:
http://www.gigabyte.com/products/product...id=1955#ov
Link to the latest BIOS:
http://download.gigabyte.us/FileList/BIO...75x_f6.exe

Thanks in advance!

find
quote
#2
Please show CPU-Z screenshot.
Go to BIOS -> MB Intelligent Tweaker ->CPU Clock Ratio and set it to 14.
find
quote
#3
(09-19-2015, 02:38 AM)DeathBringer Wrote: Please show CPU-Z screenshot.
Go to BIOS -> MB Intelligent Tweaker ->CPU Clock Ratio and set it to 14.

[Image: sl9an_1.jpg]

Thanks for the reply.
Tried setting the clock multiplier to 14. This overclocked the CPU to 3.83GHz.
It ran this way for a bit but then reverted to the previous 3.28GHz.
I found a thread about an Intel board with the same problem (I assume that's where you found the clock multiplier setting) but this solution doesn't work for this board. Sad

According to CPU-World the FSB should be 266MHz, not 274. I suppose there is a way to manually set that as well but I'd prefer the BIOS properly identify and set the CPU parameters...

find
quote
#4
This is unlocked version of CPU for overclocking. Some values in BIOS left from your previous CPU. So you can try Load Fail-Safe Defaults or Load Optimized Defaults.
Or go to BIOS -> MB Intelligent Tweaker ->CPU Host Clock Control and set it to Enabled. And CPU Host Frequency - to 266Mhz.
find
quote
#5
(09-20-2015, 01:59 AM)DeathBringer Wrote: This is unlocked version of CPU for overclocking. Some values in BIOS left from your previous CPU. So you can try Load Fail-Safe Defaults or Load Optimized Defaults.
Or go to BIOS -> MB Intelligent Tweaker ->CPU Host Clock Control and set it to Enabled. And CPU Host Frequency - to 266Mhz.

This seems to have fixed it; when I enabled CPU Host Clock Control it defaulted to 266. Don't know why that would be disabled to begin with...

When I rebooted, the BIOS correctly reported 3.73GHz and 266x14 during POST.

Now the only issue is that I see the clock multiplier fluctuate from 14x down to 12x and sometimes back up while watching it with CPU-Z in Windows. I assume this is normal and the CPU is just throttling back because it isn't under load?

Thanks!

find
quote
#6
LoneCrusader Wrote:I assume this is normal and the CPU is just throttling back because it isn't under load?
I think it's normal.
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in