Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Latest Threads
Patch bios
Last Post: idris237
Today 07:19 AM
» Replies: 0
» Views: 21
Asus M5a78l-m Lx3 thermal trottling HELP...
Last Post: Edson430
Today 06:25 AM
» Replies: 0
» Views: 16
[REQUEST] Lenovo Thinkpad T430u (H6ETA0W...
Last Post: Dudu2002
Today 06:09 AM
» Replies: 1
» Views: 31
[REQUEST] Lenovo T440(S) (GJETxxWW) Whit...
Last Post: Dudu2002
Today 06:07 AM
» Replies: 545
» Views: 144491
Asus M5a78l-m Lx3 plus Update Raid
Last Post: Edson430
Today 05:40 AM
» Replies: 0
» Views: 26
[REQUEST] Acer Aspire E1-570G BIOS Unloc...
Last Post: Twistykus
Today 04:10 AM
» Replies: 89
» Views: 40764
[REQUEST] Lenovo IdeaPad P400, P500, Z40...
Last Post: notiiz
Yesterday 10:00 PM
» Replies: 96
» Views: 37834
[REQUEST] Lenovo G580 (5ECNxxWW) Whiteli...
Last Post: Dudu2002
Yesterday 09:58 AM
» Replies: 2116
» Views: 520258
[REQUEST] Lenovo Thinkpad T440p (GLETxxW...
Last Post: Dudu2002
Yesterday 09:53 AM
» Replies: 667
» Views: 154324
Lenovo B590 (20208) Advanced options and...
Last Post: Dudu2002
Yesterday 09:45 AM
» Replies: 13
» Views: 12139
[Request] MSI PRO DP21 11M UEFI Aptio BI...
Last Post: Tosgaba
Yesterday 06:26 AM
» Replies: 8
» Views: 300
[Request] Asrock B460M Pro4
Last Post: siiNCey
Yesterday 12:49 AM
» Replies: 0
» Views: 112
[REQUEST] Lenovo IdeaPad U310 & U410 (65...
Last Post: NeverMind1
Yesterday 12:15 AM
» Replies: 1842
» Views: 350907
need microcode Agesa OrochiPI 1.5.0.0
Last Post: Edson430
09-25-2022 10:43 PM
» Replies: 0
» Views: 136
[REQUEST] HP G4-1204TX WiFi whitelist re...
Last Post: white-dingus
09-25-2022 08:07 PM
» Replies: 0
» Views: 152
[REQUEST] Lenovo G710 BIOS Whitelist Rem...
Last Post: Dudu2002
09-25-2022 11:52 AM
» Replies: 533
» Views: 122380
[REQUEST] Lenovo G70-70 BIOS Whitelist R...
Last Post: Dudu2002
09-25-2022 11:48 AM
» Replies: 152
» Views: 62603
[Request] Zotac Magnus One AMI Bios unlo...
Last Post: Limon93
09-25-2022 10:29 AM
» Replies: 71
» Views: 10914
[REQUEST] Lenovo IdeaPad P400, P500, Z40...
Last Post: Masoud.S2
09-25-2022 09:24 AM
» Replies: 729
» Views: 151536
[REQUEST] X16-1155CA WHITELIST REMOVAL S...
Last Post: drmrsolds
09-25-2022 06:37 AM
» Replies: 0
» Views: 87

[REQUEST] GL504GS BIOS unlock
#71
No problem, being a 7th/8th gen platform, I had hopes that it may be possible, but now I understand better. If unlocking the options available would be possible I would appreciate it, being able to access the OC functions for undervolt purposes would be very useful. Thank you!
find
quote
#72
I received the PM & flashed the BIOS, it worked great! Thank you so much!

I then tried enabling the iGPU & setting the primary GPU from PEG to auto in order to improve thermals and power efficiency. Unfortunately I did not look at the board schematic before doing so - turns out this laptop has all video outputs attached directly to the NVIDIA GPU, there is no mux. This made it unbootable (black screen on boot, can't enter BIOS blindly to set defaults just through shortcuts like F2->F9->F10). No output on DP or HDMI either. I tried Ctrl+Home to boot recovery, tried shorting JRST2001 & 2002 underneath the second RAM module, tried pulling both CMOS & regular battery, no progress. I don't think any of these methods clear NVRAM values, which is what I think the problem is. I am procuring a CH341A and will try flashing the chip directly. I have attached the board schematic for future "victims".


Attached Files
.zip   GL504GSv2.1.zip (Size: 3.06 MB / Downloads: 2)
find
quote
#73
@varu

On normal laptops ,all graphic signals are output through integrated graphics(cpu) ,and no mux design. so ,now it's boot but no graphic signal output. As long as you only can see option "SG Mode Select" under Switchable Graphics and it's only has Muxless model ,it probaly is this design.


On this old laptop ,it should has a cmos battery ,remove it and wait for minutes can clear cmos. Or try this way , first turn off your laptop then turn on it and hold on the power button more than 40sec until it shut down again. Then turn it on to test if clear cmos is successful.

My page>>>click
My bios unlock >>> click
donate me >>>click


find
quote
#74
Thank you, I wonder why simply enabling the iGPU would lock it up then! Unfortunately still no luck. If plugged in and I try holding the power button, it turns off after a few seconds and remains off (charging status light also goes off and remains off until release). Upon powerup 40+ seconds later, no change. If I do the same on battery only, the behaviour is identical except once it turns off the fans also spin up to their max speed and remain so until I release the power button - also with no change after 40+ seconds.

Unplugging the CMOS battery also has brought no change, I left it unplugged for hours, also unplugged the main laptop battery.

I have added the official BIOS renamed to both ASUS.BIN and ASUS.CAP to a small FAT16-formatted drive, but recovery has not started. I am not sure how I could trigger BIOS recovery.

I have acquired a CH341A, modified it for 3.3V, and soldered to test points right beside the chip. Unfortunately I am unable to flash it on the board, the CH341A stops registering as soon as the wiring adapter is plugged in - presumably as it's trying to power up far more than the chip itself. Being WSON8 I would need to unsolder it with a hot-air station and solder it to a specific WSON8 adapter - this is the next step on the list. If you have any further ideas or something I can try before carrying out such invasive tactics, please let me know! I appreciate all your help so far!
find
quote
#75
@varu

1. It should easy to revert bios by clear cmos if only some wrong bios tweaks. Not only tune igpu ,but you did other options? Such as directly tune "Core Voltage Offset" in the bios?? I don't think it is only a simple wrong bios setting.

2. Wson8?? on 8th gen asus laptops ,it still should a sop8 chip and it near the south bridge. I've never touch CH341A so i can't give you any suggestions ,but you can find many instructions about it on the internet.

3. Just out of curiosity ,on normal programmer the work voltage is 3.3v~5v ,it didn't need to modify. But if you wanna read a low unlodervolt chip(such as 1.8v) ,you need a 1.8v adapter.

My page>>>click
My bios unlock >>> click
donate me >>>click


find
quote


Forum Jump:


Users browsing this thread: 3 Guest(s)