Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[REQUEST] Lenovo T520 (8AETxxWW) Whitelist Removal
Hello,

Would you please send me the password of the 1.49 BIOS (http://rgho.st/7dkRRhtpz)?

Best regards.
find
quote
(07-05-2019, 07:37 AM)Marcin Dąbrowski Wrote: Hello,

Would you please send me the password of the 1.49 BIOS (http://rgho.st/7dkRRhtpz)?

Best regards.

Can someone send me the password for this file as well? Please and thank you.
find
quote
Hi everybody,

could someone help me to modify the bios from thinkpad T520?

ThinkPad T520 (4243 CTO)
BIOS VERSION: 8AET69WW (1.49 )
BIOS download link:
https://pcsupport.lenovo.com/pl/pl/produ...s/ds018810

Any help is appreciated.

Thanks
find
quote
Here's T520 modded 1.49
https://www22.zippyshare.com/v/8tOexOFB/file.html
https://www.sendspace.com/file/pzzl8i
http://www.filedropper.com/lenovot520t520i149mod
find
quote
(07-27-2013, 05:45 PM)sovem Wrote:
(07-27-2013, 05:05 PM)blautens Wrote: Greetings, powerful dev/moderator -

I'd be extremely grateful for a modded BIOS for this - I guess it's too new to be common, but at some point I'd think this is going to be a popular request. I checked but didn't see this in the BIOS repository.

I have a ThinkPad T520 (4239-CTO) currently using BIOS v1.43. It uses an Intel 6300 AGN card, but I'd like to use my new Intel 7260 AC card in it.

Download link to 1.43 BIOS:
http://download.lenovo.com/ibmdl/pub/pc/...uj24us.exe

Current wireless card:
PCI\VEN_8086&DEV_4238&SUBSYS_11118086&REV_3E
PCI\VEN_8086&DEV_4238&SUBSYS_11118086
PCI\VEN_8086&DEV_4238&CC_028000
PCI\VEN_8086&DEV_4238&CC_0280

Again - thanks in advance.

Bruce

WL removed.
Bios mod: THINKPAD_T520_8AET63WW_8auj24us_NWL
https://app.box.com/s/eptlwiogd0srrk0ikaii
Look README to update. Please post results.

Hey, could you please fix the Download Link?
find
quote
(09-11-2019, 12:08 AM)killer23d Wrote: Here's T520 modded 1.49
https://www22.zippyshare.com/v/8tOexOFB/file.html
https://www.sendspace.com/file/pzzl8i
http://www.filedropper.com/lenovot520t520i149mod

Has anyone tried this modded version on a T520 yet? Everything running smoothly?
find
quote
T520 2760QM, planning to install Intel IT-8260HMW-B, I saw somebody did this on reddit and there's one on aliexpress in half mini pci-e format.
https://pl.aliexpress.com/item/328534206...5c0fzw6h5N

I have tried the files uploaded by killer23d, which I thank you very much for!

Sadly it seems to crash on windows 10 1809 64 bit. It does a bluescreen with WinFlash64.sys, I figured to update winflash from asus, but it fails.
Ended up buying a 10$ 2.5" Seagate HDD and installed windows 7 32 bit on it, I had to move wifi drivers as there was no internet and no drivers at all.
No battery drivers, so winflash would stop flashing because it won't flash without battery plugged in and charging.
Sideloaded WiFi drivers, did all the updates in windows 7 and the drivers also downloaded along.
Battery was visible and I double click flash.bat, allow UAC and it goes smoothly. I also did battery firmware upgrade while at it, as this one also crashed on Windows 10 bit, bluescreen.

TL;DR
All went great, but there's 5 beeps, pause 5 beeps and then it boots
I found out a very old post that said to switch Security Chip to Inactive and it doesn't do this anymore.

This supposedly turns off the TPM. I was wondering if there's a chance of having 1.49 bios with working TPM?

Thanks everybody, this is truly a great device Big Grin
find
quote
So I have got the AC-8260 for T520 with the modded bios,
It seems to work fine, I can connect to BT4.0 devices BUT
For some reason I can see only a limited amount of WiFi networks around me, quite possibly only 5GHz networks
Basically if there are 6 networks around me, I would see only 2 on the T520, not really sure where the problem is.
I have plugged the antennas per this guide by Lenovo
https://support.lenovo.com/us/en/solutions/pd009754
Grey connected to 1 and black wire connected to 2, having placed white wire in that slot, I'm not really sure how should I get it working properly, any tips?
find
quote
(11-20-2019, 08:52 PM)olokos Wrote: So I have got the AC-8260 for T520 with the modded bios,
It seems to work fine, I can connect to BT4.0 devices BUT
For some reason I can see only a limited amount of WiFi networks around me, quite possibly only 5GHz networks
Basically if there are 6 networks around me, I would see only 2 on the T520, not really sure where the problem is.
I have plugged the antennas per this guide by Lenovo
https://support.lenovo.com/us/en/solutions/pd009754
Grey connected to 1 and black wire connected to 2, having placed white wire in that slot, I'm not really sure how should I get it working properly, any tips?

If you are in Windows you can configure the card using the Device Manager, where you can select which bands to use. I should get the same cards soon and will report back.
find
quote
It's set on Dual band by default.
I have 19 wifi networks around me as reported by AC-8260 in my PC using 2 large external antennas
T520 AC-8260 I have 3 networks, one being my Phone hotspot and another router in my room, the third one is some random wifi, still quite a difference between 19 wifis and 3 wifis Sad
Makes me a bit sad, the speeds are improved a lot, I can use my BT4.0 mouse, but there's definitely something wrong here...
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in