Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[REQUEST] Lenovo Thinkpad X240 (GIETxxWW) Whitelist Removal
Hi All,

Please try to use my fixed lenovo update program.

PS: only support same Mod BIOS version. not upgrade. please use original exe for upgrade.
Just to make you guys know
I just received my hardware programmer and tried to read my X240 flash chip in-circuit using a test clip. It didn't work at all. I then tried to read the flash of my old EEE PC laptop also in-circuit and it worked! Also I tried with some old videocard and it worked too.
For some reason I cannot do that on my X240. I guess I need to desolder the chip and try again. But my old soldering iron is so big and powerful I'm afraid of damaging my X240. So now I'm thinking of getting myself some good soldering station hahaha.
@rozker: can you share hardware programmer that you bought?
i have similar situation.
1. with GQ-4X.
i successfully use SOIC test clip with my T430. but failed when tried on the Intel DQ77MK board.
i tought it is because the flasher not supporting the chip, because no specific IC name in the devices list (W25Q64FV).
(turns out to be wrong - cont read my post for more detail story)
so after googling, i decided to getTS866CS because this flasher has the chip name in the supported devices list.
I also buy some similar type of IC for backup.
2. with TS866CS
when i tried this flasher with SOIC test clip for Intel DQ77MK board, it turns out to be total failure.
then i tried again to use SOIC test clip read backup IC that i bought (same type, W25Q64FV), it's not recognizing the ic. Sad
tried to use the Adapter coming in package with the flasher, it correctly identified the IC (backup)
and I was able to write bios file from intel.
this fact is inline with someone writing tutorial in our forum for flashing his X230T.
he wrote that he had no luck with SOIC test clip, so he take out the bios chip, reflash, then resoldered.
so, i would say that this flash programmer's not gonna work with SOIC test clip. please cmiiw.

as i had chip backup, i tried to read and write bios file on the chip (not the one on intel board) using my old flasher (GQ-4X).
and the flasher successfully identify the chip after i picked W25Q64 in the device list. it works both ways, either using SOIC test clip or using adapter.

after read the firmware update guide in the intel website, i found that the guide ask for flashing process with power standby.
it also mentioning different hardware flasher.

perhaps other member with more knowledgeable brain on chips and hardware stuff can shed some light on this issue.
anyone? Smile

btw, i'm considering to buy a SMD reworks station too.
any good brand/type you think of?
I bought TL866CS. And I also tried it with with W25Q64FV (DIP package, taken out of some motherboard) and it worked like a charm. So I guess it should work also with W25Q128FV in my X240 when I take it out.

For reworking station, Lukey 852D+ looks good. Not expensive, includes hot air gun and soldering iron. And can be improved with some Hakko parts.
I just been reading some forums about TL866CS/A and people say that's not very good for in-circuit programming. Sometimes it works, but often doesn't work too. This depends on circuitry the flash chip is plugged in real devices. With taken out flash chips TL866 works fine!
to me, below links are interesting:

i never deal with flash programmer nor electronic stuff prior modding bios,
so this kind of information is useful for me.
I spent a bit of time looking into how this works, wanting to remove the whitelist on my X230.

I found these great references - the first link in particular. One even exploits a bug in a Dell flasher to circumvent the signing check.

In the end I didn't do anything about it. Toying with getting a hardware flasher instead.
Hi all,

I'm using a Lenovo x240 which embeds a barely working rtl8192ee wifi card. Since I just installed an AC network at home I'd like to switch card and bought an Intel 7265.

Of course I can't get past the BIOS screen as the IDs (8086:095B / 8086:5210) are not part of the list. I've tried updating the BIOS to the latest version but it didn't help, at least I got the FL1/FL2 files from the update ISO.

But looking online and reading this (almost similar) thread:
I've realized it wouldn't that easy to change the BIOS.

Since I'm running Linux, not many tools seem to be adapted, so I went ahead and remove the W25Q128FV chip from the motherboard and did a backup copy of the current BIOS.

My questions:
- Now that I have a flash dump + FL1/FL2 files, what are the next steps to add my IDs (at least) or remove the check completely?
- Are there any Linux tools to do so?
- Are those (Windows) tutorials adapted for the x240 BIOS?

Hi all,

Following up on this, I've tried to the thinkpad-biosmod procedure and got stuck at the phnxdeco command where it says the BIOS isn't a Phoenix one.

Any ideas? What bothers me is that I expected to see the Realtek IDs in the dump directly but I can't find it.

Hello, Gary!
Unfortunately, bios chip is rewrite protected so mod can be flashed using HW SPI Programmer only!
There are two ways of removing whitelist.
1. You can change id of current card to id of new card. So new wlan card added to whitelist and laptop contunue to booting.
Whitelist not disabled, and you will get "Unauthorized card..." when try to install new wlan card. This is easiest way to bypass this error.
2. Needs more deep knowledge in codes. This method makes all cards are "white" so you can install any card and laptop will start successfully.

Please,do not post requests me in PM.Bios modding is very dangerous work.If i provide you confirmed modded bios, please donate for my dangerous work you!

Forum Jump:

Users browsing this thread: 4 Guest(s)