Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bios ram table mod
#1
Photo 
I have abit ix38 quadgt with has problems with bios and 8GB ram hard to pass 1000Mhz for example 990Mhz full stable at vdim just 1.8v when @1000Mhz can't even pass 1 test in prime95. Even with ram 1066 i can't pass 1000Mhz even with vdim 2.35...
So last time I'm thinking about mod bios to take meminit from other board for example here from gigabyte. What you thinking is this possible ?
Here is screen shoot from cbrom left =abit, right gigabyte.
[Image: bioses.jpg]
So i would replace position no 6 on abit bios with position 11 from gigabyte. Are those roms memorry tables ? Is this posible to change it and boot system ?
Or maybe is better to play with edit SPD setting in ram roms ? Like put values from ram witch easy oc at abit ?
One more question what is this mem init in BB (bootblock) why in abit i don't have it.
find
quote
#2
Adjust tRFC to 220+ might help, if you have tRRD set to 7 or above. What is this 8GB, 2x4Gb or 4x2GB? Was it designed for x38-x58, or is it a newer kit made for P55-Z77 or newer than that even?

hard to say what is in the Abit BIOS without looking at it, but it's not easy to simply swap those around even if they both are memory init tables.
And that means just what it says, the mem init in the Gigabyte BIOS is within the boot block, abit one is not (or those are not opened in same cbrom version) You can try simple swap, but I wouldn't do that unless you have programmer in hand, backup made and tested programmed back and it works, then you know you can recover.
find
quote
#3
TRFC max in bios is 78 other values 15 max what i tried and didnt help main timings 6-7-7-32 didnt help too. There must be some problem with bios or ram spd. Ram is kingston 4x2GB 1066 5-5-5-18 @2.3v, For everyday i can just run them at 990mhz but at timings 6-6-6-18 with only 1.8v. Tried max 2.35v and can't load even windows at 1040mhz with mch 1.25v up to 1.65. But 2x1Gbocz 800mhz worked at 1200mhz without any problem. CL4 working same like this 790Mhz without problem 800 not even boot. CL5 maybe will work up till 940Mhz. But at cl6 990mhz its still faster ram than 2x1+2x2 ozc at cl5 1000mhz.
Bad that abit bankrupt and didn't make any good bios for this mobo. Its like they made this ram table good just for 2 sticks of 1GB ram.
I swaped roms for raid etc and max what can put is this 64kb 8,5ver bigger doesn't work so can be same with different meminit.
On screenshoot bot bios are opened with cbrom198 here is my bios from abit in case you would like check it.

Maybe edit spd in the ram stick would help and would be easier to do.
find
quote
#4
8GB is not going to work well at all if you cannot set tRFC above 78 (That's even too low for many 2GB modules if using 8GB). 52-72 is more ideal for pushing tight timings on 1GB modules, 60-88+ for 2x2GB, with 4x2GB I would want to set at least 88-120 probably. Sorry, I thought you had 4GB modules there at first. So there is one of the main issues. Fully loaded ram slots are tough to run on older system like this, especially if you cannot raise timings high enough, or don't have direct access to the more important timings like I mentioned.

Editing SPD may work, if the BIOS will allow the higher programming timings to load in the background, but I doubt that's possible or it would be working now for tRFC since I'm sure it's default programming is above 78 for tRFC.

If you have "Static tRead' setting that could be causing issues if set too low too, set that to 9-11 until you sort things out, 5-6 is tight, 7-8 still pretty tight for 4x1GB or 2x2GB, so 9-11 probably best option to loosen this up if you have the setting available.

Check in AIDA64 (Motherboard > Chipset > NB then look at current timings and find tRFC) what is the current tRFC timings at 1600 even? You can also check with HWInfo64 on the little CPU-z like window tRFC is on the bottom right corner, or in the large window go to memory but don't expand it, just select the memory entry and look at the timings tRFC and tFAW (if given) at bottom tRRD right above those two.

Yes, for these boards, X38/X48 and even P35, using 4GB modules it a pain sometimes, especially at high speeds with limited access to proper memory timings, or like you case access to the timings but then too low of a max allowable setting limit.

What is the board, I have all Abit BIOS. I want to check BIOS to see if you have Vtt voltage option, MCH Strap, memory strap options etc.
find
quote
#5
Its abit ix38 quad gt (ddr2) What i read many people have problem with those kingstons but this board with 6gb ram has same problems.
I saw just 1 time some 1 had OCZ 8Gb at 1066Mhz without problems just mch was +0,1v. Plus i have quad on this board q9650 what is harder to overclock too. Max fsb with 2x1 +2x2 is around 474 and with 4x2 hard to pass 460. But even without oc can't pass cl4 at 800 or cl6 at 1000mhz
where 10 less working 100% stable. Here you have screenshot of uguru same settings are in bios now I'm testing bio no 19 from 2009 but is same.[Image: timings.jpg]

even if i set all values of timmings to max at bios it doesn't help. Ram is rated with 2.3v what is high but max what i tried was 2.35 or 2.375v MCH up to 1.65v. I wish run this for 24/7 and would be stupid push so mach voltages just maybe for 2-5% of performance.
find
quote
#6
Same issue with 2x2GB? Thanks for images, I see tRead (Performance level) is set to 8, can you adjust that in BIOS or not?
tRFC 52 is too low, even for 2x2GB if you are trying to push past 1000MHz

Can you adjust Vtt voltage in BIOS? This is not same at all as MCH voltage, and MCH adjustment really not needed at all for any of this but it's safe to use around 1.2-1.25 if you find it helps.. I see in your software Vtt is shown, but is that only place you can adjust, or BIOS too? This may need 1.2-1.3+ for 8GB at 1000+, using ram voltage 2.1 should be enough. Vtt increase should really help and this may be one of the larger issues holding you back, and if you can adjust tRFC to max for now, and tRead/Performance level in BIOS that would be good too.

I'll check BIOS now, thanks for board info. I only have up to v14 Sad Grabbing 17 from your link above to add to my pile, thanks Big Grin
Can you link 19 you're using too, thanks

I checked, at least in 17, no MCH Strap or memory strap options, so your locked into using whatever it's using
find
quote
#7
Same setting and voltages i can edit at bios tRFC max can be 78 and not help anything any settings wont help i tried a lot. I didn't try 2x2 but 2x1 worked at first try at 1200mhz. There is something in bios for sure 990-994 is stable at 1.8v and 1000 doesn't even on higher voltages everything much higher wont help. And it's like this that at 1000 Mhz most BSOD at prime95 and when you use normal PC many times errors like bad ram. So for sure fault must be at bios. Here you can find bios no19 and much more.
find
quote
#8
Did you try 1.2-1.3 VTT voltage yet? Did you try same with official older BIOS?
find
quote
#9
Yes i tested all bioses but 11-14 doesn't support rev E0 cpus. Max Vtt i made 1.25v Its for sure bios plus this kingston problem. Cant be 5-10mhz so big change. But need someone who can programming in assembler and decompile roms maybe. To check those meminit roms. I think at asus motherboards tREF i saw over 16000t when here is 3120t.

What i see some timings changed alone:
[Image: timing2.jpg]

1 more idea maybe push bios from ddr3 version or even ix48, there is cl3-11 when my only have 3-6 settings all other timings same just i don't know if this can boot and what with meminit if need swap with ddr2.
find
quote
#10
Make it support those CPU's, add microcode = win - many times older BIOS might work better for things like this.
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in