Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
DELL Inspiron 518 & Xeon 5400 Series
Will do. Thank you very much DeathBringer.
**Props to DeathBringer for adding the microcode to the bios**

The Inspiron 518 with bios 1.0.8 has partial support out of the box for X5450.

DeathBringer has injected LGA 771 microcodes to get full support for X5450.

With these bios you will gain the full the full instruction set for the X5450 (VT-X, SSE4.1, CompareExchange128 etc)
If you own an Inspiron 518 and have an X5450, you will not be able to upgrade to Windows 10 without these instructions.

Attached are the modified bios.

Thanks DeathBringer for your time and work.

Instructions to install the bios (Very Important as Win Flash will p00p the bed if you do not pass bios name as a parameter)
1. Unpack all files to c:\bios
2. Run cmd with admin rights.
3. Do in command line: cd c:\bios
Then type in: WinFlash 7C1D1P29.BIN

This should unpack and ask you to update bios.

After installation do a restart and you should be in business!

Before and after pics included along with error if you don't follow the instructions.

BTW CPUZ reads X5450 as E5450 at top but bios and the rest of CPUZ are correct**

*****As of 11/10/2016 I was made aware by DeathBringer that these bios support all X5400 series xeons on the inspiron 518.*****

As always,
Thank you Bios-Mods community.

Attached Files Thumbnail(s)

.zip (Size: 520.13 KB / Downloads: 18)
I am requesting the microcode for the X5470 xeon be added to the attached bios for a Dell Inspiron 518. These bios are the most current and have been edited once by member DeathBringer to fully support the X5450.

X5470 S-Spec SLBBF

I have tried to edit these bios a long time ago but I remember Dell locked these bios up tight and I could not get entry to edit them. If your out there DeathBringer your my man!!!

Thanks for all the support Bios-mods members.

Attached Files
.zip (Size: 520.13 KB / Downloads: 7)
This BIOS mod already has microcode for all Xeon 5400 series.
(11-12-2016, 01:59 AM)DeathBringer Wrote: This BIOS mod already has microcode for all Xeon 5400 series.

I just realized that. After a load optimized bios selection the system caught on. Sorry to take your time. I appreciate your help and I'll add a note that this bios supports all x5400 xeons in the working bios section. Thanks man.
Tried the update, ran per instructions. Got an error message that said failed to erase. Rebooted to black screen. How can I recover this bios?
Do you have a working bios mod for a Dell Inspiron 518? The file in this post bricked a motherboard, folled directions and it failed to erase and said to check to make sure board wasn't locked and rebooted to a black screen, no post. Got a new motherboard but don't want to use this same file. Bios is the latest from dell. Just installed a Intel Xeon E5450.  Works but I want to make sure its fully supported, windows 10 64bit installed. Thanks
(04-04-2017, 01:59 PM)clickitrepair Wrote: it failed to erase
Erasing always before writing. So this mod isn't the reason of your problem.
You should flash it in supported(!) operating system and with supported(!) CPU.
I think this WinFlash is too old and doesn't support Windows 10.
You can use awdflash in native DOS instead of WinFlash in Windows.
BTW: hardware programmer (like CH341A) can help to recover BIOS.
[Image: 02671da8b45f49eca8c216eb8031c9d3.png]
It was a supported CPU. Error was that it failed to fully erase before writing new bios, saying the bios was locked, but I udated the bios to 1.0.8 from dell website in windows 10 no issue. I am aware it must erase every time for bios update. What are the advantages of this hack? Only reason I ask is that it seems the Xeon cpu is working and showing up just fine. Not sure I want to risk bricking another motherboard. Thanks
(04-05-2017, 12:35 PM)clickitrepair Wrote: but I udated the bios to 1.0.8 from dell website in windows 10 no issue.
This does not mean that it will always be so.
Make & post a screenshot of regedit with expanded key HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System\CentralProcessor\0
Also I need a screenshot of CPU-Z.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in