Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dell Inspiron 1545 & Core 2 Extreme QX9300 & Core 2 Quad Q9100
#1
I would like to operate core 2 extreme qx 9300 with inspiron 1545
core 2 extreme The cpuid of qx 9300 is 1067 A
In the official inspiron 1545 bios the code of 1067 A is the one of 2008/04/09 old and supports core 2 extreme qx 9300 Precision M6400 bios is 2011/10/04 that is newer than inspiron 1545
So I thought that it would be better to replace microcode and did the following

[1], I have inspiron 1545 a14 bios (https://goo.gl/U3Z5nj) and
Precision M6400 a13 bios (https://goo.gl/k1UeTk)
Downloaded.

[2], both of the two exe files
filename.exe / writehdrfile
And I got two bios .hdr files

[3], I checked the position, size and date of microcode using MCE.exe in UBU_v1_70_b8_Dev and I was convinced that the bios file of inspiron1545 contains the old microcode 

[4] Open the .hdr file using HxD Hex Editor and copy the character string of 0x2000 size from the position confirmed from the Precision M6400 bios file with MCE.exe and replace it with microcode of Inspiron 1545

[5], this worked Inspiron 1545's 1067 microcode .hdr file was replaced by the one on October 4, 2011

[6], I learned that PhoenixTool.exe can compress .hdr files into .gz and remodeled.hdr file was compressed by PhoenixTool but PhoenixTool had {no vaild checksums found}  Huh Angry

[7] Then I compressed my unmodified. hdr file with PhoenixTool This worked fine The bios.gz file was completed

[8],When I confirmed the contents with 7-zip I confirmed the size that bios.hdr was in and it was exactly the same as the remodeled .hdr file so I overwrote it with a remodeled .hdr file

[9], usb 
not remodeled biosfile.exe
I added a modified. Hdr file
bios.gz
I entered biosfile.exe / readgzfile in the dos window I thought this would work. But the dell bios updater said {ROM file CRC - 32 is incorrect. Bad ROM file} Angry Angry Angry 

I think that crc32 is checked before updating bios and it is supposed not to update unless it matches Is there a way to match crc32 with unmodified file or how to skip crc32 check?
You can use any method
I am tolerating risks
Help me
Thank you


Attached Files Thumbnail(s)
   
find
quote
#2
Post screenshots of first (CPU) & third (Mainboard) tabs of CPU-Z with supported CPU.
find
quote
#3
(07-01-2018, 10:56 AM)DeathBringer Wrote: Post screenshots of first (CPU) & third (Mainboard) tabs of CPU-Z with supported CPU.
Thank you for answering

Screenshot of core 2 extreme x9100 currently in use with inspiron 1545


Attached Files Thumbnail(s)
       
find
quote
#4
A few motherboards with Socket P can boot quad cores CPUs. It's hardware incompatibility.
But you can try the motherboard's mod for quad core CPU supporting.

Current version of microcode is enough to start QX9300, but you can try to flash my mod with updated microcode.
find
quote
#5
Thanks, I try the motherboard's mod for quad core CPU supporting. And bios update
find
quote
#6
Since my pc was already running fsb at 1066 MHz

I do not do 

"" 2) Modify the mainboard:

http://abload.de/img/266-fsbe2cow.jpg (240 kB image hoster link)

Cut the yellow marked trace, then the marked side of the capacitor. We are thinking it the operators at 200 MHz, which is needed. There is no need to revert this changes if You want to use a CPU made for FSB - 800 when doing the modification this way (but the BIOS has to contain the microcode for the CPU).

Now you should be able to use FSB-1066-CPUs. If you have the hardware, you should test stability now with a normal FSB-1066-Core2, so that you can be sure that your RAM and chipset work stable at the higher speeds before proceeding with the next steps required for quad core support.""


I do
""{3} (only for Core 2 Quad) Modify the mainboard further and insulate CPU pins:}
of
{Besides this, a core 2 quad has some tested motherboards for this motherboards for this operation on a quad are connected to VCC or VSS on dual cores, so we have to insulate them on our quad core inserting it in a mainboard made only for dual cores.
These are D8, AA7, AA8, AC8 and AE8.

I used the insulation of thin wires, cutted it into pices, so that I got small tubes which I could stick onto the pins with some tweezers.

http://abload.de/img/quadcore-pinsy1dm5.jpg (240 kB image hoster link)

I opened the four clips at the socket have the sockets at the bottom of the socket, the two parts of the socket, so That no chips will get into the socket. Do NOT try to drill the holes without hanging out the top of the socket!

http://abload.de/img/bild3mns98.jpg (150 kB image hoster link)
(This image shows T500 board, but it is done the same way on T61 board)

Put the socket together again:
http://abload.de/img/sockelt6126e71.jpg (225 kB image hoster link)
}""

I only did and launching the PC it worked!! Big Grin  , But I only have 2 cores enabled Angel

If I do this, will 4 cores be enabled?(BIOS has not updated yet)
Also, which one should I do, 1 or 2?
I will send the picture of my motherboard and the direction of cpu(bord1.jpg = bord, bord_cpu.jpg =direction)
1
""{Core 2 Quad needs GTLREF (which is 0.63 * VCC 1 R 05 B) at pin D 22, which is reserved on dual cores.

http://abload.de/img/t61-mainboard-quadcor4qep0.jpg (210 kB image hoster link)}

2
""Edit: Here is a much simpler solution suggested by FryPpy, which is confirmed to work.""


thankyou


Attached Files Thumbnail(s)
       
find
quote
#7
(07-02-2018, 05:09 AM)toshi8003 Wrote: I only did and launching the PC it worked!! Big Grin  , But I only have 2 cores enabled Angel
Did you tried to do Load Defaults in BIOS?
Do it again and make TXT-report of CPU-Z.

Run msconfig.exe
Go to tab Boot
Click BOOT Advanced options button.
Make & post a screenshot.
find
quote
#8
(07-02-2018, 11:42 AM)DeathBringer Wrote:
(07-02-2018, 05:09 AM)toshi8003 Wrote: I only did and launching the PC it worked!! Big Grin  , But I only have 2 cores enabled Angel
Did you tried to do Load Defaults in BIOS?
Do it again and make TXT-report of CPU-Z.

Run msconfig.exe
Go to tab Boot
Click BOOT Advanced options button.
Make & post a screenshot.

I tried initializing the bios setting, cmos clear, but only 2 cores were valid
Also, since I possess 4 core Core 2 Quad Q9100 it insulated as well as QX 9300 it worked, but only 2 cores were valid Sad 

The png file is a screenshot of BOOT Advanced options when each cpu is installed

The txt file is a report of cpu - z when each cpu is installed

thankyou


Attached Files Thumbnail(s)
       

.txt   Core_2_Quad_Q9100.txt (Size: 55.51 KB / Downloads: 3)
.txt   Core_2_Extreme_QX9300.txt (Size: 50.2 KB / Downloads: 3)
find
quote
#9
Run msconfig. Press button Advanced options on current OS in Boot tab. E.g.
[Image: 1396959939201.win7%20advance%20boot%20op...config.png]
Uncheck Number of processors. Press OK.
Reboot and make new screenshot of main tab of CPU-Z.
find
quote
#10
(07-02-2018, 11:35 PM)DeathBringer Wrote: Run msconfig. Press button Advanced options on current OS in Boot tab. E.g.
[Image: 1396959939201.win7%20advance%20boot%20op...config.png]
Uncheck Number of processors. Press OK.
Reboot and make new screenshot of main tab of CPU-Z.

I unchecked and restarted, but only 2 cores are recognized

Screenshot of cpu - z main screen and cpu - z report (after restart)

thankyou


Attached Files Thumbnail(s)
   

.txt   Core_2_Quad_Q9100_new.txt (Size: 55.48 KB / Downloads: 1)
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in