Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Disabling CompuTrace
#1
Greetings everyone,

I refurbish computers for a living.  An office in my area upgraded their laptops and sent the old ones to a recycling center in my area.  The recycling center plans to scrap them for metal, because they all have Computrace active.  If I can disable the Computrace, they're willing to sell them to me for cheap.  They gave me one of them to play with and try to disable it.  If I can't, they're going to throw these otherwise perfectly good I5 laptops in the shredder.

They are all Dell Latitude E5430.  The one I got had bios A11 on it, and I flashed it to A18 (non-vPro).

Direct link:  https://downloads.dell.com/FOLDER0413595...430A18.exe  

Computrace has 3 settings in the Bios - "Disabled", "Deactivated", and "Activated".  "Deactivated" means it's ready to be set to "Disabled" or "Activated".  Once set to one of those two, it can "never" be changed, and the setting in the Bios is grayed out.  I want to change the setting from "Activated" to "Deactivated" so I can then go in and disable it.

I found a video of someone doing this on a different Dell (this is exactly what I'm trying to do):  
https://www.youtube.com/watch?v=kwsM51V0SXc

What I've tried:
- I tried extracting the Bios from the "5430A18.exe" file using the /writehdrfile and /writeromfile flags, but got errors and it didn't work.
- I used "Universal BIOS Backup ToolKit 2.0" to try to backup my Bios to a file.  I ended up with "DellInc.-A18.rom", which is 14MB.  It is attached.
- I then used "UEFITool_0.22.4_win" to try to edit the Rom. I found 2 Computrace modules, and a lot a Computrace references in "SetupPrep".  The 2 modules were easy enough to remove, but wasn't sure if I should remove SetupPrep or leave it.  I don't know enough to edit it. I decided to leave it.
- I got stuck when it came time to try to flash the Rom file back.  Dell has no separate flash utility for Rom/Bin/HDR files; their Bios files are all EXE.  I tried a few flashing programs, but they all said my Rom was an invalid file.

Can anyone please help me?


Attached Files
.zip   DellInc.-A18.rom.zip (Size: 3.5 MB / Downloads: 0)
find
quote
#2
I'm in the same boat with a E6530 with A14 bios.  Was royally screwed on my laptop purchase with an authorized vendor, and a highly disrespectful Absolute Software / Computrace employee lying to me about its activation and purpose.  The computer came from a school, who sold all their hardware cheaply, but didn't deactivate the software, and while it is not stolen, the company computrace will not do anything for me.
So far 600.00 bucks wasted. 

At least my computer isn't bricked, but I can't run any of my older proprietary software that uses hard drive copy protection schemes not to mention just the idea of this running in the back ground doesn't give me any security or piece of mind.

I have seen so many videos and posts where people say they can do it, but I certainly am not that smart.

I will keep a watch on this with hopes of learning and taking a hands on approach to removing this bug.
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in