Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HP Z2 mini G4 Workstation extended CPU support
#1
Hi all,

I have an HP Z2 Mini G4 Workstation - details here: https://www8.hp.com/h20195/v2/getpdf.aspx/c05987462.pdf

This comes in two versions: 'Entry' and 'Performance' - I have the 'Entry' version.

The entry version only supports a handful of CPUs:

Intel Xeon processor E-2104G
Intel CoreTM i7-8700 processor
Intel CoreTM i5-8600 processor
Intel CoreTM i5-8500 processor
Intel CoreTM i3-8100 processor
Intel PentiumTM G5400 processor


But the 'Performance' version supports a lot more, including i7-9700K and i9 CPUs...  (I had already upgraded the Power Supply to the 230w version to support the higher TDP of these.)

I tried my 'Entry' version with an i7-8700K and an i7-9700K and got a 'CPU unsupported' before boot.  Both versions use the same BIOS - is there any way of enabling the extended list of supported CPUs on the 'Entry' model...?

I have attached the bin of the BIOS.  Let me know if you fancy a challenge and need any more information!
find
quote
#2
Post a screenshot of third (Mainboard) tab of CPU-Z with native CPU.
Make a photo of the screen with 'CPU unsupported' error.

Download Intel CSME System Tools v12
I need results of MEInfo on this system.
find
quote
#3
(05-14-2020, 01:02 PM)DeathBringer Wrote: Post a screenshot of third (Mainboard) tab of CPU-Z with native CPU.
Make a photo of the screen with 'CPU unsupported' error.

Download Intel CSME System Tools v12
I need results of MEInfo on this laptop.

CPU-Z:

   

I'm afraid I no longer have the CPUs that don't work, and am trying to remember the exact wording...  It was in a red font, before the BIOS splash screen.  I think it said "CPU not supported".

MEInfo:

Intel ® MEInfo Version: 12.0.64.1551
Copyright © 2005 - 2020, Intel Corporation. All rights reserved.
General FW Information
    Platform Type                              Work Station
    FW Type                                    Production
    Last ME Reset Reason                       Global system reset
    BIOS boot State                            Post Boot
    Slot 1 Board Manufacturer                  0x0000103C
    Slot 2 System Assembler                    0x00000000
    Slot 3 Reserved                            0x00000000
    Capability Licensing Service               Enabled
    Local FWUpdate                             Enabled
    OEM ID                                     00000000-0000-0000-0000-000000000000
    OEM Tag                                    0x00
    TLS                                        Enabled
Intel® ME code versions:
    BIOS Version                               Q50 Ver. 01.06.02
    MEBx Version                               12.0.0.0010
    Vendor ID                                  8086
    FW Version                                 12.0.10.1128 H Corporate
    LMS Version                                Not Available
    MEI Driver Version                         1914.12.0.1256
    Wireless Hardware Version                  Not Available
    Wireless Driver Version                    Not Available
IUPs Information
    PMC FW Version                             300.2.11.1018
    LOCL FW Version                            12.0.10.1128
    WCOD FW Version                            12.0.10.1128
PCH Information
    PCH Version                                12
    PCH Device ID                              A309
    PCH Step Data                              B2
    PCH SKU Type                               Production PRQ Revenue
    PCH Replacement State                      Disabled
    PCH Replacement Counter                    0
    PCH Unlocked State                         Disabled
Flash Information
    SPI Flash ID 1                             Not Available
    SPI Flash ID 2                             Not Available
    Host Read Access to ME                     Not Available
    Host Write Access to ME                    Not Available
    Host Read Access to EC                     Not Available
    Host Write Access to EC                    Not Available
FW Capabilities                                0x5DF6D147
    Intel® Active Management Technology - PRESENT/DISABLED
    Protect Audio Video Path - PRESENT/ENABLED
    Intel® Dynamic Application Loader - PRESENT/ENABLED
    Service Advertisement & Discovery - PRESENT/ENABLED
    Persistent RTC and Memory - PRESENT/ENABLED
End Of Manufacturing
    Post Manufacturing NVAR Config Enabled     Yes
    HW Binding                                 Enabled
    End of Manufacturing Enable                Yes
Intel® Active Management Technology -
    Intel® AMT State                         Disabled
    M3 Autotest                                Disabled
    Localized Language                         English
    C-link Status                              Enabled
    AMT Global State                           Disabled
    Privacy/Security Level                     Default
Intel® Protected Audio Video Path
    Keybox                                     Not Provisioned
    Attestation KeyBox                         Not Available
    EPID Group ID                              0x28CA
    Re-key needed                              False
    PAVP Supported                             Yes
Security Version Numbers
    Minimum Allowed Anti Rollback SVN          1
    Image Anti Rollback SVN                    4
    Trusted Computing Base SVN                 0
FW Supported FPFs
                                               FPF         UEP         ME FW
                                               *In Use
                                               ---         ---         -----
Enforcement Policy                             0x00        0x00        0x00
EK Revoke State                                Not Revoked Not Revoked Not Revoked
PTT                                            Disabled    Disabled    Disabled
OEM ID                                         0x00        0x00        0x00
OEM Key Manifest Present                       Not Present Not Present Not Present
OEM Platform ID                                0x00        0x00        0x00
OEM Secure Boot Policy                         0x404       0x404       0x404
CPU Debugging                                  Enabled     Enabled     Enabled
BSP Initialization                             Disabled    Disabled    Disabled
Protect BIOS Environment                       Disabled    Disabled    Disabled
Measured Boot                                  Disabled    Disabled    Disabled
Verified Boot                                  Disabled    Disabled    Disabled
Key Manifest ID                                0x00        0x00        0x00
Persistent PRTC Backup Power                   Enabled     Enabled     Enabled
RPMB Migration Done                            Disabled    Disabled    Disabled
SOC Config Lock                                Done        Not Done    Done
SPI Boot Source                                Enabled     Enabled     Enabled
TXT Supported                                  Enabled     Enabled     Enabled
ACM SVN FPF                                    0x00
BSMM SVN FPF                                   0x00
KM SVN FPF                                     0x00
OEM Public Key Hash FPF                      0000000000000000000000000000000000000000000000000000000000000000
OEM Public Key Hash UEP                      0000000000000000000000000000000000000000000000000000000000000000
OEM Public Key Hash ME FW                    0000000000000000000000000000000000000000000000000000000000000000
PTT Lockout Override Counter FPF               0x00

Hope this is udeful? It's a mini-workstation with the Intel C246 chipset, not a laptop, if that helps.
find
quote
#4
No CPU - no help.
find
quote
#5
(05-17-2020, 02:36 AM)DeathBringer Wrote: No CPU - no help.

Hi Deathbringer,

If you think there's something you can so, I'll get my hands on one of the unsupported CPUs.  Grateful for any assistance!


×
find
quote
#6
Any chance you'd be willing to help..?
find
quote
#7
I can't help without a photo of the screen with 'CPU unsupported' error.
find
quote
#8
(05-20-2020, 04:07 AM)DeathBringer Wrote: I can't help without a photo of the screen with 'CPU unsupported' error.

OK thanks, let me see what I can do.


×
find
quote
#9
(05-20-2020, 08:05 AM)rob12345678 Wrote:
(05-20-2020, 04:07 AM)DeathBringer Wrote: I can't help without a photo of the screen with 'CPU unsupported' error.

OK thanks, let me see what I can do.


×

So I bought another 'unsupported' processor (i3-9100)... and it worked.  I'm wondering if it's because the TDP is also 65W, where the K chips were 95W.  Am going to try a non-K i9-9900 next...
find
quote
#10
OK so the i9-9900 works, so I'll just stick with that. Many thanks anyway!
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in