Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Latest Threads
BIOS Samsung RF510/RF410/RF710
Last Post: nebyru
Today 05:55 PM
» Replies: 0
» Views: 9
[REQUEST] Asus ROG Strix GL702ZC BIOS Un...
Last Post: Odin Vex
Today 05:48 PM
» Replies: 146
» Views: 49845
[REQUEST] Lenovo G580 (5ECNxxWW) Whiteli...
Last Post: 2bell
Today 03:23 PM
» Replies: 2036
» Views: 419901
[REQUEST]Unlocking advanced bios menu Le...
Last Post: jcnwholland
Today 02:21 PM
» Replies: 7
» Views: 252
[REQUEST] Lenovo Legion 5 (EFCNxxWW) BIO...
Last Post: Scax
Today 01:56 PM
» Replies: 18
» Views: 4406
[Request] Thunderobot Zero
Last Post: Exila
Today 12:19 PM
» Replies: 85
» Views: 12228
[REQUEST] Lenovo IdeaPad P400, P500, Z40...
Last Post: speedybeppe
Today 12:05 PM
» Replies: 95
» Views: 32845
[My Real, Single, and ONLY Request] Acer...
Last Post: fluffycat
Today 12:03 PM
» Replies: 2
» Views: 98
Intel T9550 for Dell Inspiron 1420
Last Post: DeathBringer
Today 11:55 AM
» Replies: 20
» Views: 555
Gigabyte z390 D rev1.0
Last Post: naporitan
Today 11:40 AM
» Replies: 8
» Views: 419
[REQUEST] BIOS Unlock ASUS X550IK / K550...
Last Post: genius239
Today 10:12 AM
» Replies: 3
» Views: 1427
[REQUEST] Lenovo T440(S) (GJETxxWW) Whit...
Last Post: Dudu2002
Today 08:07 AM
» Replies: 520
» Views: 116506
Aero 15 OLED XC Unlock
Last Post: jpaf
Today 12:53 AM
» Replies: 4
» Views: 211
[REQUEST] Acer Aspire A315-55G BIOS Unlo...
Last Post: Daniel's
Yesterday 10:50 PM
» Replies: 3
» Views: 769
[REQUEST] 2021 Acer Swift X - SFX14-41G
Last Post: SaarN
Yesterday 09:00 PM
» Replies: 4
» Views: 845
[REQUEST] Packard Bell EN TS11HR BIOS Un...
Last Post: Maxinator500
Yesterday 07:09 PM
» Replies: 18
» Views: 14140
[REQUEST] Lenovo G500 (78CNxxWW) Whiteli...
Last Post: Dudu2002
Yesterday 01:58 PM
» Replies: 1230
» Views: 196340
sony vaio vgn-c1s/w Bios update
Last Post: casperkral12
Yesterday 10:33 AM
» Replies: 0
» Views: 90
[REQUEST] Acer Aspire V3-772G BIOS Unloc...
Last Post: Dudu2002
Yesterday 07:48 AM
» Replies: 634
» Views: 125294
[Request] Lenovo 3000 G530 Whiteliste re...
Last Post: Maxinator500
Yesterday 07:21 AM
» Replies: 4
» Views: 2764

Lenovo T460 - I need a repair of the BIOS file - SOLVED
#1
Information 
Hello,

I have a Lenovo ThinkPad T460 with a "broken" BIOS file.

During a BIOS update something has gone wrong.
Now it is not possible to install a BIOS update.
After installing the T460 has to restart to finish the update, but it doesn't restart, no matter how long i wait.
I can plug off an on the electricity and the T460 will boot, but will not finish the update.
Only the old BIOS starts.

Now the T460 needs about 45 seconds to start booting. After booting everything works fine.

I bought a SPI flasher and made a dump of the BIOS file. 
I tried to flash a donor BIOS file form another T460, but it didn't work, the T460 did not boot or start with the donor
BIOS.


I flashed back the original BIOS file and it works with the known failure, it needs 45 seconds to start booting.


I think the original BIOS file is defective, or some parts of it, because a BIOS update has gone wrong.
A donor BIOS file does not work, I think because of some individual Keys or the TMP chip - I dont'know.

Is it possible to repair the defective BIOS file?
I can send you the original dump of the defective BIOS file and a dump of another T460 that works fine.

Of course i will return the favour if anybody can help.
find
quote
#2
Update:

I was able to flash a donor BIOS from another T460, Version 1.42.
After that I was able to install other BIOS versions with the Lenovo Update Tool using Windows 10, restarts to complete the updates 
are working fine. I have installed 1.41 and after that again 1.42, everythink works fine.


The only problem is, that the T460 still needs about 30 seconds to start booting.


Is there any way to fix it?


Can anybody help?   

I will return the favour!
find
quote
#3
I think the Problem is Intel ME. It is disapeard in the BIOS, the field with the firmware version is empty.
T think this is the reaseon the T460 Needs 30 seconds to start booting.

Does anybody know how to solve the problem?
find
quote
#4
I have a very similar issue.
Something went wrong during the BIOS update and I was forced to spam the power button a few dozen times to even get the machine to boot up.
Not only that, but it wouldn't reboot at all, only shutdown.


I bought a CH341A kit, waited about two weeks for it to get to me, and I found a BIOS dump on via Win-Raid forum while I waited.
I cleaned the ME Region and flashed it, only to find it's for an 20FN model and not my 20FM.
BIOS version is up to date but ME Firmware Version remains empty in BIOS and takes almost thirty seconds to POST.
At least it's able to reboot now.

Let me know if you find a fix.
I'll do the same.
find
quote
#5
I got it sorted!

Here's a repaired, clean and up to date BIOS dump: https://anonymousfiles.io/QIUpCEAZ/
Flash it with the CH341A Programmer software.

To correct your MTM and Serial number, you can download the Lenovo Maintenance Disk and follow the directions to get it booted from USB: https://archive.org/details/i7tm38us

Once booted, select option 1.


Pay special attention to the format used to key it in.
1STTTTMMMMCCSSSSSSSS = 1S 20FM 123456 1234ABCD = Whatever is printed on the sticker under your battery without the hyphens.
TTTT = Machine Type
MMMM = Model Type
CC = Country Code
SSSSSSSS = Serial Number

Here's a video someone made on it: https://www.youtube.com/watch?v=trXyPlLjhcs
find
quote
#6
@S3NTYN3L 

Thank you very much for your help, the problem is solved now!

The BIOS file was damaged, the Inel ME files were missing.
I have found the win raid forum, too.
I have tried to clean up the BIOS, but it didn't work. I tried it with the manual, but I was not
able to make step 7, there was no option to select the needed function.


Anyway, i have flashed the BIOS from your post with the CH341A programmer.
The T460 worked fine with it.
After that, I installed a regular BIOS update with the App "Lenovo Vantage", it worked fine.
There was only the message, that there is installed a custom BIOS and if I want to keep a copy of it.
I made the update, it worked very well.

There was no need to edit or to change any serial numbers. 
My Laptop works fine now.

Thank you very much!
find
quote
#7
(03-19-2020, 09:11 PM)Shepard Wrote: ... custom BIOS and if I want to keep a copy of it.
I made the update, it worked very well.

There was no need to edit or to change any serial numbers. 
My Laptop works fine now.

The custom BIOS message was likely because I had a custom boot image instead of the default red Lenovo graphic.
Glad to hear that your flash kept your original MTM and Serial numbers.

Enjoy.
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)