Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 3 Vote(s) - 3.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
You have to register before you can post on our site.



Latest Threads
[REQUEST] Lenovo G710 BIOS Whitelist Rem...
Last Post: alex 177
Today 06:42 AM
» Replies: 557
» Views: 122407
[REQUEST] Lenovo L540 (J4ETxxWW) Whiteli...
Last Post: Dudu2002
Today 01:52 AM
» Replies: 44
» Views: 3162
Last Post: literalmousse
Yesterday 11:30 PM
» Replies: 14
» Views: 2692
A315-59 Bios Unlock
Last Post: denemex
Yesterday 02:25 PM
» Replies: 2
» Views: 0
[Request] Tongfang GM7PX8N BIOS unlock.
Last Post: HiSJAM
Yesterday 08:25 AM
» Replies: 0
» Views: 0
hp 705 G2 & G3 with amd pro A4 cpu
Last Post: jamjam
Yesterday 06:10 AM
» Replies: 0
» Views: 0
modify bios SPD data for hp stream 11-y1...
Last Post: taylorgodiva28
05-29-2023 08:30 PM
» Replies: 3
» Views: 860
HP MCP61PM-HM (Nettle2) 5.27 With Unlock...
Last Post: Search For THE Bios
05-29-2023 07:01 PM
» Replies: 872
» Views: 697175
BIOS fix Lenovo c460
Last Post: DeathBringer
05-29-2023 08:10 AM
» Replies: 1
» Views: 0
[REQUEST] Asus ROG Zephyrus S GX701GX BI...
Last Post: adiif1
05-29-2023 02:26 AM
» Replies: 24
» Views: 4836
[REQUEST] Lenovo Thinkpad T430u (H6ETxxW...
Last Post: Dudu2002
05-29-2023 01:55 AM
» Replies: 22
» Views: 9106
[REQUEST] Lenovo Ideapad 330s-15IKB (81F...
Last Post: Furretix
05-28-2023 07:32 PM
» Replies: 6
» Views: 0
[REQUEST] IBM Aptiva K45 add CD-ROM Boot...
Last Post: dirsorsrs
05-28-2023 06:00 PM
» Replies: 0
» Views: 0
[Request] Bios mod for Lenovo Ideapad 51...
Last Post: artamis
05-28-2023 02:02 PM
» Replies: 4
» Views: 0
[REQUEST] Lenovo T440(S) (GJETxxWW) Whit...
Last Post: Dudu2002
05-28-2023 06:59 AM
» Replies: 484
» Views: 144697
[Unlocked] Alienware M14x bios unlocking...
Last Post: procious_saathvik
05-28-2023 05:16 AM
» Replies: 13
» Views: 17725
[REQUEST] Lenove Yoga 3 14 80JH Whitelis...
Last Post: Dudu2002
05-28-2023 03:03 AM
» Replies: 31
» Views: 9206
[REQUEST] Lenovo Y50-70 (9ECNxxWW) White...
Last Post: pastod
05-27-2023 10:14 PM
» Replies: 1990
» Views: 394338
HP 3500 pro MT bios Recovery
Last Post: massatt212
05-27-2023 10:04 PM
» Replies: 0
» Views: 0
Last Post: TUDOG
05-27-2023 07:00 PM
» Replies: 0
» Views: 0

[REQUEST] Toshiba Satellite C850 & C855 BIOS Unlock
(10-12-2019, 11:26 AM)hArDsTyLe2259 Wrote: Laptop Model: Toshiba SATELLITE C855-1HK

Im looking to unlock an option that allows me to enable UEFI Smile

Rev: 3.7
Bios version: 6.80

Bios date: 01/10/2013
SMBIOS Version: 2.7

I just realised i didnt put my bios download link! Here it is:
Ok so I need access to the advanced options in my BIOS on a TOSHIBA Satellite C850-B561 from 2012, I need access to it in order to increase my Intel Integrated Graphic's dedicated VRAM or its minimum shared system memory. Now, I've tried numerous methods to unlock these options such as pressing A just after pressing the F2(BIOS key) on my keyboard or pressing FN+TAB 3 times on the keyboard. So I've come to my last resort of hoping that someone who reads this will make a modded BIOS for me as I have no idea on editing my BIOS, My BIOS is an InsydeH20 v6.80 rev 3.7 and on the BIOS main section it says all this,
System Time:
System Date:
CPU Type
CPU Speed
Total Memory Size
System BIOS Version: 6.80
EC Version: 6.00

Now I need access to some more options on the advanced section, On the advanced section I only have all of these,
Boot Speed: Normal
Execute-Disable Bit Capability: Available
Virtualization Technology: VT-x Only
Beep Sound: On
USB Power in Sleep Mode: Enabled
USB Legacy Emulation: Enabled
>System Configuration

Now inside of the System configuration section, I don't have what I'm looking for. Please help me out, I don't have any other options available. I have experience with software and Hardware, Mostly with Hardware but never with the BIOS, Please try to unlock other hidden menus and options as well ^_^
- Motherboard Model: Toshiba Satellite C850-1CC (It might be Greek-market-restricted, as I only find it in Toshiba's Servers dedicated to Greece. Link:
- Bios Type: Inside Bios, Version 6.80, Revision 3.7 (Link from an other C850 which I have flashed and works:

Greetings everyone!

I have a couple of issues with this model, which I have seen addressed here through the past years that I have been using it.

My first issue would be the innate lock of the HM70 southbridge, which shuts the computer down after exactly 30' if the CPU is detected not to be matching the HM70's "list". Through my research towards this issue's solution, I came across the ME's 30' shutdown restriction, which seems similar to what I am facing. I first got some hints of this from this post:, in case anyone is furtherly interested or facing the same issue. I haven't twinkled with MEcleaner yet, as I'm waiting for my flasher to arrive, but I have not many hopes for this issue to be solved, as I found out through a little more digging that ME's 30' restriction is irrelevant to HM70's 30' restriction. Once my flasher arrives I will attempt it either way, in case it miraculously decides to accepts my i5-3320M. Otherwise I will have to stick with the Pentium B960 that the machine came with.
This concludes the first issue and I'm writing this just in case anyone has any idea or advice that could potentially solve this issue.

The second issue concerns a BIOS mod or, if even possible, an upgrade. It regards the same machine, a Toshiba Satellite C850, which has been running on the latest official BIOS since the day it was purchased. This was approx. back in 2014, so, as expected, its battery has run out of juice by now... I recently bought an OEM new one, and, as if this machine is unwilling to accept anything that is fed to it, it isn't recognizing it. Instead, there is the battery LED blinking at a steady pace, even when the laptop is shut down. Also, the laptop will not be starting with this new battery plugged in.
I got around this issue by removing the battery, starting up the computer and then plugging it in, when it "recognizes" it and posts it at 100%. (I believe this is just the last-known condition of the old battery.)
This solves my problem short-term and allows me to flash a new BIOS as well, as the computer is tricked to think that it has a full battery, but I'd rather that I don't have to unplug and plug the battery every time I want to turn the computer on. (Also, if I remove the power cable, it will revert to the "LED blinking state", so it will shut down almost immediately.)
Through this post ( I found out that it is a BIOS issue yet again! The easiest solution is simply a BIOS update, yet, I happen to already be running on the latest official BIOS for this device... Here lies my question: Is there a mod, an unofficial BIOS version or even a revision anywhere?

I have upgraded this laptop's HDD to an SSD, adding a disk caddie in the process to host the spare HDD, its RAM from 4GB to 16GB (somehow that was accepted) and am looking forward to its CPU upgrade as well (I bought the i5 nearly a year ago)... With a new battery and all these upgrades, I see it running a couple of years more (at least until win10 are abandoned, or potentially even further).
Therefore, any help regarding the above two BIOS related issues will be much appreciated!
(07-12-2015, 04:43 AM)BDMaster Wrote: Here You go (v.6.70 and v6.80 by Donovan6k) :


I have been following both the post where donovan6000 created these mods ( and this one, as I have posted a thread myself about my issue.

In case donovan6000's mods help me with my problem, is there anyone who can reupload the bios files for version 6.80? The download links (for instance: do not seem to be working for me...

Thanks in advance!!

Forum Jump:

Users browsing this thread: 1 Guest(s)