Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sabertooth Z77 nVME Intel 660p - Cannot install Windows... Need help!
#1
Hey all, I'm new around here, and this is my first post. Smile

I am trying to update a computer (my wife's actually) to boot off an Intel 660p on her Sabertooth Z77 motherboard. I followed the instructions here and the flash was successful. The SSD is in a PCIe casing.

I have tried using USB UEFI and CD UEFI to install Windows 10. Both were met with failure. The USB reported a BsOD saying the USB is corrupt (it isn't). In case of the CD, after asking to press any key to boot from CD, it reboots into non-UEFI low resolution Sabertooth Z77 logo and stays frozen there.

Non-UEFI wise, both USB/CD arrive at same result. On selecting partition to install Windows, I get a message saying that Windows cannot install on this disk and asks me to go into BIOS to enable this controller. Unfortunately, there is no nVME controller setting in the Z77 BIOS.
I tried playing with CSM options as well as DISKPART to no avail.

I should also mention the 660p is the only drive connected to the PC. I disconnected all other drives.

Perhaps there is a way one of you guys can help a fella out and see this resolved? I would really appreciate the help to get that PC booting off of that SSD.

Thanks!
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in