Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
You have to register before you can post on our site.



Latest Threads
[REQUEST] Bios Unlock Gigabyte AERO 15 O...
Last Post: falconnic
Today 12:28 AM
» Replies: 22
» Views: 2882
[REQUEST] Lenovo B590 (H1ETxxWW) Whiteli...
Last Post: troymax33
Yesterday 06:03 PM
» Replies: 910
» Views: 272382
[ЗАПРОС] на разблокировку samsung
Last Post: sergei_mors
Yesterday 04:29 PM
» Replies: 0
» Views: 0
sony vaio pcg-71712n CPU upgrade from In...
Last Post: Starlingc
Yesterday 11:11 AM
» Replies: 2
» Views: 0
Lenovo B590 unlock the checking original...
Last Post: Denis.G
Yesterday 09:18 AM
» Replies: 30
» Views: 15337
[REQUEST] Lenovo Y50-70 (9ECNxxWW) White...
Last Post: kels2903
Yesterday 07:04 AM
» Replies: 1967
» Views: 394338
Lenovo E585: refuses to boot after a bio...
Last Post: kurtspirit
Yesterday 06:49 AM
» Replies: 0
» Views: 0
[REQUEST] Lenovo IdeaPad Gaming 3 15IMH0...
Last Post: Dudu2002
Yesterday 04:05 AM
» Replies: 48
» Views: 12320
Last Post: rezilienza
Yesterday 01:11 AM
» Replies: 12
» Views: 1327
Intel DG41WV and Xeon X5450, microcode u...
Last Post: Bielito
11-25-2022 08:10 PM
» Replies: 56
» Views: 25500
[REQUEST] Acer Predator Helios 300 PH315...
Last Post: Dudu2002
11-25-2022 05:47 PM
» Replies: 60
» Views: 19593
[REQUEST] Lenovo L540 (J4ETxxWW) Whiteli...
Last Post: Dudu2002
11-25-2022 08:17 AM
» Replies: 50
» Views: 3162
[REQUEST] Packard Bell TM85
Last Post: Maxinator500
11-25-2022 06:18 AM
» Replies: 4
» Views: 956
[REQUEST] Lenovo Ideapad Gaming 3-15ACH6...
Last Post: Navneet Kumar Singh
11-24-2022 10:43 PM
» Replies: 9
» Views: 478
[REQUEST] Bios unlock aorus 17 xe4
Last Post: Lexmada
11-24-2022 07:52 PM
» Replies: 0
» Views: 0
[REQUEST] Lenovo G505S (83CNxxWW) Whitel...
Last Post: pkorchmidt
11-24-2022 03:29 PM
» Replies: 77
» Views: 17528
ECS RC410L/800-M (V2.0): Core 2 duo supp...
Last Post: jollystukas
11-24-2022 01:20 PM
» Replies: 9
» Views: 5794
[REQUEST] Bios Unlock Gigabyte AERO 15 O...
Last Post: falconnic
11-24-2022 11:46 AM
» Replies: 0
» Views: 0
[REQUEST] Lenovo G50-80 (B0CNxxWW) White...
Last Post: Dudu2002
11-24-2022 11:18 AM
» Replies: 101
» Views: 27411
[REQUEST] Lenovo G710 BIOS Whitelist Rem...
Last Post: Dudu2002
11-24-2022 11:16 AM
» Replies: 550
» Views: 122407

[Solved] Acer v3-772g InsydeH2O bios bricked. Recovery doesn't work

I recently updated my bios to the bios in this thread: even that my model isn't 100% the same. Bios was working perfectly until i'll started doing to many changes in the advance section. Now my computer wont load bios and its stuck on black-screen, all lights and fans are working. Therefore ill request an orginal bios file or a modified biosfile for bios recovery.

Im going to follow this tutorial:
May try to use the FN + ESC if its not working with Win + B

Can someone help me out here? Big Grin

"New signature: Learning by doing"
#Update# Ive read about a guy with same problems i think. He said:

"HAPPYYYYYY!!! Thanks to Recovery!

No CMOS Battery or else...... just extract the Bios File from Acer,Rename it to VA70HWX64.fd,Format USB Stick to FAT32,Unplug Battery from Notebook,put USB Stick on left 1.USB Slot,Hold FN+Esc,push Power Button,after 30 sec. a signal Beep comes,no afraid,just wait....and voila..... the Acer Boot Logo apears!"


I have tried to do this myself but not working no messages at all. Im nor sure if im doing it right, ive tried to copy all files over to USB and rename FD-file to VA70HWX64.fd ive also tried to do it with single FD-file renamed. USB is FAT32 and all USB-ports have been used. I got my file from Acer drivers "Bios-Update".
Also tried to remove CMOS-battery
Hi friend,
which Bios version and which file You got ?
Spartan had the v.1.15 and your actual ?
Let me know

Here is the Recovery Bios v.1.15 :

[size=undefined]Your Brain [/size]. . . . It's the best tool U can use ! Wink
[size=undefined]Don't FLASH the Bios Mod if You get a Size Alert, You risk a Brick !!! [/size]
Donate to me for my work, click here BDM
Thanks for your feedback! Smile

I had Insyde 1.15 stock. Trying to recover with your file but screen still black.
I did some changes on my videocard including changing value from 1200 to 2000 i think it was some power setting.
Maybe i have fried my graphic chip?
No I think that You have Boot Block issue and Bios cannot be Recovered by Itself !
So You need the tools (SPI PGM and Clip), look here :

Get the tools and I will help You to make the job !
Let me know

[size=undefined]Your Brain [/size]. . . . It's the best tool U can use ! Wink
[size=undefined]Don't FLASH the Bios Mod if You get a Size Alert, You risk a Brick !!! [/size]
Donate to me for my work, click here BDM
Hi folks,
I've been trying to make Pci passthrough happen on my device, so I was playing around in the Advanced Tab of my modded bios. I don't remember which options I changed (I think i was messing with chipset options) but, now I don't have display on my screen.
When I press the power button, computer starts, fan starts spinning, and hdd busy led flashes for a second like a normal bootup. Even AC power jack beep works. But I have no display. Tried hdmi, but it's same.
I have also tried clearing cmos by removing cmos battery, waiting for 10-20minutes; tried bios recovery with fn+esc key combination with no luck. Usb recovery method worked before when I was trying to mod my bios. Used same usb flash to recover before but this time with no luck.
Removed all HDDs, pci wlan card, ram. Tried with different ram module. No display...

Similar thing happened before when I disabled the Optimus option. But that time, clearing cmos did the trick. I'm certain I didn't play with optimus this time butchanged a lot of pci-e options.

What should I do? Any suggestions apreciated.
Sorry for bad grammar.
Bought spi flasher. Gonna try flashing bios and me firmware. I'll report back in 2-3 days.
Good news! Reflashed bios chip with the ch341a spi flasher, and it works again!
Now I'm confident that I will be able to recover the bios again, I'll continue my pci-passthrough journey.
Hello, my name is Tobias,

yesterday I tried to reflash this (Biosbackup.bin) modified bios BDMaster made for me a few years ago.
I used the windows interface to flash the bios but unfortunately the screen completely freezed and an error similar to  this one showed up: "Unable to flash bios, no permissions"...

I turned of the Laptop, removed the battery and tried restart it... But nothing... No fan, not even the power indicator LED on the power button turned on. Just a black screen.
After that I tried to reflash the bios by emergency mode, but that was unpossible because there is no power on the USB port.

The last option I´ve known was to use my CH341 EEPROM programmer with SOIC-8 Clip. I completely disassembled the laptop, connected the clip to the bios chip and reflashed the bios. Unfortunatelly it´s still not working, the laptop looks like being dead...

The Bios chip is this one: MXIC MX 25L1673E M2I-10G, SOIC-8, 16MBit SPI Flash.
It has a capacity of 2MB but the BIOS rom a capacity of 4MB. I did a lil bit of research and found out that on this 4MB ROM could be also be in additon stored the intel ME (management interface) with 2MB of storage...  How can I remove this from the BIOS rom? Otherwise I´ll never be able to reflash the Bios properly.

What am I doing wrong? ;(

Hopefully someone can give me a lil tip to revive my laptop (Acer V3-772g-747a161TBDWakk) Undecided

Wish all of you an amazing day!


EDIT: I recently found out that there is a MXIC MX 25L3273E M2I-10G, SOIC-8, 32MBit SPI Flash BIOS chip on the back side of the motherboard... This one has a capacity of 4MB´s... Probably this is the one I need to reflash... I´ll update this as soon as I reflashed it...

EDIT2: Could this second (2MB) BIOS Chip be for redundancy? Does that make sense?  ?

EDIT3: The second one (2MB) is for the EC.

Attached Files Thumbnail(s)

Forum Jump:

Users browsing this thread: 4 Guest(s)