Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 14 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[-]
Welcome
You have to register before you can post on our site.

Username:


Password:





[-]
Latest Threads
[REQUEST] Acer Nitro 5 AN515-54 BIOS Unl...
Last Post: Dudu2002
Today 06:37 PM
» Replies: 92
» Views: 29378
MSI 970 Modded Bios Request
Last Post: Davrsmania
Today 11:37 AM
» Replies: 0
» Views: 51
[REQUEST] HP Pavilion dm1 f13 bios mods
Last Post: tomsimi
Today 11:04 AM
» Replies: 0
» Views: 55
[REQUEST] Lenovo Yoga 2 13 (96CNxxWW) WW...
Last Post: Dudu2002
Today 06:55 AM
» Replies: 177
» Views: 63374
[REQUEST] ASUS TUF Gaming FX505DV BIOS U...
Last Post: Zues1911
Today 05:13 AM
» Replies: 3
» Views: 2573
[SOLVED] Change Serial Number, UUID, Mac...
Last Post: dremspb
Yesterday 04:15 PM
» Replies: 7
» Views: 7625
[REQUEST] Lenovo ThinkCentre M715q 2nd G...
Last Post: Vega068
Yesterday 01:06 PM
» Replies: 19
» Views: 2282
[REQUEST] Lenovo G500 (78CNxxWW) Whiteli...
Last Post: Hiva2023
06-14-2024 01:15 PM
» Replies: 1185
» Views: 291926
[REQUEST] Lenovo IdeaPad L340 (BGCNxxWW)...
Last Post: CyberBonk
06-14-2024 12:45 PM
» Replies: 58
» Views: 17769
HP EliteDesk 705 G5 SFF: CPU Upgrade
Last Post: clogscancer
06-14-2024 03:10 AM
» Replies: 3
» Views: 563
[REQUEST] Acer Aspire 5738(G,Z): CPU Upg...
Last Post: lollo90
06-13-2024 05:26 PM
» Replies: 45
» Views: 29583
[REQUEST] Sony VAIO SVE-151 & SVE-171 (R...
Last Post: noodlexd
06-13-2024 08:33 AM
» Replies: 0
» Views: 186
[REQUEST] Lenovo ThinkPad T450(s) (JBETx...
Last Post: portapane
06-13-2024 08:28 AM
» Replies: 135
» Views: 74670
[REQUEST] Acer Aspire 4738(G,Z) BIOS Unl...
Last Post: arisprast1
06-13-2024 01:28 AM
» Replies: 62
» Views: 17342
Acer Aspire 7750G: Ivy Bridge support
Last Post: DeathBringer
06-13-2024 12:23 AM
» Replies: 3
» Views: 386
[REQUEST] Sony VAIO SVE-151 & SVE-171 (R...
Last Post: noodlexd
06-12-2024 06:51 PM
» Replies: 42
» Views: 36716
[REQUEST] IGEL M320C Thin Client
Last Post: Trixxtar
06-12-2024 10:33 AM
» Replies: 1
» Views: 1089
[REQUEST] Acer Nitro 5 AN517-52 BIOS Unl...
Last Post: MATI1XD
06-11-2024 06:36 AM
» Replies: 17
» Views: 3842
MB (A55M-E33 FM2+)
Last Post: TamoNeki
06-10-2024 03:28 PM
» Replies: 15
» Views: 805
Lenovo Ideapad flex 4 14IAU7 missing UUI...
Last Post: balli4u
06-10-2024 01:10 PM
» Replies: 0
» Views: 250

[REQUEST] Lenovo X220 (8DETxxWW) Whitelist Removal
I installed the 1.46 full-mod BIOS on a X220 Tablet (i7), using flash.bat. Now it seems to have lost the SLIC table for Windows activation. Any ideas on how to get it back?

Running SLIC ToolKit, it now says SLIC Status: Invalidated

What sort of info would you need to help troubleshoot?

On a side note, the boot logo also disappeared. But that's the least of my worries right now.

EDIT: Clearing the NVRAM restored the original boot logo.
A member on another forum helped with a custom patch that restored the SLIC. So all good now. (There's 2x5 beeps on boot, but I can live with that or turn off TPM.)
find
quote
Looks like there is a DOS based bootable CD available from Lenovo as well. It appears that it uses pflash.exe, which contains at least these strings:

PFLASH v1.4.83.0 (20110105) ©Phoenix Technologies Ltd. 2009 All Rights Reserved$
Usage: PFLASH [/cvar] FileName$
FileName : New BIOS Name For Flash Programming$
/secure : Security Flash$
/cvar : Clear varibles$
/bbl : Update recovery volume$
/nosmi : Flash BIOS without SMI$
/hide : Flash BIOS without PFAE and GUI$
Example : PFLASH 965gf.fd$
: PFLASH /secure CAPSULE.cap$

Simply replacing the original file with modified version didn't work, apparently there is a checksum verification somewhere in there. Probably running the pflash.exe directly would bypass this, as well as version comparison. (I flashed with original 1.46, would be nice to reflash with modified version)

I will keep on working with the DOS image and its contents; it would be really nice to get this working - or has someone already seen the trouble?

....

pflash /exit /sa 8det76ww\$01cb000.fl1 --> "Fail to authenticate image!(Fail: UNSUPPORTED)"

$ sha256sum 8det76ww/\$01cb000.fl1
3fd47f1ba7cdbd6b577f32d640d65a8a4d74299632cca581a7e0993b5859ef4b 8det76ww/$01cb000.fl1

Is this some kind of checksum issue or am I just lucky I haven't bricked the x220 yet?

....

I called it quits, dug out a windows machine and created the winpe usb stick linked in the instructions on some post in this thread- link here to help other lazy people: http://x220.mcdonnelltech.com/bios/

That software installs nicely with Wine, and if you look where it installed itself, you will find an ISO image; worth taking a look at, could be handy for things like this.
find
quote
ValdikSS and johnmcdonnell,
I like your latest BIOS very much. I appreciate very much the effort you put into building a nice X220 BIOS.

I had an additional request.

Since I heared about Intel ME I do not trust it. How can we still trust that the Intel ME part in the new Lenovo BIOS just does what we want it to do? I did everything I could to disable all Intel ME components in the BIOS settings but in Windows the "Intel Management and Security Status" 2007-2010 still gives the messages:
- Intel Active Management Technology (Intel AMT): turned on (How can that still be the case?)
- Intel Remote PC Assist Technology (Intel RPAT): Not supported (Can we trust that statement, is all possible trouble really permanently solved?)
- Intel Antithefttechnology (Intel AT): Turned on (How can that be since I permanently disabled that in BIOS)
I disabled the possibility to update the Bios from within Windows but Lenovo asked for my password and updated the BIOS anyway, so how much can we trust the BIOs settings or that intel that ME is disabled?

From what I can find out there is no solution yet for the 30 minutes shutdown bug when Intel ME is completely removed. But there is something called me_cleaner which can do three things: (1) remove most parts of intel ME, (2) shrink the ME portion of bios and (3) enable A HAP bit for a High Assurance Platform setting which is supposed to mean that the remaining Intel ME components "do not misbehave".
see https://github.com/corna/me_cleaner/wiki...isable-bit
They claim that can be moved into a user flashable BIOS, if a ventor (like Lenovo) provides a flashing software (Like Lenovo does and I presume you use for your custom BIOS) it could be flashed from windows (or alternatively a windows PE bootdisk). That would be very nice since I am not a IT specialist but would like to get rid of Intel ME.

Would it be posible to incorporate that in a new custom BIOS for the X220?

I hope to hear from you guys about this
find
quote
Can anyone confirm which bios is working with X220 tablet? I need to remove whitelist to get a new wifi adapter Intel 7260.

Thanks
find
quote
(10-22-2018, 08:12 PM)Kalan1 Wrote: Can anyone confirm which bios is working with X220 tablet? I need to remove whitelist to get a new wifi adapter Intel 7260.

The BIOS posted by ValdikSS here works with all X220 models including tablets.
find
quote
Quote: Flashed 1.46 on X220 (Lenovo official 1.46 previously flashed) and "Advanced" menu shows, X220 is apparently behaving normally since. However at end of flashing (flash.bat) a message had appeared quickly three or more times in succession "Verifying BIOS Fail! Reflashing". Eventually the process finished without any particular confirmation message of success or otherwise.

Does this indicate something unrecoverable went wrong, or does it indicate the flash was eventually successful?

I had the same issue. Seems to me that it works normal as expected except that suspending does not work any longer. Can it be that this is related to this issue?
find
quote
(06-28-2018, 07:01 AM)ValdikSS Wrote:
(06-28-2018, 05:28 AM)tinybeaver Wrote: There is a new BIOS available for the X220, version 1.46 - https://support.lenovo.com/pl/en/downloads/ds018805. The changes are related to the Spectre (v3a and v4) security risk. May I ask for the unlock of this BIOS version? Many thanks

This package contains 2 BIOS modifications for Lenovo ThinkPad X220 laptop.

** Lenovo X220 v1.46 Modified Bios (no whitelist only) **

- Whitelist removal only
- Re-signed with custom key to get rid of 5 beeps on boot

** Lenovo X220 v1.46 Modified Bios (full-blown) **

- Whitelist removal
- Unlocked AES-NI on "no-encryption" machines
- Unlocked hidden advanced menu
- Unlocked memory speed (supports DDR3 1600 and 1866)
- Disabled package c-state lock at MSR 0xE2 (for Hackintosh)
- Re-signed with custom key to get rid of 5 beeps on boot


https://files.catbox.moe/9dt19z.7z
https://my.mixtape.moe/hduebg.7z
https://a.safe.moe/fAhaWog.7z
http://dl.asis.io/AGrynCdp.7z
https://u.teknik.io/ZwJOA.7z

this is my first time updating and flashing my bios and I know it can brick my machine so I want to make sure I'm doing this right.

my x220 is currently at 1.42.  Do I have to update to 1.43 > 1.44 > 1.45 > 1.46 in that order then update to 1.46 custom bios?
find
quote
I tried this Bios and I still get the error, is there something I'm missing? X220 4286-CTO 8DET76WW (1.46)
I did the white list only version. If it was successfully install would there be any way to tell other then not getting an 1802 Error?
I was trying to use the same card that was in the machine just from a different manufacturer Intel N6205, I also tried a N6230 with no luck. Multiple 1802 errors.

Regards
find
quote
No need to whitelist, I just saw post up for 1.46 bios.


Attached Files
.rar   outimage.rar (Size: 4.97 MB / Downloads: 38)
find
quote
With my X220 previously on official Bios 1.46, I always receive the error

"Verifying BIOS Fail! Reflashing" Confused

when flashing ** Lenovo X220 v1.46 Modified Bios (full-blown) ** under Windows 7.

Computer not bricked, modified bios seems to work, but there must be some binary mismatch...

Any ideas what might be the reason, and what is not working ?
find
quote


Forum Jump:


Users browsing this thread: 5 Guest(s)