Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
You have to register before you can post on our site.



Latest Threads
[REQUEST] Lenovo Thinkpad T420s (8CETxxW...
Last Post: Niemand
Today 03:15 PM
» Replies: 205
» Views: 71819
[REQUEST] Lenovo Thinkpad X240 (GIETxxWW...
Last Post: dj_igor
Today 02:54 PM
» Replies: 43
» Views: 15807
SOLVED Samsung AMI BIOS Write-Protection
Last Post: e_favero
Today 10:24 AM
» Replies: 1
» Views: 1253
[REQUEST] HP 1030 G1 setup_extr.txt only
Last Post: sonyu
Today 08:48 AM
» Replies: 0
» Views: 0
[REQUEST] Alienware x17 R1 Bios Unlockin...
Last Post: Zumakeydom
Today 08:47 AM
» Replies: 1
» Views: 365
[REQUEST] Lenovo Thinkpad T430u (H6ETxxW...
Last Post: Dudu2002
Today 07:36 AM
» Replies: 30
» Views: 9106
Unlock GA-P67-DS3-B3 (rev. 1.0)
Last Post: paissi
Today 04:29 AM
» Replies: 26
» Views: 9008
TerraMaster F2-220 Bios
Last Post: Voigoth
Today 04:08 AM
» Replies: 0
» Views: 0
Acer Aspire ZS600 (IPISB-AG Rev 1.06): U...
Last Post: DeathBringer
Today 12:40 AM
» Replies: 13
» Views: 1736
AMD Ryzen Motherboard Crossflashing Thre...
Last Post: sluclikocr
Yesterday 06:02 PM
» Replies: 1
» Views: 3270
[REQUEST] Unlock Bios Lenovo Yoga Book Y...
Last Post: Cryen
Yesterday 05:28 PM
» Replies: 1
» Views: 2112
[Request] Adding 7th Gen CPU support to ...
Last Post: DeathBringer
Yesterday 03:34 PM
» Replies: 3
» Views: 0
[REQUEST] Lenovo IdeaPad S145-15API (BUC...
Last Post: Dudu2002
Yesterday 02:10 PM
» Replies: 8
» Views: 2809
[REQUEST] Lenovo B590 (H1ETxxWW) Whiteli...
Last Post: bdivrik
Yesterday 12:25 PM
» Replies: 916
» Views: 272382
[REQUEST] Lenovo G780 (5ECNxxWW) Whiteli...
Last Post: Dudu2002
Yesterday 11:52 AM
» Replies: 965
» Views: 274416
Bricked Lenovo E530 during BIOS update
Last Post: macinor
Yesterday 11:08 AM
» Replies: 2
» Views: 0
Clevo P775TM1-G BIOS
Last Post: Satyre
Yesterday 06:58 AM
» Replies: 158
» Views: 53643
[REQUEST] Lenovo Legion T5-26AMR5 BIOS U...
Last Post: francuzz84
Yesterday 02:52 AM
» Replies: 0
» Views: 0
[REQUEST] Lenovo G580 (5ECNxxWW) Whiteli...
Last Post: Hannes
Yesterday 12:56 AM
» Replies: 2138
» Views: 520365
[REQUEST] Lenovo G400 (78CNxxWW) Whiteli...
Last Post: ForTheKop
01-31-2023 09:38 PM
» Replies: 82
» Views: 53045

[GUIDE] Flash BIOS with CH341A programmer

CH341A details

This guide is based on the winbond 25Q64 bios chip.

Special thanks to Lost_N_BIOS for your help.

CH341A programmer:

[Image: yjqgDTv.png]

PINs details:

[Image: hH2Ap6c.png]

[Image: juDxcVx.png]

[Image: AT2ZMUA.png]  [Image: 2wXHVDF.png]

1.8V Adapter:

[Image: vQU7dQM.png]

[Image: cwMs82I.png]

[Image: HNfIuW8.png]

PIN 1 on the BIOS chip:

[Image: NAW7f3Z.png]

[Image: 8jvCZv3.png]

[Image: MmQfDLC.png]

If you receive this error(s) with the CH341A programmer connected to bios chip:

[Image: TarZn3y.png]

[Image: jnZbfp0.png]

This error(s) is caused by the bad connection of the clip or by the wrong software version.

Try the following steps:

Exit form C341A software.
Disconnect ch341a programmer from USB.
Disconnect the test clip from the bios chip.

Connect the test clip to bios chip.
Connect ch341a programmer to USB.
Run C341A software.
Press detect button.


Please try another software version.


Download  here the CH341A tools (Thanks to Lost_N_BIOS)

Unzip the downloaded pack and install the ch341a drivers (run CH341PAR.EXE)

[Image: 51Jtc8o.png]

[Image: Ps8Bokr.png]

Remove CMOS battery from your motherboard.
Connect the test clip to bios chip.
Connect ch341a programmer to USB.
Run CH341A_c.exe from CH341A programm v1.29 folder.

[Image: Dl1TE8v.png]

[Image: qLhJGpF.png]

[Image: FYmMBWD.png]

Go to "Auto" and uncheck "Erase" and "Blank check" options:

[Image: p9Gq8OX.png]

Press "Read button" and wait until the process is finished:

[Image: BjCZrVo.png]

[Image: nHy3zmv.png]

[Image: eSmXRr4.png]

Now press "Verify" and wait until the process is finished:

[Image: wLRy40u.png]

[Image: tBSJfyZ.png]

[Image: 7rDPltF.png]

[Image: IPQM1Rq.png]

Attention, before continuing with the PART 3, please check the content of the backup file.

You can compare the backup file with the original bios file from manufacturer site, using one hex editor software.

The contents of the files is not the same but it is very similar.

Lost_N_BIOS Wrote:Run read, then verify, once it says "Chip/Buffer match" then that is verified, click save and then open that file in hex editor and make sure it's valid BIOS and not all FF's.

If it is all FF's, that's verified invalid blank and you need to use another software version or CHIP ID and try again until you get verified and valid backup).

Lost_N_BIOS Wrote:Then install driver in above package. Then open software of your choosing to try first, I already try newest version first. Hit detect and if it detects your chip by ID OK, then select that one. Sometimes you might need to choose less than full ID, or different than ID too, like BIOS ends in FV sometimes BV works better, but you'll figure that out later if it comes to that. Once you've done that, hit read and when it's done hit verify. If it verified good, then you hit save BIOS. Verify after reading it should tell you chip and buffer or memory match, then that is possibly a good verified file (not always). Open that file in hex editor and make sure it's not all FF"s. Then repeat that a time or two and compare those two verified files, if they're always good files and match then probably OK. Save this BIOS somewhere safe as backup. Make sure it opens properly and looks correct in any BIOS editing tools you are familiar with too, then you'll know it's OK.

Backup file examples (OK and wrong):

[Image: Rj5ZYBx.png]

[Image: x1ikzue.png]

[Image: tWdKoSS.png]

[Image: VtgJLRZ.png]


After checking and saving your backup press the "Erase" button and wait until the process is finished:

[Image: oinIArj.png]

[Image: Kg5DS2G.png]

[Image: GF5bPzC.png]

Now press the "Blank" button and wait until the process is finished:

[Image: SVdchpM.png]


If the next window appear, when you press the blank button:

[Image: YeFvBzb.png]

Lost_N_BIOS Wrote:Chip Main Memory Not Null = this means you erased (Should be all FF) and then ran blank check and it found not all FF's (Some other data still) so erase not complete. Also will say that if you do not erase, and just run blank check when you know there is data there.

Possible solution:

Please Re-Erase chip and check Blank again OR use another software version.

If it does not work, you can try this (You can use a heat shrink tube.):

[Image: x88C0fp.png]

[Image: tCUMTYu.png]

If the "Chip Main Memory are blank" message appear, you can continue with the next step. Press "Open" button and find your new bios file:

[Image: boa1aXe.png]

[Image: pLgRANd.png]

After the new bios file is opened press "Auto" button and wait until the process is finished:

[Image: A1STMIE.png]

[Image: 1ZviZbz.png]

[Image: fkoCh16.png]

[Image: YDP09ZS.png]

[Image: 6wctof8.png]

Thank u for that nice Tutorial u made.

I have an Asus S56CB Notebook. The Notebook will start but it just flickering some LEDs. So i thought its a BIOS Problem. Flashing by USB wont work. I Ordered a EEPROM Programmer and made a dump from the actual BIOS -> It worked. But, If I write the now BIOS that i download from Asus the Notebook wont do anything if i push the powerbutton. If I write back the dump i made -> it will power on but the LEDs are flickering. I think its the VGA Chip what broken. But why will it not turn on with the BIOS i downloaded from the web?

Do I need to modify the downloaded BIOS from ASUS that i can write it to the Chip?

best regards
Upload a copy of your BIOS dump and I will make BIOS for you to write with programmer, you can't just write BIOS from download because it's usually only a partial BIOS from Asus. Hopefully you verified it was a good valid dump before you wrote anything (ie made sure it was BIOS not simply failed dump all FF or 00)
(03-18-2019, 10:20 PM)Lost_N_BIOS Wrote: Upload a copy of your BIOS dump and I will make BIOS for you to write with programmer, you can't just write BIOS from download because it's usually only a partial BIOS from Asus.  Hopefully you verified it was a good valid dump before you wrote anything (ie made sure it was BIOS not simply failed dump all FF or 00)

I have an Asrock z77 Extreme 4.  While flashing via the motherboard it froze at Crashless Recovery for 20 or 30 mins.  I rebooted and it won't post.  I've bought a CH341A and a spare BIOS chip.  I've read my "old" chip and saved the info.  Can you please help me @Lost_N_BIOS I have the BIOS I would like to write onto the chip, I just don't know what "extra" info needs to be embedded into the BIOS file.

edit: Also if you can help how do I attach the BIOS so only you receive it and isn't posted for everyone to get on the forum?
Cyn - you'll have to upload to some file host and send me link via PM
help pls! My programmer just won't detect my chip. no matter what I do!

I have been trying to get this to work for a few days now, but I am coming-up short. Perhaps you could lend a hand? I am working with a Winbond 25Q16DVSIG. I cannot find this chip listed anywhere in the CH341a Programmer versions I have available.

Is there a newer version somewhere that has this chip? The skygz links are all dead that I can find. I've tried using the chips that are available, but detection keeps saying that it cannot find my chip. 

Anything that you could do to help point me in the correct direction would be greatly appreciated!
(11-19-2018, 07:27 AM) pid=\146665' Wrote:Hi, I have a Dell Inspiron 5748 that doesn't POST, no LEDs flashing or blinking and no error beeps, just fan and hard drive spinning up and it tries to read from DVD drive. I suspected that the laptop is bricked and failed BIOS update is the cause! I tried to recover using USB flash drive by holding the End key and connecting AC, BIOS recovery doesn't start!

I used a programmer to dump the BIOS, but I'm not sure how to repair BIOS file I've noticed that the dump I took doesn't contain a GBE region! 
I uploaded the DUMP as well as the extracted HDR and ROM file (extracted from the BIOS update downloaded from the Dell website) here. The archive contains the BIOS dump I took (BIOS.rom) as well as the extracted HDR and ROM file (3442a14).
Any assistance would be greatly appreciated!

Forum Jump:

Users browsing this thread: 4 Guest(s)