Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
You have to register before you can post on our site.



Latest Threads
[REQUEST] Lenovo G580 (5ECNxxWW) Whiteli...
Last Post: xX__mini__XxDoxie...
Today 04:14 PM
» Replies: 1723
» Views: 520365
[REQUEST] Lenovo B575E (HPETxxWW) Whitel...
Last Post: Yanis102
Today 01:23 PM
» Replies: 15
» Views: 9065
[Request] HP Elitedesk 800 G2 BIOS Unloc...
Last Post: Darkuwu
Today 11:40 AM
» Replies: 0
» Views: 0
Last Post: Angelus
Today 11:31 AM
» Replies: 0
» Views: 0
CBROM with CPU Microcode Larger than 2Ki...
Last Post: bbuchholtz
Today 07:41 AM
» Replies: 2
» Views: 0
[REQUEST] Unlocking Zotac Magnus ER51070...
Last Post: John_Smith
Today 02:57 AM
» Replies: 0
» Views: 0
(Request) Unlock Dell XPS 8700 Bios
Last Post: whitezombie455
Yesterday 01:32 PM
» Replies: 23
» Views: 6547
[REQUEST] Lenovo G510 (79CNxxWW) Whiteli...
Last Post: Dudu2002
Yesterday 12:28 PM
» Replies: 648
» Views: 158070
[REQUEST] Whitelist Removal Lenovo L440
Last Post: Dudu2002
Yesterday 12:27 PM
» Replies: 157
» Views: 43522
[REQUEST] Acer Nitro 5 AN517-51 BIOS Unl...
Last Post: geberal9
Yesterday 06:59 AM
» Replies: 20
» Views: 7171
Hi, I would like to modify this bios.
Last Post: Kang Jinsu
Yesterday 01:00 AM
» Replies: 1
» Views: 0
Request BIOS unlock clevo NH55ADY AMD b4...
Last Post: dragon2224
12-01-2023 04:17 PM
» Replies: 0
» Views: 0
[REQUEST] Lenovo Y50-70 (9ECNxxWW) White...
Last Post: Dudu2002
12-01-2023 04:08 PM
» Replies: 1997
» Views: 394338
unlock bios asus tuf dash f15 fx516pr
Last Post: bogdan2390
12-01-2023 02:33 PM
» Replies: 2
» Views: 0
[REQUEST] Acer Nitro 5 AN515-44 BIOS Unl...
Last Post: Dudu2002
12-01-2023 05:19 AM
» Replies: 3
» Views: 0
compaq CQ61 475SQ
Last Post: Bogdan_Bughy
12-01-2023 03:42 AM
» Replies: 4
» Views: 0
[REQUEST] Lenovo ThinkPad Edge E320 (8NE...
Last Post: hengliangshen
11-30-2023 04:11 PM
» Replies: 94
» Views: 25238
[REQUEST] HP 15-ac022ur Whitelist remova...
Last Post: sign
11-30-2023 12:37 PM
» Replies: 0
» Views: 0
[REQUEST] Lenovo G710 BIOS Whitelist Rem...
Last Post: Dudu2002
11-30-2023 12:19 PM
» Replies: 576
» Views: 122407
m72e Lenovo Supported CPU upgrade microc...
Last Post: DeathBringer
11-30-2023 10:28 AM
» Replies: 4
» Views: 4103

[REQUEST] Veriton M2610 - Ivy Bridge Support
Hey, Guys.
Is it possible to add Ivy Bridge support to this mobo without replacing the bios chip with 8MB one? I read somewhere that there is some hope with hardware programmer. I've got one.



Board name
ACER H61H2-AM v1.1

25Q32BVSIG - (4 MB)

I have attached compressed RAR file with various bios files in it.

Here's the explanation of the folders

Downloaded Unofficial Bioses - This folder contains some random bios files i downloaded from the internet.

ACER H61H2-AM CORE 3 V1.1 MASTER W25Q32BVSIG 27.3.2015.BIN - It has "CORE 3" in the filename so i assumed it might contain support for Ivy Bridge. I flashed it with CH341 and it works with Sandy cpus, sadly it still doesn't work with Ivy Bridge cpus.

My Backup with AFUDOS - My original backup with AFUDOS /o

My Backup with CH341 - My backups with CH341

Official Acer Bios - Official M2610 bios on the ACER site but AFUDOS says "Rom size doesn't match"

This is probably the reason according to ACER

Quote:BIOS versions are not interchangeable. If your BIOS version is P01.xx, you can only update to other BIOS versions for that system that are P01.xx. If you try to use version P02.xx or P03.xx an error will be given stating that the BIOS that is trying to be installed is not the correct size.

Any help is appreciated.  Thanks!

Attached Files
.rar   ACER H61H2-AM v1.1.rar (Size: 10.54 MB / Downloads: 105)
Try to flash this mod by hardware programmer.
(03-15-2020, 02:42 PM)DeathBringer Wrote: Try to flash this mod by hardware programmer.

Hi, DeathBringer. Thanks for taking a time to look at this!

I flashed the file with hw programmer. Verified it. Installed an i3-3220.

It didn't post (nothing on monitor) but CPU fan runs. Also it didn't make the 4 beep sound like the original bios + 3nd gen cpu.

I cleaned the CMOS. Same result. I installed back the 2nd gen cpu. Still same result.

Let me know if you need any more info.
Try to flash this dump.
(03-16-2020, 01:58 AM)DeathBringer Wrote: Try to flash this dump.

Wow. This one posts with the i3-3220. Nice!

Good news
1. Sound, LAN, BIOS (editing values, saving, etc), Legacy cards like GTX 460, GTX 730 works. I am not sure what more should one usually check when testing modded bioses. I'll certainly do some stress tests if we arrive at final modded bios.

Bad news
1. Modern cards doesn't work.

EVGA GTX 1060 6GB SC - Nothing on monitor
MSI 1050 Ti 6GB - Stuck on first BIOS screen (wallpaper, F1, DEL)

2. Sensor from Windows seems to be very wrong (I hope lol). But values looked normal from BIOS. Tested with different PSUs.

3.3V - 1.1V
5V - 7.4V
12 - 19.1V

3. I've disabled EIST and set Ultimate Performance on Power Settings. CPU speed still kept going back and forth between 1.6GHz & 3.3GHz. Maybe need to disable states? I didn't see C1E or other states settings in the BIOS. Is it possible to enable them?

Great work! DeathBringer.

In the meanwhile, I'll flash the orig bios to check if any of issues above exists.
Now try to update BIOS to offical P02-A2 by AFUDOS.
(03-16-2020, 11:46 PM)DeathBringer Wrote: Now try to update BIOS to offical P02-A2 by AFUDOS.

Ok, I'll try that now.

Btw here is some info i've gathered in last few hours

I found another random bios from some china site and flashed it instead of my original backup.

It boots. But product name says: Veriton M290 (P01-B0)

3rd gen didn't work.

Modern cards works.

Wrong power rails value issue still exists.

Attached Files
.rar   H61H2-AM V1.1.rar (Size: 1.86 MB / Downloads: 66)
My apologies for replying late but DeathBringer, you are INSANE! Big Grin

I've been testing it for last few days and everything seems to be working fine!

I had to use /X switch to bypass the ROM ID and unplug the BIOS_WP jumper to flash P02-A2 with AFUDOS.

i3-3220 Cores, Threads - Pass
Modern GPUs - Pass
16GB RAM - Pass
Bios features, Resetting, Saving, etc - Pass
Sounds, LAN, USB Ports, etc- Pass
Some stress on GPU and CPU - Pass
Left Windows running for 12 hours - Pass

Thank you very much! DeathBringer

I've attached a working bios dump if anyone wants to try. There shouldn't be an issue since i have tested it by flashing original bios then the bios dump.

Also, the very wrong (too high or low) power rail voltages on hardware monitoring tools issue still persists in original bios. So it's not a modded bios issue. I am not sure if it's my mobo's sensor that is broken or BIOS bug or AIDA64/HWInfo bug. I checked rails with multimeter and voltages looked fine. So, whatever.

I'll certainly post this bios in Confirmed CPU Support Upgrades when i am done testing it with Ivy i5 or i7 processor (currently trying to borrow one) and identifying models of other desktop pcs that uses this motherboard. So someone looking to upgrade their CPU to 3rd Gen CPU can easily find the thread by searching their desktop model name on Google. I think there should be few more Founder and ACER branded desktops.

Best Regards

Attached Files
.rar   ACER_H61H2-AM_V1.1-IvyComplete.rar (Size: 2.82 MB / Downloads: 342)
Nice news!
How to use the / X switch to bypass the ROM ID and unplug BIOS_ WP jumper, flash p02-a2 with afudos?

Forum Jump:

Users browsing this thread: 4 Guest(s)