Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Acer Aspire M5100 R01-A3
Is this thread dead?

i was needing an update to support my phenom 965BE CPU.
I am also running windows 7 64bit so award flash doesnt work for me

Can anyone help out?

(btw not really clued up on bois updates so sorry in advance ^^)
find
quote
(04-23-2012, 11:29 AM)Kilaq Wrote: Is this thread dead?

I hope not!

I have an US M1100 AMD RS690-SB600-6A669FK8C-0, and I used the M5100 R02-B1 bios from euro site to update my BIOS to see if that would correct some issues I was having with using more than 2GB of ram, and it hosed up my system. Unfortunately, I didn't make a backup of the original BIOS, and can't seem to find the original anywhere for download. Does anyone have the original R01-A1 BIOS image available?

Thanks in advance!!
find
quote
Hi people, i thought i'd post here as to my understanding the M1100/M3100/M5100 all have the same mobo, i've been looking for a modded bios for the past week and a half (bricked my bios using winflash to flash a modded bios a week ago) i just recovered using a hotflash using a mates pc today Big Grin using the R01-A1 XP VISTA Bios from Acer on this link
http://support.acer-euro.com/drivers/des...m3100.html

#winning!

lol anyhow i don't wanna risk flashing another modded bios on my M1100 without knowing it should work, if anyone would mod that bios for me or provide a working version for my pc (basic details listed below)

PC DETAILS: (Reported by CPU-Z etc)
Acer Aspire M110 (written on case panel)
Motherboard: ACER F690GVM (CPU-Z)
CPU: AMD Athlon 64 x2 Dual Core Processor 4000+ (Windows 7 System Properties)
CHIPSET: ATI RS690/RS690M (CPU-Z)

BIOS Details:
Version: R01-A1 (as stated above its the one from this link http://support.acer-euro.com/drivers/des...m3100.html)
Winflash Reports this?: RS690-SB600-6A669FK8C-00
BRAND: Pheonix Technologies, LTD(CPU-Z)
Verzion from CPU-Z: 6.00PG

Anything else you need just ask Smile
hope someone can point me to something that works, winflash says some of the ones i downloaded were incorrect or something like that

Thanks in advance

-Ben
find
quote
So are any of the download links for the amd version of this mobo? Its dumb how this pc feels like it has so much potential but is bottle necked like crazy, also is it true that some of the dual cores can have potential to be unlocked to quad core? i feel like ive read that somewhere.
find
quote
The motherboard used in the m1100,m3100,m5100 is the rs690m03-8ekrfs2h, its made by foxconn and has a similar layout to their 740g boards(which is basically the 690 but with a better southbridge)

Its appears that this series of motherboard has two different revisions, problem is Foxconn probably put Rev2 boards in the M3100 and M5100 but not the M1100 or their is the distinct possibility that there are rev1 or rev2 boards in all 3 which is causing the bricks and/or confusion. That is why I loath different rev boards as all it does is cause confusion for tech support and the customer. OEM's get away with it as they don't expect customers to open their computers for the most part.

the R02 bios is probably for rev2 boards and Acer Europe posted bios updates not taking rev1 into account(that page is so horribly organized btw)

the R01 is probably for rev1

A quick look in Award Bios Editor 1.0 gives me no issues at all for open R01, but R02 it won't let me edit, just view it

i tried to backup the bios originally but the 512mb file wouldnt fit on all on one floppy with the along new bios on there taking into account MS bootable startup files so i tried my luck and didnt back the original up which was a dumb mistake.

Also someone earlier posted an R01 file after R02 failed for me using the floppy disk recovery mode trick but it still just sticks on it sounding like the floppy is doing something at startup, then the green light just stays on and makes no moving noise. (It was doing this because the autoexec.bat strings were incorrect)

If you want to get into floppy recovery mode with this mobo u have to take the cmos battery out for 5 min and do a jumper reset on the board, sometimes it won't let you go into that mode, especially after you have tried different .bins to flash.

The funny thing in all this for me is I was troubleshooting this board for a customer and it turns out the common problem in this board is the cmos battery needs to be replaced if it wont post. I fixed that problem and I was trying to update the bios so I could run a Athlon 2650e 15w cpu and have a cpu-string for it. Man I should have just stuck with AMD Unknown Processor and I would have a working board as the cpu was working fine in windows, just wanted power control settings and needed the vendor_id for that to recognize in Win7.

The main thing we need going forward is original bios dumps of both rev1 and rev2 as there is no original release bios file for these boards anywhere online.I have a feeling this problem will continue for a while with Windows 8 supporting this board in most likelyhood as the Athlon X2 is still viable in today's PC world as the e-350 fusion boards from AMD use the K8 architecture cpu's like the Athlon64 X2 but shrunk to 32nm from 65nm for power savings.

EDIT- Just to let everyone know what the real problem in all this is... Acer uses it own command strings that have to be strictly followed in order to flash the board after it has been bricked

some sites give a string which will probably work for non oem boards. my guess is people are following the guide over at biosman which he should have included that some boards may only
work with a specific string and not the universal one he suggested which was....

AWARDFLASH.EXE BIOS.BIN /py/sn/f/cc/r

when for this board its

AWDFLASH.EXE BIOS.BIN /PY/SN/WB/CC/CD

you can usually figure out the award string for an oem board by looking at aflash.bat file that comes bundled with the bios download which is what I did, such as the european one. The problem is that you need both the aflash.bat file along with a autoexec.bat file that both say the exact same thing on the floppy. Basically you create the autoexec.bat file by opening notepad and saving it as non txt file as autoexec.bat

The autoexec.bat will usually disappear on the floppy once you move it to there, but trust me its there, just hidden.

Also you can use a external usb floppy drive like a did on this board, it will also work for a standard floppy drive, but make sure you know it reliable as they go out pretty easily. You will know the flash is working after it spins for a solid 3-4 minutes and then you can reboot manually.

The bios I used for the Acer M1100 was R02-B1 as R01-A1 bricked my board originally, giving into my hypothesis that there are 2 revs of this board and Acer isn't letting people know this or Acer US realized this and won't release an updated bios with Europe will . Also people should not flash these series of M computers until we find out if there are in fact 2 revs of this board. I am now interested in injecting AGESA code into Award BIO's but it seems easier to do with MMTool for AMI. If anyone knows how to do this shoot me a pm. I can't find a good Windows based program for editing Award bin files.

hope this helps folks in the future, love what you guys are doing around here
find
quote
Howdy,
This thread has been very interesting as I am also the owner of an Acer M5100-5201A.
My apology to TheWiz if this is going to feel or sound redundant!! The thread is very confusing as to who is having success with which bios mod version.
Background:
My Acer was bought new here in the USA,
The original BIOS was R01-A0(from memory)
Shortly after buying the pc I updated the BIOS to R01-A1(this is also the version it is at currently)
My only reason for updating the BIOS was to get the Hardware Virtualization(HAV) aka AMD-V to function. Since day-one, this Acer M5100 has been used as a testing box with Virtualbox installed on a CentOS server platform.
All the reading and testing shows that the AMD 4400 x2 chipset is capable of HAV(AMD-V) but my Virtualbox software nor HyperPC will recognize the capability.

Okay, so to the point! AMD claims on their site that the AMD-V is always enabled and will work when needed(I am not fully onboard to this explanation).
The BIOS does NOT have any settings available for HET, VT, Virtaulization etc..
My fear and reason for posting is that there is some difference between the Modded BIOSes because the Euro Acer version appears to work on R02-### based mods and the USA version appears to be safe with R01-### based mods.
So if possible, I would like to know from TheWiz if the M5100A3.bin was built from an R01-### or R02-### bios??
Thanks for taking the time to help,
Hogger
find
quote
Howdy,
I think I found the way to ID which BIOS will work with which motherboard.

We have 2 different ID's the following one appears to be an "revision 2":

Motherboard Properties
Motherboard ID 02/23/2008-RS690-SB600-6A669FKZC-00
Motherboard Name Acer F690GVM

The following one appears to be "revision 1":

Motherboard Properties
Motherboard ID 10/10/2007-RS690-SB600-6A669FK8C-00
Motherboard Name Acer F690GVM

The bolded string is where the magic is. The R02-## bios work with FKZC
and the R01-xx work with FK8C. My board is the FK8C, these appear to be the earlier release.
IMHO,
Hogger
find
quote
I have an Acer Aspire AM1100-B1300A which is basically the same thing as the M5100. I will add some specs from it to the bottom of this post.

This computer has an AMD CPU. From reading on this thread it seems that some models have an Intel and not an AMD and that this causes all of the bricks.

There seems to be a lot of different bios files for this motherboard. I see some R01-XX and R02-XX.

My computer has the R01-A3 Bios. Attached is my dump of this bios made with winflash. Can someone please mod it? It should work for others also.

Quote:Northbridge ATI RS690/RS690M rev. 00
Southbridge ATI SB600 rev. 00
Mainboard Model F690GVM (0x000001CF - 0x004FD90D)

DMI BIOS
vendor Phoenix Technologies, LTD
version 6.00 PG
date 10/10/2007
ROM size 512 KB

DMI System Information
manufacturer Acer
product Aspire M1100
version R01-A3
serial PTS890X07974906A532702
UUID {53251C00-810E-0720-1204-094339000000}


Attached Files
.bin   awdbios.bin (Size: 512 KB / Downloads: 68)
find
quote
Hi payterx,

Please try the attached image and let us know if it works. I will open a new thread for your model number if it works well.

http://www.bios-mods.com/BIOS/Award/Acer...B1300A.zip

TheWiz
www find
quote
(04-28-2013, 06:57 PM)TheWiz Wrote: Hi payterx,

Please try the attached image and let us know if it works. I will open a new thread for your model number if it works well.

http://www.bios-mods.com/BIOS/Award/Acer...B1300A.zip

TheWiz

It worked!

Now I just have to figure out how to overclock.

And to let other people that want to flash this one know, I used the awdflash and .bat file from the official bios update from the European site. Here's a zip with the exact files I used, the "AM.BIN" is the bios you uploaded just renamed.


Attached Files
.zip   Desktop.zip (Size: 371.96 KB / Downloads: 90)
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in