Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bricked vn7-791g and fd file too big
Hello, I recently bought a m.2 ssd for my laptop acer vn7-791g. After plugging it, the drive was not detected neither in linux or in the bios.

I decided to update the bios,
1. boot on windows,
2. downloaded the 1.14 bios from :;-;Aspire%20VN7-791G.
3. execute the executable, the computer reboot then bios update screen appear, then it reboot again but
Got stuck on Acer Logo at boot.

Tried multiple things, reset button, remove cmos battery, fn+esc (usb flash) with the extracted fd file from the download renamed PoseidonX64.fd. Nothing worked, I got stuck on a black screen(with back light) without being able to acces the bios.

So I bought a CH341a spi flasher, and I just read my bios and I noticed that the rom I was trying to install was too big; it was 9056760 bytes but it is supposed to be 8388608 bytes. (8MB)

Am I supposed to trim it down? if so how ?

Anyway, I am looking to
1. make my laptop boot again.
2. make m.2 ssd recognised
3. maybe have the advance bios menu

The bios is made by InsydeH20.

Thanks in advance for your help.
Bios file extracted from TMBI114s.fd.

You also could refer to below link to get dump bios.

Good luck!

My page>>>click
My bios unlock >>> click
donate me >>>click


Forum Jump:

Users browsing this thread: 2 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in