Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
You have to register before you can post on our site.



Latest Threads
[REQUEST] Lenovo T440(S) (GJETxxWW) Whit...
Last Post: Dudu2002
Today 06:59 AM
» Replies: 484
» Views: 144697
[Unlocked] Alienware M14x bios unlocking...
Last Post: procious_saathvik
Today 05:16 AM
» Replies: 13
» Views: 17725
[REQUEST] Lenove Yoga 3 14 80JH Whitelis...
Last Post: Dudu2002
Today 03:03 AM
» Replies: 31
» Views: 9206
[REQUEST] Lenovo Y50-70 (9ECNxxWW) White...
Last Post: pastod
Yesterday 10:14 PM
» Replies: 1990
» Views: 394338
HP 3500 pro MT bios Recovery
Last Post: massatt212
Yesterday 10:04 PM
» Replies: 0
» Views: 0
Last Post: TUDOG
Yesterday 07:00 PM
» Replies: 0
» Views: 0
[REQUEST] Lenovo Thinkpad T430 (G1ETxxWW...
Last Post: Dudu2002
Yesterday 03:05 PM
» Replies: 697
» Views: 300857
Some Bios Strings Exceeds The Maximum Le...
Last Post: adam7336
Yesterday 09:45 AM
» Replies: 4
» Views: 1072
[NEEDINFO] Variable + Var store in IFR e...
Last Post: mixmid
Yesterday 07:46 AM
» Replies: 4
» Views: 0
[REQUEST] EVGA Z370 FTW disable spread s...
Last Post: Neutro
Yesterday 05:38 AM
» Replies: 0
» Views: 0
A315-59 Bios Unlock
Last Post: Dudu2002
Yesterday 02:19 AM
» Replies: 1
» Views: 0
[REQUEST] Lenovo ThinkPad Edge E531 (HEE...
Last Post: Dudu2002
05-26-2023 04:43 PM
» Replies: 107
» Views: 19527
Request: Asus GL503VD AMI BIOS unlock
Last Post: Tkaczyk24
05-26-2023 03:18 PM
» Replies: 37
» Views: 9860
[REQUEST] Lenovo B470 / V470 / V470c (43...
Last Post: GarbageRaccoon
05-26-2023 02:40 PM
» Replies: 35
» Views: 10937
[REQUEST] Lenovo IdeaPad L340 (BGCNxxWW)...
Last Post: Mke_2023
05-26-2023 10:57 AM
» Replies: 43
» Views: 13001
Last Post: Dudu2002
05-26-2023 02:53 AM
» Replies: 1
» Views: 0
[Request] Asus H110M-R Mainboard - Xeon ...
Last Post: DeathBringer
05-26-2023 02:45 AM
» Replies: 9
» Views: 0
[REQUEST]Acer 4720z bios unlock
Last Post: Arktel1990s
05-25-2023 02:49 PM
» Replies: 2
» Views: 2413
Last Post: GarbageRaccoon
05-25-2023 02:34 PM
» Replies: 0
» Views: 0
[REQUEST] Lenovo Ideapad 3 15IIL05 White...
Last Post: Dudu2002
05-25-2023 12:49 PM
» Replies: 1
» Views: 0

IGEL H710C ThinClient - not recognizing PCIe NIC. Possible BIOS mod?
Great minds of bios-mods forum,
I come to you for help. This is how my problem looks :
I have few  IGEL H710C ThinClients and decided to make some good use of them - make a pfsense router. Just play with it and learn new things about networking etc. I also have few Intel PRO/1000 ET NICs ( 0HM9JY ).  I've installed pfsense, plugged in the NIC... pfsense only sees crappy onboard Realtek RTL18111D controller... Checked BIOS - no options for network controllers ( except for onboard/PCIe ROM ). During booting, BIOS doesn't see Intel's NIC... also, quite often, board won't boot at all with NIC installed - black screen, beeps once...and that's all. I've tried to physically disable Realtek controller ( isolating its PCIe bus by pulling down one of it's controll pins). It disapears from the system but that doesn't change anything. 
In next step, I installed Windows 7 embedded on the machine. No luck. But once i got the system running with Intel's NIC, I installed it's drivers ( at this point only Realtek was in the device manager ) ..and voila! I got that NIC recognized and seen in device manager ! But.. it said something about not having enough resources to run properly ( it was disabled ). Theeen.. i disabled Realtek controller from the device manager ...and Intel's NIC was up an running! Ofcourse after rebooot, same storry - system wont boot ( black screen, one beep).
So i thought i can modify BIOS somehow...On boot screen it shows Poenix-Award  .. In RW Anything i see : Vendor String1 - "Phoenix Technologies, LTD", BIOS Version String2 - "6.00 PG". I used Phoenix tool to read the BIOS - got 1024kb .ROM file. Used external flash programmer and flashroom to read it - got same size .bin file... BUT.. i cant open those files in any BIOS mod software i could find...
Is there anything that can be done? The easiest way would be getting different NIC to try, but those are quite pricy ... Oh, and the system works if i plug in a Wireless PCIe card.. just that Intel's NIC isn't working.. 
Any help and suggestions are greatly apreciated !

Attached .rom file from Phoenix tool...

Attached Files
.rom   PhoenixTechnologies,LTD-6.00PG.rom (Size: 1 MB / Downloads: 2)
I found out that this is Award BIOS... So i was able to read it again with Award flsh reader and open it in Award BIOS Editor v1.0 but... I don't see anything obvious there noob like me can change.. IRQ table is empty..

Attached Files
.bin   awdbios.bin (Size: 1 MB / Downloads: 2)
Quote:doesn't see Intel's NIC... also, quite often, board won't boot at all with NIC installed
If it's happends when you not change any options, may be bad contact of card in the pcie slot ?
Resources is mean pcie lane x4 link not free ?
That was the first thing I checked - all connections ( continuity ) swapped cards, removed riser board, checked all voltages, changed mainboards etc...
The thing with not booting frm time to time has something to do with internal flash of the NIC - Intel provides a flash configuration tool for changing preboot options - every time I change it to defaults on another system ( where NIC is working without issues ), ThinClient is booting ..
I might try to compile coreboot and try it.. but last time i tried that, I wasn't able to compile coreboot at all for some strange reasons .. Oh well.. Learning time again ...

Forum Jump:

Users browsing this thread: 1 Guest(s)