Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MCP61PM-GM - Mod and Microcode Help
#1
Hi. I have a MCP61PM-GM (eMachines ET1331) and need some help modding my bios. I already tried modding with AMIBCP and MMTOOL, (Unlock features and add CPU microcodes) but the board dosen't boot each time I edit the bios. I don't know what i'm doing wrong. I get no errors while editing.

I have a eeprom programmer and a backup of my chip before starting any mods.

I will include some files

P01-A2L.ROM - Latest untouched bios availiable for this board
AMD AM2 MicroCode - Folder with some AMD AM2 Microcodes

Thank you.
find
quote
#2
What AMIBCP and MMTool were you using, and what did you change?

I only see Quick Boot, Quiet Boot as possible things to enable (Set Access to User)
Smart Fan, check the box, that may or may not work depends on your boards hardware (And this may cause non boot possibly if hardware missing)
If you checked the Smart Fan box, did you also test a mod BIOS without doing that, but making the two above changes alone too?

Are you programming in the modified BIOS? If not, try that instead of flashing.

In your microcode package, one is not microcode (#15=all 00's/padding) and only 7 of them are latest versions, which are the ones already up to date (FYI)

Here is three mod BIOS, both with updated microcodes, and one with AMIBCP changes as mentioned above (1 with all I mentioned, 1 without smart fan change, in case that causes failure) You may need to rename them to shorter names if flashing, if using programmer should be no problem with long name.
[Image: ovNGToQ.png]

http://www.filedropper.com/mcp61pm-gm-modx3
find
quote
#3
Thanks for your response

I have good news. I flashed "P01-A2L-ucode-QuickQuiet-Smartfan.rom" and it worked fine. Maybe it's the version of AMIBCP i was using? I was only enabling those stuff from Access to User and checking the Smart Fan box.

I'm using AMIBCP3.13 and MMTOOL 3.22.

It's possible to add microcode for QuadCore cpus? Like 00100FA0 00100F43?

--------------EDIT------------------

Switched to MMTOOL3.26 and now I added microcode for QuadCore, It's working (boots fine) but needs testing with a QuadCore CPU.

[Image: NlqJgJu.png]

Bonus tip: This board works with 8GB of Ram, instead of the 4GB advertised.


Attached Files
.rar   P01-A2L_MOD.rar (Size: 487.6 KB / Downloads: 18)
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in