Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[REQUEST] Lenovo G505S (83CNxxWW) Whitelist Removal
#11
(01-07-2014, 10:54 PM)sovem Wrote: Try flash from PURE DOS with USB-bootable, please.

Same Error.

The only way i can get this laptop to boot to anything other than the internal HDD is by switching from UEFI only mode to UEFI+Legacy
Disabling Secure Boot didn't make a difference
There is an option to allow USB Boot even with UEFI only, but as far as I can tell it hasn't made a difference.
I have tried to trick the machine to (re)boot to the usb stick in UEFI only mode via advanced restart on Win 8.1 but it just gives me an error saying there is no boot device present.
It seems to want the USB stick to have a UEFI Operating System on it.
its like its looking for the EFI partition.
I am currently trying to find a way to fake an efi partition and/or make a UEFI bootable dos disk that this laptop will accept.

Sorry for the wall of semi-useless information, i've been running on caffeine and ramen for the past 30 some hours.

The only thing i can think of (not knowing too much about bios's at all) is the issue is due to the fact it is in UEFI+Legacy mode when i attempt a flash and not "Pure UEFI Support" as the lenovo bios describes UEFI only mode as.
then again that may be totally unrelated. i wouldn't know; my area of expertise is computer networking.
(funny how this all started because of a network card of all things)

thanks for sticking with me thus far
-Xerise
find
quote
#12
Try this one: Lenovo_G505s_83CN12WW_BACK_NWL_Xerise_win
http://rghost.net/51484027
Update from windows, please post results.

From Hanoi, Vietnam
find
quote
#13
at first it gave me an error saying there was not a rom file in the directory so i pointed it to the file via platform.ini
and now it gives me the
"Error;
It only supports to flash to secure BIOS on current platform.
The image to be updated is not a secure BIOS."

if it is of any importance when i was trying this earlier with a different platform.ini i was getting an "Error. Load file: File may not have EC rom!"

thanks for the prompt reply.
-Xerise

Edit: Would it be better if i were to update to the official v2.some bios from lenovo so you have both the rom and bin files from the official .fd file to change?
just an idea.
find
quote
#14
OK. Try update official 83cn35ww bios, then backup with TESTBACK.EXE please.

From Hanoi, Vietnam
find
quote
#15
(01-08-2014, 06:59 AM)sovem Wrote: OK. Try update official 83cn35ww bios, then backup with TESTBACK.EXE please.
Ok, result.rar is attached.

.rar   result.rar (Size: 1.96 MB / Downloads: 22)
find
quote
#16
Try this: Lenovo_G505s_83CN35WW_NWL
http://rghost.net/51487690
Please post results.

From Hanoi, Vietnam
find
quote
#17
Gave an Error on first attempt saying that BIOS is the same as image to be Flashed
so i changed line 379 and line 403 to 0's to disable the compares.
The windows part of the wizard ran fine then.
-but-

InsydeH2O - Secure Flash
Error : Invalid firmware image!!!

Please press any key to reset system......

So close yet so far....
Im going to see if the official update lets me boot to usb from UEFI only.
if you can think of anything or need info let me know.
and thanks a ton for spending your time helping a total stranger with a problem that you don't even get paid to help them for.
you are honestly one of the very few truly awesome "guru's" on the internet
-Xerise

EDIT: No dice, still the same weird issue with the UEFI usb boot.
I'm going to have to teach myself about all this bios modding so I can see what makes this thing tick.
find
quote
#18
Hi Xerise,

I have the same model of laptop and was delighted once I saw that Lenovo had released a BIOS update (83cn35ww.exe) as I thought that this would at last allow us to remove the whitelist and flash the BIOS using the included flashing tool.

I spent quite some time learning how to edit and recompile the BIOS file and (I think) I managed to do this successfully. I chose to replace one of the approved device IDs in the whitelist with the one from the card I want to use, rather than completely bypassing the whitelist.

I then tried to flash the modded BIOS and encountered exactly the same errors that you list above. I could get the Windows tool to reboot into "DOS" and it failed at this point with the same error about "Invalid Firmware Image". I also tried some of the pure DOS flashing tools and received various error messages dependant on the version of the tool used.

I'm still unable to flash the modded BIOS and so would like to hear if you did eventually manage to get this to work or have made any further progress.

Many thanks, Mick
find
quote
#19
Shocked 
What do I need to provide to get whitelist removal?
Link to Lenovo BIOS: http://download.lenovo.com/consumer/mobi...(3.00).exe










Lenovo G505s AMD 5750M 2.5GHz with 3.5 Turbo Boost 16GB of RAM AMD8650GM+8670GM Dual Graphics
find
quote
#20
(11-01-2014, 11:22 AM)bmcsky96 Wrote: What do I need to provide to get whitelist removal?
Link to Lenovo BIOS: http://download.lenovo.com/consumer/mobi...(3.00).exe

Hi freind,
use this tool run It as Admin and upload here th result file :

http://rghost.net/58219938

Let me knon
Regards








Lenovo G505s AMD 5750M 2.5GHz with 3.5 Turbo Boost 16GB of RAM AMD8650GM+8670GM Dual Graphics

Your Brain . . . . It's the best tool U can use ! Wink
Don't FLASH the Bios Mod if You get a Size Alert, You risk a Brick !!!
Donate to me for my work, click here BDM
find
quote


Forum Jump:


Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in