Forum RSS Feed Follow @ Twitter Follow On Facebook

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
You have to register before you can post on our site.



Latest Threads
[Request] HP TX2-1000 Series - Unlock hi...
Last Post: Vivaldi042
Today 12:05 PM
» Replies: 11
» Views: 0
Intel DG35EC & Xeon L5410
Last Post: Vivaldi042
Today 12:03 PM
» Replies: 16
» Views: 0
HP ProOne 400 G4 23.8-inch ADD SUPPORTED...
Last Post: Vivaldi042
Today 12:02 PM
» Replies: 4
» Views: 0
[REQUEST] Acer Aspire 4349, 5349 & 5749(...
Last Post: Vivaldi042
Today 12:01 PM
» Replies: 275
» Views: 94986
Core 2 Mobile BSEL mod
Last Post: Vivaldi042
Today 12:00 PM
» Replies: 1
» Views: 0
[REQUEST] Lenovo ideapad 320-17IKB (type...
Last Post: Vivaldi042
Today 11:58 AM
» Replies: 3
» Views: 0
[REQUEST] Lenovo IdeaPad Gaming 3 15IMH0...
Last Post: Vivaldi042
Today 11:56 AM
» Replies: 72
» Views: 12320
[Question] Acer Aspire R7 572G Haswell t...
Last Post: Vivaldi042
Today 11:55 AM
» Replies: 4
» Views: 0
Forgotten tools from HP
Last Post: Vivaldi042
Today 11:54 AM
» Replies: 4
» Views: 0
Add NVM Express support to H110M Pro VH ...
Last Post: Vivaldi042
Today 11:53 AM
» Replies: 6
» Views: 0
[Accepting Requests] HP Probook 4530s WL...
Last Post: Vivaldi042
Today 11:51 AM
» Replies: 2
» Views: 0
Last Post: Vivaldi042
Today 11:50 AM
» Replies: 1
» Views: 0
[REQUEST] helios 500 ph517-61 BIOS Unloc...
Last Post: Vivaldi042
Today 11:49 AM
» Replies: 4
» Views: 0
[Request] Lenovo T540p (GMETxxWW) BIOS U...
Last Post: Vivaldi042
Today 11:48 AM
» Replies: 57
» Views: 28018
Lenovo G50-70 bios recovery
Last Post: Vivaldi042
Today 11:46 AM
» Replies: 6
» Views: 7189
uCode update for Fujitsu-Siemens Amilo D...
Last Post: Vivaldi042
Today 11:45 AM
» Replies: 14
» Views: 0
[REQUEST] Lenovo IdeaPad P400, P500, Z40...
Last Post: Vivaldi042
Today 11:44 AM
» Replies: 762
» Views: 151572
[REQUEST[ Acer Nitro 5 AN515-46 BIOS Unl...
Last Post: Vivaldi042
Today 11:42 AM
» Replies: 8
» Views: 0
[REQUEST] Lenovo G580 (5ECNxxWW) Whiteli...
Last Post: Vivaldi042
Today 11:41 AM
» Replies: 1726
» Views: 520365
Lenovo T480 Bios Mod
Last Post: Vivaldi042
Today 11:38 AM
» Replies: 5
» Views: 0

[WORKING] Asus P8Z77-V: NVMe BOOT Support w. Download
The link to download the BIOS does not work for me.
I am Japanese and not good at using English.
However, I really want to thank you and write it.
I downloaded modbios from another site and tried OS booting from NVMe.
However, even if the black 16x slot was set to x4 mode in the bios setting, the speed was only about 400MB / s depending on whether the OS failed to boot or started up in x1 mode.
I desperately searched for straw and finally arrived at this thread and succeeded in starting in x4 mode! !! !! !! !!
It operates at about 1500MB / s.
Thanks to brownie12 for creating the modbios at the beginning, samiby for creating the mod with the right fixes, and everyone in this thread.
I'm really thankful to you.

(By the time I got here, I bought 3 PCIe-NVMe conversion cards and repeated a clean OS installation more than 10 times.)

I'm really happy now! !! !! !! !! !! !! 1
Hello, Thank you for this post!

Through the long research to see if it was possible to even get an NVMe drive to work I found this post. Thank you for the guide brownie12 and for the modded BIOS samiby. The modded BIOS worked perfectly in the second PCIe slot (White) which gives Gen 3.0 PCIe, unlike the bottom black one. This was done on a P8Z77-V with a Startech adapter and Barracuda Q5 2TB m.2 NVMe SSD.

Please take note of what I have written bellow if you have troubles, some of it is really important! I hope it helps others even if it isn't for this board but this is just from my experience:

If you just want storage you can use the drive without using the modded BIOS however if you want to use it as a system drive like everyone here then follow the guide! The BIOS and Windows can communicate with the drive but the BIOS wont let you boot from it.

If your wanting the modded BIOS from samiby you need to create an account.

I have the first gen P8Z77-V board not any of the LX, PRO, etc. I'm not sure if you meant that there is a miniscule revision that added the flashback button to the board but it isn't mentioned anywhere that it doesnt have one on the standard P8Z77-V, but I assume you meant the later boards where the flashback button is located at the I/O area. My board at least has one down the very bottom in between the USB Connections, you can locate it in the manuals diagram, it works the exact same as a normal flashback button.

If you are looking for AI Suite 2 it's on the Asus support page but you need to look under windows 8.1 or bellow to see it (I ran it in compatibilty mode just because windows asked).

However I had to flash using the flashback button in order to flash the bios. I could not get the modded bios to flash using ASUS Update in Ai Suite 2, it would take 5 seconds and say succeeded which just like the flashback button if it only does 5 flashes it does not flash, it should take a minute maybe more. I also could not use EZ Flash in the BIOS either, as "Security Verification Failed" came up because it's modded!
The only other way to flash the .cap files and the only way to force flash it is to use the flashback button. You WILL need a USB 2.0! USB 3.0 cant be used, it must be FAT32, keep everything default. The cap file should be renamed to "Z77VB" for the P8Z77-V board, if you have a different variation look up flashback rename guide for the board.
If you dont have luck with this try another USB or you may have to try a different BIOS that is definitelty for your board variation and modify it yourself.

After you know it's working check BIOS and see what shows. If "PATA SS" comes up it means it recognizes it but you cant boot from it. It will come up as "Windows Boot Manager" when it does work and will come up as an option in the boot order. Note that my SATA drive didnt show up in the boot order section anymore but I can still boot from it by manually selecting it.

You WILL and unfortunately have to do a blank install of windows as BIOS wont recognize a clone as a boot option (However it is easy to transfer data across). I'm pretty sure this just applies to this modded BIOS because JayzTwoCents on YouTube is able to clone his SATA to NVMe but on later hardware/software. To do this I did it from a recovery USB drive (which can be USB 3.0). You can either search "Recovery drive" in windows and use windows to create one or use the Media Creation Tool from Microsoft's website (Which I used because Recovery Drive program wasnt loading).

Note the NVMe drive must be GPT! Not MBR. After cloning, it had cloned into a MBR drive and I couldn't do anything with it in the windows install unless it was reformatted. Converting it wont do anything either thats why I had to do a clean format and clean windows install.

Hope this helps anyone looking to do this, was shocked at how fast the drive was even if its not the top of the line NVMe m.2.
Here there are files ...
Brownie12 file :

Samiby file :


[size=undefined]Your Brain [/size]. . . . It's the best tool U can use ! Wink
[size=undefined]Don't FLASH the Bios Mod if You get a Size Alert, You risk a Brick !!! [/size]
Donate to me for my work, click here BDM
Hello guys,

wonderful post - successful flash mod just completed! :-)

Board: ASUS P8Z77V, used brownie12's .cap, BACKFLASH button worked beautifully. Can boot from Samsung 970 EVO 2TB SSD now, sits in 2nd PCIe 3.0 slot (SLI shared with graphics card). Currently, I am running a Sandy Bridge CPU, therefore transfer speed is limited to 1,500MB/s max transfer rate. Will upgrade to an Ivy Bridge 3770K soon, then expecting to double this speed to something close to 3,000MB/s :-)

Kudos to having worked this out, thanks a lot! :-)

habe gefüllt das ganze Internet durchforstet, bis ich hier gelandet bin. Leider komme ich immer noch nicht weiter.

Habe einen Intel i7 3770K, asus p8z77-v deluxe,

habe die Samsung 970 EVO Plus 2 TB PCIe 3.0 (bis zu 3.500 MB/s) NVMe M.2 Internes Solid State Drive (SSD) (MZ-V7S2T0BW)

mit einem Adapter

NVME Adapter PCIe x16 mit Kühlkörper, 6amLifestyle M.2 NVME oder AHCI SSD auf PCIE 3.0 | 4.0 Adapterkarte für Key M 2230, 2242, 2260, 2280 Größe M.2 SSD, unterstützt PCIe x4 x8 x16 Slot

an den zweiten PCIe 16x, SLOT5

windows lässt sich auch drauf installieren, nur Booten geht halt nicht weil sie nicht im BIOS angezeigt wird.

Habe alles versucht was hier geschrieben wurde und leider geht es immer noch nicht. BIOS bekomme ich auch nicht geflasht, wenn ich das über die FLASHTASTE mach blink diese kurz und dann leuchtet sie dauerhaft, zwei verschieden USB-Sticks mit USB2.0 auf FAT32 versucht, leider auch ohne erfolg.

hat noch wer eine idee, das ich von der Samsung booten kann, oder geht nur neues Mainboard.

After trying and failing to flash both Samiby and Brownie’s BIOSes using the Flashback method, I have determined that neither of these BIOSes will work with an ASUS P8Z77-V-PRO board (yes, I tried renaming them to match my specific board).

To solve this, I ended up just making my own modded BIOS using the guide here:, ignoring all the ASUS .CAP specific steps, and inserting the NvmExpressDxe_5 module into the unextracted unmodded .cap in "Compressed" form. (I downloaded the latest unmodded BIOS from here:

I was successful in flashing this BIOS using Brownie's Flashback method, with the only change I made being renaming the .cap file to Z77VP.cap instead of Z77VB.cap to match the naming rule for the P8Z77-V-PRO ( Also, like Samiby, I didn't delete the PcieLaneDXE entry, so the NVMe drive should be readable from any PCIe slot.

So far I've only tested booting from my NVMe drive installed in the top (blue) slot, but using this slot I've been successful in both installing and booting to Windows. CrystalDiskMark shows that I'm getting 3435 MB/s sequential read, and 3078 MB/s sequential write.

The drive I'm using is a WD Black 2TB SN750 NVMe, and is the only drive installed on the computer.

To save you all the the trouble, I've attached my working modded BIOS to this post.

Attached Files
.zip (Size: 4.32 MB / Downloads: 67)
Dear Noxon,

This is true power of information in flesh and blood and how it is valuable in today's world. You have just made me save a few weeks of my time in the least. I am just waiting for my Samsung M.2 NVMe 970 Plus drive to arrive today in order to install into my P8Z77-V PRO. Being a dummy, nevertheless, I feel pretty competent after studying all your links in just in one day. And a particular thank you for the cap file. This unique file saves a few days of my time considering all the study and trials I need to do to prepare it from scratch.

Thank you in person and all who contributed this invaluable thread.
Greetings Everyone,

I have the ASUS P8Z77-V-PRO Mobo and I'm faced with the same issue to get an nvme drive in a pcie adapter to show 
up in bios boot menu to boot from.

I am pretty sure I understand all the steps indicated by "Noxon", that has the same Mobo but was wondering if the step below from Brownie12 is still needed using his Bios File??  
0) Update Intel Management Engine (ME) to Version 8.1 - Downloads on Asus Support Page

I did download and start installing with the ASUS Intel ME update Tool but it's been going for over two hours already - Not Frozen since I still see the moving dots after "updating, please wait...." (See Attched Pic)  and also still able to navigate in windows.  

Any input or replies would be greatly appreciated... :-)

Forum Jump:

Users browsing this thread: 1 Guest(s)