Forum RSS Feed Follow @ Twitter Follow @ Twitter

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Wrong BIOS on the Mainboard?
Good Morning everyone,

I bought a MSI Z87-g45 Mainboard on ebay and tried to install my i7-4770K.
And got nothing, black screen. Just the fans are running on 100%.

At next bought a old intel Celeron G1820 and installed it on my mainboard and it worked.
After installing win10 I tried to figure out which BIOS version is installed.
Now the strange thing:
CPU-Z tells that I have a MSI Z87-G43 mainboard
the BIOS version is V29.1.... from 2012.

I figured out that I bought a OEM board, but the seller doesn’t answer my mails so I cant check the OEM.

Is it possible to flash a newer BIOS? I already tried to update a BIOS version MSI Z87-G43 and MSI Z87-G45. On both i got the same error.
The SETUP Data Map is diffrent between system BIOS and boot BIOS.
if select to boot, the system would be fail to reboot!!!

Thanks a lot

Attached Files Thumbnail(s)

Forum Jump:

Users browsing this thread: 1 Guest(s)
Expand chat
Expand chat
Expand chat

To join us in the community live chat, please register or log-in