HP Nettle2/3 COMPAQ IRIS8 and Acer Aspire E380 Unlocked RETAIL Bios

We finally have some really really exciting news. The battle for these common boards to have stable OC menus, voltage modification, Phenom II support, and a professional retail BIOS has finally come. Our most helpful members banana19 and MrTangoWhiskey have found an ABIT retail BIOS, that successfully flashes to all of the OEM boards mentioned with full control of voltage, OC, and has support for all Phenom I/II proccessors.

So before we get to specifics, a brief timeline on the modding proccess for this motherboard. This has been going on for over a year, and it has taken a lot of support and research to get this board where it should be. We originally started off modifying the HP BIOS for the board. we were able to get overclocking options from it, but the menu was very unstable and items were always floating on the screen. After about 8 months of searching for the solution within the HP BIOS, we realized that poor coding quality in the BIOS was unfixable, and it was time to find the retail fit. I had been doing research on this when a kind member on the forum pointed that this BIOS had all the goods. Its version numbers were similar, it had the same chipset (BIOS donated from ABIT board) and abit has always been known for having overclocking options. With this unlock, we have unlocked what we would see in a retail award bios. The most appealing features are control of AMD Cool and Quiet, Adjustment of CPU FSB, and even setting the voltage and memory timings.

That said, what are you waiting for? Here’s what we need to get started:
1. First, we need to prepare a bootable USB to launch DOS and flash the new BIOS. To do so, download the HP USB disk format tool and install it here

2. Once installed, open the utility and select the USB to format. Below, tick the bubble for creating an MSDOS startup disk. It will then want you to point it to a DOS image folder. You will need to download and unzip this DOS image (do NOT use your own DOS image) here Once it has completed formating your drive, open up the USB in My Computer. Verify that there are only three files on the USB, making sure to unhide protected operating system files in explorer to see them. If you see three DOS files, you are ready for the next phase.

3. Now we will copy over the ABIT BIOS image as well as the flash utility. You will need download AWDFLASH and copy it over to your USB here Once awdflash has been copied over, download the Bios image and save it to your usb from here

4. Once these files have been copied over, you are ready to flash. Reboot windows, and when the BIOS screen comes up hold down Esc and select your USB to boot off of. You will then see a WIN98 splashscreen temporarily flash and you will be in DOS. Once at the prompt, type in the following command:

awdflash M613Z_19.BIN /py /sn /cc / cd /cp /wb /r

Once you type this in you should see on screen the progress of the BIOS flash. When it has finished, it will automatically restart the systen. When it does, tap the delete key to eter the BIOS. There are a couple of this that you will instantly have to do for the best results. Set Smart Fan to Auto in PC Health setup, Enable HPET Support in Advanced BIOS setup, and in the standard setup, MAKE SURE that the floppy is disabled, or it may stall windows for several odd reasons. Out of our four testers, we have all had success with this mod, each on a different board. I was a second tester for the Nettle2 and have a few more words. If you are planning to do this, I recommend backing up windows in case you have to reformat, which wasn’t that bad considering WHS backs up my data. Also, if you hear loud fan noise do not worry. First off, I am the only tester who had this issue, but if you do have this issue then unplugging the rear system fan on the back of the case will instantly make the box silent, and colling isn’t affected. I have also made a work around for solving the fan speed issue, if you need it (which you shouldn’t) then you can hit the support forum. We are ensuring 24hr. technical support for these boards, and by become a member of Bios Mods (free) you can post on the forums with any questions.

Acer Aspire E380 Support
HP Nettle2 Suspport
HP Nettle3 Support (NOTE: ABIT BIOS DOES NOT WORK FOR THIS MODEL. PLEASE USE THE FOLLOWING UPDATED BIOS: here)
HP COMPAQ Iris 8

Thank you all for your support, it has been a long journey for getting this board stable. Thanks to another member freddyz, who has provided screenshots below.

 

TheWiz

42 Responses to “HP Nettle2/3 COMPAQ IRIS8 and Acer Aspire E380 Unlocked RETAIL Bios”

  • Brian:

    Thank GOD… finally there is hope for my OEM HP with its bare-bones ECS Nettle2 bios. Learned the hard way about OEM’s locking their bios… next computer I have will be self-built. Until then, I’m broke… so must deal with what I have. Waiting for the info/download + holding my breath.
    -BT

  • Hey Brian,

    The action has been taking place in the forums, but it makes sense I should add the info here, so enjoy the read!

    Thanks,
    TheWiz

  • BH:

    Will this support Athlon II as well?

  • Yes, Athlon II has been fully tested and reported working.

  • adisak01234:

    where cpu voltage change

  • RM12577:

    This is awesome, I got one of the HP branded mobo’s from goodwill the other day for 25 bucks and it was throwing a fan error and no OC features, this fixed both things, you guys rock for figuring this out and setting up a good process document on it, A+

  • Free Radical:

    Wow. Outstanding achievement.
    Fortune favors the prepared mind.

  • Jean:

    Here, my brand new Athlon II X2 245 do not working!

    Reported on forums and waiting a solution… or soon im buy a new mobo 😛

  • flipylost:

    Hi, this bios would be valid for acer aspire T180 with mcp61pm-am board?
    thanks a greeting.

  • flipylost:

    sorry, the board is mcp61sm-am.

  • andri:

    I just flashed my bios on acer E380 with the abit flash bios and work like a charme. You guys are fantastics. A+

  • juggernaut:

    Sir, that’s an outstanding achievement!! The original BIOS supplied by HP is pitiful, with almost no options at all available. HP Customer support is not very helpful either.

    One more request: could you make that work for the Narra3 version of the board (manufactured by Asus, their model number: M2N68-LA) too? Its specs are identical, with the manufacturer being the only obvious difference:

    http://h10025.www1.hp.com/ewfrf/wc/document?docname=c01357135&tmp_task=prodinfoCategory&lc=en&dlc=en&cc=uk&lang=en&product=3705515

    Original BIOS:

    ftp://ftp.hp.com/pub/softlib/software9/COL21072/pv-55440-1/sp37190.exe

    As a student, I have limited money available for updating my computer and I’d love to be able to upgrade just the CPU instead of buying a new computer.

  • Hey juggernaut,

    We’d love to take a look at your inquiry. We have done some work with this board but we would like you to create a new thread over at the forums. If you have any questions, please feel free to send me an email.

    Chris

  • yoyojobg:

    can the bios flash re reversable?? change it to the way it was before doing this mod??

  • Greysolid:

    Hi, with this bios mod can support 125w CPU for HP MCP61PM-HM (Nettle2) 5.27 motherboard?

    I want to upgrade CPU but I dont know which be better,
    *Athlon 64 X2 6400+ 3.2 ghz 125w or
    *Athlon 64 X2 6000+ 3.0 ghz 125w or
    *Athlon 62 X2 6000+ 3.0 ghz 89w or
    *Athlon 62 X2 6000+ 3.1 ghz 89w

    Thanks in Advance.

  • tayral:

    Hi,

    This bios is it compatible with the followings processors :
    – amd athlon ii x2 250
    – amd phenom 9450e

    Because I install this bios, and i couldn’t boot with this processors.

    Thanks

  • richrx:

    Can someone either direct me to the pages or post the correct modded BIOS to enable Phenom I & II support for an eMachines with the ECS MP81PM-AM Rev 1.0? I downloaded “M613Z_19.BIN” & “abit_unlocked.bin” but am still unsure which of these is for my board or if it is an entirely different BIOS.
    Thanks.
    Rich

  • Zoomzabba:

    Awesome thread, but I’ve found nothing to help my
    Asustek Narra 1.01
    Chipset- NVIDIA MCP61 Rev. A3
    Southbridge- NVIDIA MCP61 Rev. A2
    LPCIO- Fintek F8000
    BIOS- Phoenix Technologies, LTD
    5.02
    O3/06/07

  • It is possible this BIOS may also work with your Narra MCP61, if you are interested in adding it to the support list please visit our forums for a request.

  • Josh:

    I tried to install the BIOS on my MCP61P-HM (Nettle-2) and when I type in the command I either get “Specified file not found” or a list of commands. Please help, I downloaded all of the files from this location and followed directions exactly, I don’t know what’s going wrong.

    • Josh:

      When I enter just the file name I get a colored screen with “File Name to Program:” and the farthest I have gotten from here is loss of keyboard function at “Do You Want To Save Bios (Y/N)”

      • This may be something with the combination of switches/awdflash version you are using, although the one outlined in this tutorial is correct for that motherboard. Please verify and leave us a message on our contact page or in the forums if problems proceed.

    • Hi Josh,

      It sounds like the USB stick may not have the right filename or the file extension may be hidden. Make sure Windows File Explorer is set to show hidden file times and verify the filename of the BIOS image is correct. Also consult our nettle 2 thread in the forums for verification on procedure.

  • Kurt:

    Are these files not hosted anymore?

  • Peter:

    TheWiz I have a Phenom 8550 Will this BIOS support this CPU? Because back in the 2009 post, I flashed my BIOS with that post and not this one. With that BIOS I put my phenom in and nothing starts. I believe some fans go on but black screen. Dose this one support it?

  • Hi.

    I tried to flash BIOS with these instructoins.
    My mobo is MCP61PM-HM (Iris) Rev 1.0A
    Link: http://h10025.www1.hp.com/ewfrf/wc/document?docname=c00907953&lc=en&cc=us&dlc=en#N116

    Flashing went smooth and completed successfully, but right after flashing computer wouldn’t restart. Actually after the restart the fan goes crazy running too fast as mentioned above, and BIOS would not load at all. I can hear a POST sound which is one long beep and screen shows nothing.

    Please help.

    • I would try clearing the cmos with both the red jumper and blue jumper. Sounds like the beep might be indicating a CMOS misconfiguration.

      • I tried that. With unplugged power cable I switched the position of both jumpers, blue and red clear bios/cmos ones. Didn’t change anything. Should I attempt to power on the PC with the jumpers in reset position?

        Thank you.

        • Looks like one of my RAM chips was not recognized by AWARD BIOS? Is this actually possible? I removes the chip and all started working well. Thank you.

          • That’s fantastically strange but not out of the realm of possibilities. Curious to see if re-seating the chip after a successful boot allowed it to start working again.

          • I was wrong blaming it on RAM. It was my PCIe card – not a graphics one. I was using this PCIe card to add a parallel port to my PC which I needed for some reason. At the same time I was using on-board graphics card as my primary one. Now, what happened after BIOS upgrade is that PCIe card was set as primary. As I had a non-graphics card in PCIe slot – BIOS was posting graphics card error – 1 long beep followed by 2 short (which were too close together so I thought it was just one long beep). After I removed the Parallel port PCIe card – the computer utilized on-board graphics card and loaded successfully. I then had to change BIOS settings to force on-board card as primary. Woooh, thanks for your help a lot!

  • I tried that. With unplugged power cable I switched the position of both jumpers, blue and red clear bios/cmos ones. Didn’t change anything. Should I attempt to power on the PC with the jumpers in reset position?

    Thank you.

  • Todd:

    Hey I have the nettle2. Will this open up ahci option in the bios for ssd?

    Thanks for the hard work,
    Todd

    • Hi Todd – I am pretty sure it does but cannot remember off hand. It’s a worthwhile upgrade either way, but I’m pretty sure it has AHCI for you 🙂

  • mel:

    does this support MCP61PM-AM 1.0 Rev.A2 …Phoenix Technologies Ver.6.00 mobo please I would like to know I have a old gateway gt5432 …I added a psu better ram kingston hyper x and graphic card just trying to get my ram working right …timming and voltage…thx

  • NugunsKnight:

    All the links are broken. DB says that “Error (403)
    It seems you don’t belong here!”

  • Harry:

    Harry here from Dayton, Ohio… I’m a newbie and I hope I don’t offend anyone by posting here, but here is where I ventured in search of an answer to a pc question and situation.

    I have a HP a6200n stock Pavilion running Windows Vista Home Premium SP2,that I wanted to replace and upgrade the memory from 2G (2x1GB) pc2-5300U RAM to 4GB (2x2GB)pc2 6400 800MHz using slots 3&4 on the mobo where the previous 2GB was. I swapped out the memory, booted up and got this error message about IRQL_NOT_LESS and decided that I would try to track down the problem of my pc. So I tried each stick in either of the 3&4 slot by itself and no problem.. but when trying to use both.. ERROR..And when I tried slots 1&2 the computer just lay there totally lifeless nothing running.

    I found that I have the ECS MCP61pm-hm 1.0b (Nettle2) motherboard and I found your forum about BIOS flashing, which I thought might solve my problem.. So, like a newbie, I flashed the old phoenix bios per the instructions given (of course without doing any kind of backup)and it didn’t help with the memory problem, but it did change the report from the program CPU-Z that my motherboard was now identified as an NF-M2S from Abit..

    I cleared the CMOS by moving the pin connector on the mobo AND also by removing and reinstalling the battery.. and.. DOOM arrived.

    I figured that maybe I’d have to do a full pc recovery of my machine and broke out the recovery disks but then it just went downhill

    When Vista attempted to run it asked for the Activation Product Key… so I dug around the web to find out how I would find that on a HP with prepackaged software and recovery disks.

    I entered what Microsoft’s Help Desk said was valid, but it kept getting rejected and the recovery disks were useless since I found out that any changes to the system or mobo that change the identical code that the recovery needed, automatically stopped the computer from recognizing the computer..

    So for now, all I want to do (if it’s even possible) is to flash my bios back to the original bios that came with the computer and try another avenue of figuring out why my memory upgrade wouldn’t work..

    My Question Is: HOW do I flash this monster back to the factory bios program?

Leave a Reply

*